Floppy Drive not working properly

By ATILLA ยท 5 replies
Jul 16, 2002
  1. Hello Everyone.
    J'm facing a serious problem with my Floppy Drive.
    The thing is that when j try to copy something to a floppy disk j get a lot of Blue screen's of death, which say:
    "Disk write Error"
    "Unable to write to the disk in drive A:"
    "Data or files may be lost."

    Somethimes j receive and windows error messages like:
    "Cannot Copy"
    "The disk is write protected."
    "Remove the write-protection or use another disk."

    Says about the write protection but the disk is not write protecded at all???
    J tried 15 diferenet floppy disks like "Verbatim", "Sony", "Basf" and in every case it's the same thing, errors all the way. J tried these floppy disks on other PC and they work fine.
    J tried to clean the Floppy Drive but it didn't help at all, j tried to change the power cable, and the FDD cable, but still the same thing???
    At last j bought a new NEC Floppy Drive and j thought that my misery is over, BUT STILL THE SAME ERRORS AND BSOD'S.
    Next j tried to re-install Win98-no good, then tried with Win98SE-no good, and at last with Win2000Pro-no good.

    PS:MY MASHINE>>> PII300Cel A/ 160MB SDRAM/QUANTUM FB. 5.1 GB. HDD/ SB CREATIVE AWE 64 GOLD/ MB PC CHIPS M715 (i440 EX/LX chipset>> know it's old)/ PSU 250W. Never tried, but is it possible that it might be the PSU ???:confused:
  2. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    well i couldn't spend too much time because i am on my lunch break right now, but since you have replaced the drive and are still having problems, I think its one of several things:

    -Your operating system has corrupted floppy controller drivers. Try reinstalling them through device manager. The drivers are on your OS CD.

    -Your actually FDD controller on the motherboard is fried. Short of replacing the motherboard, or buying some IDE PCI controller board just because it has an extra FDD controller on it, you may have to switch to an LS120 drive which is an IDE device but read normal floppies plus high capacity 120MB disks as well.

    -Did you try replacing the floppy cable?

    ATILLA TS Rookie Topic Starter


    Did try switching the power cables form the PSU, but no good, and about the cable, j'm working on the FDD cable right now.
    J'll try with the controller drivers.

    Thanks man :)
  4. vassil3427

    vassil3427 TS Rookie Posts: 640

    ATILLA go into your BIOS under the Standard settings and make sure Floppy Drive A: is set to 1.44MB 3 1/2" . I recommend this because a friend of mine could not get his floppy to work he bought 2 new drives and still couldnt get it to work, all it did when you clicked on the floppy was bring the bright blue screen or bring up tons of errors, in the end it was the fact that somehow in the BIOS it was changed from 3 1/2" to None....I hope this helps you:)
  5. gudboyph

    gudboyph TS Rookie

    Floppy Drive Error: Cannot Save File Disk is Write-Protected

    :rolleyes: hey i think i got the same problem....i tried a saving/deleting/formating floppy but the same error occurred
    I tried it on dozen floppies and nothing worked...I was advised to try cleaning the drive but it didnt work.....The thing is I am able to copy files from the floppy without any problems...just when I try to save or delete a file the error shows up ....
    ATTILA...wer u able to solve your problem? do i have to replace my motherboard?
    email me plz... gudboyph@yahoo.com
  6. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Have you set the floppies to be writable? There is this hole you can fill with a switch-like thing or chewing gum/duct tabe when the switch is gone.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...