FTP Stopped working

By k1wmq ยท 7 replies
Dec 31, 2006
  1. Running a Win2000 machine - following a Memory Dump, my network card quit.
    Installed a new card, reloaded drivers and ran RegClean. My network card came back OK - email and HTTP working fine but I cannot FTP to any of the sites I maintain. As soon as I try to connect I get a connection refused on Port 21. I normally use AceFTP but I've also tried SmartFTP and others and get the same result. With the free ftpcomm program I can get to the remote site and download a file but cannot upload back to the site. I tried a command line FTP and tried to send a "bin" file with hash marks set and got a connection refused there as well. RegClean does show some FTP entries such as: [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\sfFTPLib.FTPConnectionInfo\CLSID]@="{FBF8CDD4-BDD5-4B31-8890-AAC1DAB97BB4}"

    I'm afraid if I reverse the RegClean work that I might lose the network capability altogether again.

    Any ideas (please)??


  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    What kind of a software firewall do you use? Any chance it is a "user friendly" program like Zone Alarm or something Norton? Try disabling.
  3. k1wmq

    k1wmq TS Rookie Topic Starter

    Yes, I'm using Zone Alarm. I also have a Speedstream 4100 DSL Modem feeding a Linksys BEFSR81 8-port router. No changes have been made in any of the above.
  4. k1wmq

    k1wmq TS Rookie Topic Starter

    FTP Stopped Working - Additional

    I have a Debian Linux box on the same LAN and am able to successfully do a command line FTP from there to the same site that I can't reach from the Win2K machine so that pretty much eliminates the Router & Speedstream.
    On the PC, ZoneAlarm shows the earlier attempted command-line FTP going through unblocked so I don't think it's a Firewall issue.
  5. jobeard

    jobeard TS Ambassador Posts: 11,171   +989

    immediately after connecting, issue pass or passive
    then follow with ls.

    if you get the directory listing, you will be able to get/getm and put/putm
    as well.

    Passive tells the server to NOT use port 21
  6. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Passive tells the server not to initiate a file transfer connection and wait for a connection from the client instead. Dropping the already existing port 21 connection would be just silly.
  7. k1wmq

    k1wmq TS Rookie Topic Starter

    From the PC, I don't get connected at all. I'm immediately given a can't connect message. It only works brom the Linux machine.

    Also, when I do a netstat -an I don't see port 21 listed at all when I believe it should be listening. Doing an ipconfig /all shows IP routing enabled. I went into the router and tried changing the mtu from 0 and disabled to 1492 and enabled. Didn't make any difference.
  8. k1wmq

    k1wmq TS Rookie Topic Starter

    FTP Stopped Working - Additional

    Got it working!! It was a firewall issue. Although ZoneAlarm didn't show it blocking my AceFTP program it never showed it passing it either. I turned off ZoneAlarm and it still didn't make any difference. I installed Comodo free FW software and let it run while it learned everything. It never showed any AceFTP activity when I was attempting to run it. I added AceFTP to the list allowing Port 21 to any IP and AceFTP can now connect to all my maintained sites. Thanks for the time you took to try to help.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...