Gallery suggestions and problems

By dani_17 ยท 13 replies
Sep 7, 2003
Post New Reply
  1. Hi there,

    The new gallery looks great!

    But, it's not working at least for me. I get the next error when I try to upload a picture:

    Problem running command: "/var/www/html/gallery/jpegtran/jpegtran" -copy none /var/www/html/gallery/data/501/1343mini1.jpg

    Error Code: 126

    I don't know if this is because you are modifying the scripts now but just let you know.

    And a little suggestion:

    When you enter the description of the foto, the text area is very small. Maybe you could make it bigger and put a smaller font. It's a bit uncomfortable to wirte in such a small box, and there is plenty of space to use in that form.

    Keep going Techspot!, Techspot!, Techspot! :D
  2. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    We are aware of this issue. It is being sorted out as quickly as possible. Please be patient :)
  3. dani_17

    dani_17 TS Rookie Topic Starter Posts: 146

    No problem! If theres something I can help, just tell me and i'll try.

    My guess is that you are having the problem saving the file to the folder, due to file permissions, quota or similars....
  4. Julio Franco

    Julio Franco TechSpot Editor Posts: 7,667   +987

    I believe I got the problem fixed now, please try uploading again :)
  5. dani_17

    dani_17 TS Rookie Topic Starter Posts: 146

    It's working great now!
  6. dani_17

    dani_17 TS Rookie Topic Starter Posts: 146

    Gallery Quick Note


    Just a quick note.

    In the gallery I can't edit my photos. I made a mistake and didn't choose to put the picture in any category. So now I go to the edit photo form and when I change category and submit the form I get a "You don't have permission" error. Yes, I'm logged in :p
  7. StormBringer

    StormBringer TS Maniac Posts: 2,244

    I can no longer view images in the gallery. All of the images are broken. I know it is my firewall software causing this, since I can view it fine if I shut it down. Shutting it down is not an option I want to consider. I am fairly certain that the built in ad blocker is treating the links as ads, though I can't seem to find the string used by the images in the gallery in the rules list. If anyone knows how to fix this without disabling the software I would appreciate it.
  8. StormBringer

    StormBringer TS Maniac Posts: 2,244

    Update: I tried using this 2000/Me/98/XP&src=&pcode=npf&svy=&csm=no
    unfortunately it did not solve my problem.
    Not that anyone has bothered to help anyway, which I find odd, seems like someone would have offered some suggestion by now.
    but I can now assume that some rule in the firewall software is to blame for the gallery not loading for me. Disabling NPF is not an option and changine firewall software is also not an option since I don't like throwing money away. If no one can help then I guess I will just be unable to view the gallery. It is unfortunate for me and for anyone else who may have this problem.
  9. XtR-X

    XtR-X TS Rookie Posts: 863

    Check the npf thread you posted, StormBringer,

    You're welcome.
  10. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    I have some suggestions

    Been thinking a little bit and discussing in the IRC channel and have came up with the following suggestions:
    Toss a link in the grey bar at the top of the main page and forums, rather than the little blue one below it.
    Add a catagory to the Gallery called Random for us to post just some random pictures, maybe make that just a temporary area where they get purged after a certain amount of time to keep from taking up too much space.
    Also maybe try to bump up looking into this firewall on your list of things to get done, I know you got other things that are probably more important, but its not real convienient to turn off my firewall every time to view(I see XTRs solution, but there might be something on the server end?)
    And nobody better reply telling me that its not that big of a deal, I'm currently the 2nd highest picture poster there, and I do try to comment or at least rate the ones I check out

    This one is less for Julio and more for us:
    Participate! Some of the pictures are pretty cool that are up there, there are also many pictures with over 50 views and no comments, its not real hard to make a comment and positive comments when people look at a picture encourages more people to post some.
    TS hosts those pictures so you don't need your own webspace to put pictures up there.
  11. wicka_wicka

    wicka_wicka Banned Posts: 125

    No comment on the error, I just wanted to say I'm happy to see that the server runs *Nix.
  12. Julio Franco

    Julio Franco TechSpot Editor Posts: 7,667   +987

    Thanks for the suggestions.

    I have now added a "Random Stuff" section "For you to post any interesting or funny stuff", I have deleted those two other sections that were left untouched in all this time and going to promote the random section in the frontpage, hopefully will bring more people and overall attention to the gallery although we are doing quite fine as it is right now.

    As for the firewall problem, I have explained before that the cause of this is most likely server side protection I have enabled so that pictures from the gallery can't be used or called from outside websites (stealing our bandwidth), perhaps we could do without this protection but we would be taking such risk, what do you guys believe I should do?
  13. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Actually NPF has recently caused me a bunch of problems, I think the install has become corrupt because now enabling specific programs full access it still blocks them, today it started doing that with Outlook. So until I have time to really look into it I have disabled it and will just use XPs built in firewall.
    So I think you should just leave it as is, its not bothering me anymore and XtR did have a workaround.
  14. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    I keep getting errors like this:

    MySQL error reported!

    Query: SELECT id FROM photos WHERE date > 1074125082 ORDER BY disporder,lastpost DESC

    Result: Table '' doesn't exist

    Database handle: Resource id #11

    I just browsed photos from the last two weeks and tried to click them / their comments.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...