GeForce 3 problem

By Gamer ยท 6 replies
Apr 17, 2003
  1. GeFoerce 3 problem

    Hi guys!
    Recently I have upgraded my system. I kept the same graphic card (GF3) that worked perfectly good on my previous system (P3 based). After the upgrade, I started experiencing problems with games (Morrowind, The Thing) and 3D Mark 2003. Graphic is good, frame rate as well, but over the sudden I would be kicked out from the game, straight to Desktop. I am using DirectX 9, Win98SE (w/ IE 6) and I have tried various drivers for GF3, starting from (the most stabile) 30.82 to the latest ones available at NVIDIA site. Also, I played with BIOS settings, but no remedy. Anyone has idea what may be wrong?

    My current system is:
    Intel P4 2.4B, ECS L4S8A2, 512 Mb RAM, VisionTek GeFORCE 3 (original), Creative Live, WD 40Gb 7200, Pioneer DVD, Teac CD-RW
  2. Arris

    Arris TS Evangelist Posts: 4,730   +379

    Welcome To TechSpot forums

    What Power supply do you have in there?
    Often the PSU is overlooked when building a system. I'd say that a PSU of 300W or over from a well known brand such as Enermax or Antec would be needed for the combination of a Power hungry P4 and GF3 card. That would be my first thought. Also have you reinstalled the operating system since you changed from P3 to P4?
  3. Gamer

    Gamer TS Rookie Topic Starter

    My PSU is Antec 400W. Together with other components I bought a HDD, so it was brand new, I formated it and had a clean install.
  4. Arris

    Arris TS Evangelist Posts: 4,730   +379

    Ok so we can rule out the PSU being the problem.
    Do you have sideband addressing enabled in your BIOS for AGP? And what size is AGP aperture. Sometimes these can be the cause of lockups/crashes.

    try Geforce FAQ Gold for more information regarding Geforce problems. Usually the Geforce FAQ link in my signature is good for sections about particular problems but the site is having problems just now :(

    The only other thing I can suggest is to use one of the tools available for completely removing detonator drivers before loading a new one. Uninstall the driver, set to Standard VGA driver, use tool (such as Detonator destroyer available at ) to remove any files which remain. Reboot, then install new detonators.
  5. Gamer

    Gamer TS Rookie Topic Starter

    BIOS does not have the SB enabling option. I tried several settings for AGP aperture size - 64, 128, 256. 64 and 128 worked about the same. With 256 I got flashing screen when using 3D graphics.
    I am going to check the links you sent. I may find some answers.....
  6. dienesmark

    dienesmark TS Rookie

    need help from gamer

    I just got a ECS L4S8A2 really cheap.

    Trying to build a new PC piecing it together piece by piece. (not much money at this point in my life)

    I do not have an AGP card only several PCI VGA cards. I can not get the monitor to get any signal from any of the PCI video cards (that I know are good) and do not get any beep error codes.

    Since you have the ECS L4S8A2 board and have worked with it does the BIOS default to AGP video. I cant find much on this board for help and anything from ECS is no help.

    Thanks for any input.
  7. Steg

    Steg TS Rookie Posts: 269

    when this happens (quit to desktop i mean) run dxdiag instantly if D3D doesnt work then i have had the same problem. There is a major bug in 98 somewhere that causes this to happen alot - i upgraded to 2k and the problem went away - i think its using new DX versions and old 98 but im not sure

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...