Geforce 6800 give Direct 3d error

By Superczar
Aug 17, 2005
  1. I picked up a Geforce 6800 from an acquaintance yesterday.

    After plugging in the 6800, when I started my PC, I got 1 new hardware pop-up for VGA device as expected, however, I also got H/W device pop-up for "System Interrupt caller " :blackeye:

    I installed the drivers from the accompanying CD ( I think forceware 71.25)
    However, System interrupt caller is still showing up as a uninstalled device in my device manager

    Then as soon as I tried to start UT2003, I got an error message saying "Error creating Direct D3D device etc.etc."
    Halo also returned a similar error (Hardware acceleration not enabled)

    When I ran Dxdiag (DX 9.0c), Direct draw worked fine, however, Direct 3d acceleration tests returned the follwoing error:

    "Test failed at step 8: Creating 3d device; Hresult=0x887602eb"

    the AGP texture acceleration tab says disabled

    With my old fx5200, all these games were running perfect albeit with low FPSs (obviously)

    The system is XP 2400+ with 512 MB RAM (Hynix 400 mhz) running win XP Pro

    The Mobo chipset is Via KM333
    I tried upgrading the Via Hyperion drivers, but no-go....The v71.25 drivers (hat came with card was working fine for kev, nevertheless, I'll try the new version tonight....but I doubt if it is going to fix the issue)
    Any pointers?
  2. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 966


    What video card did you have prior to the 6800?
    Make sure you un-install all video drivers before.
    Guru3d has a good nVidia un-install guide.
    Try the drivers HERE
    From TS
  3. Superczar

    Superczar TS Rookie Topic Starter

    I had a nVidia fx5200 whih was working perfectly fine....
  4. Jamie20.03.93

    Jamie20.03.93 TS Rookie

    Hardware acceleration

    In order to enable hardware acceleration right-click on desktop and from drop menu select 'properties'. then select the 'settings' tab and click 'advanced',select the 'troubleshoot' tab and move the hardware accelerartion slider as far to the right as possible and tick the 'enable write combining' box then click 'ok'
    ;) hope this helps you to solve ur problem!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...