Getting a fake usb drive to work

By meerubus
Nov 18, 2005
  1. I bought a 2G & 4G SONY usb flash drive in Beijing China & at 1st they worked partially ie. can only copy up to 50% & then files get corrupted. So I tried formatting them & after several rounds of formatting (FAT & FAT32), they all "died". When I plug them in, the PC recognise them but their capacity is ZERO bytes!!! Nothing I do can get them to work.

    Can any offer any advise?

  2. zdrave

    zdrave TS Rookie

    Same thing

    The same thing happened to me! After I investigated them for some time I found out that they are not even made by SONY. I have still been trying to solve the problem but nothing so far. If anyone has a clue or a bit of info it would be great!
  3. weesteev

    weesteev TS Rookie

    If you are getting this kind of error with a removable storage device then it points to the hardware. Poor quality equipment causes this and if you have this kind of problem then it would seem the flash stick has failed.

    Try running a scandisk on the drive or a virus scan to see if it can pick up the FAT, apart from that take it back to the retailer or get in touch with the manufacturer.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...