1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Getting a shared partition recognized.

By TKJay15
Jun 25, 2006
  1. I created a Fat32 partition in order to share files like Mp3s and photos between my two different OS's, Windows XP sp2 and Fedora core 5. The windows partition recognized the Fat32 and i can write and read to it but the linux partition doesnt even see it. I have read some stuff on it but i was wondering how do i get the linux partition to see the Fat32 patition so i can read the files off of it. Thanks alot for any help.
  2. WinDoWsMoNoPoLy

    WinDoWsMoNoPoLy TS Rookie Posts: 252

    Open a terminal and log in as root. After each thing i say ill tell you the command.

    (will ask for password, enter it)

    Now you will enter a command that will display your current partitions.

    df -h

    df doesnt stand for anything, just a command, but the -h means human-readable.

    Notice the partitions are HDA1, HDB1, ect. HD means harddrive if they're SATA drives it will be SDA, A is just like a number so its HD number 1. And 1 is the partition number.(Some people are clueless to this....) So you will pick the drive you are adding out of the results out of that command.

    Now you need to mount the partition. For the linux newbie a mount is simply a shortcut. First we need to make the dir for it. So...

    mkdir /dev/hda1

    HDA1 is an example of course.
    Now we have to add a line to the fstab file.

    gedit /etc/fstab

    You will get results similar to this:
    LABEL=/ / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    LABEL=/export /export ext3 defaults 1 2
    none /proc proc defaults 0 0
    none /dev/shm tmpfs defaults 0 0
    /dev/hdb2 swap swap defaults 0 0
    /dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

    Now you will simply add the line relevant to what your partition is. So say:
    /dev/hda2 /newpartition vfat defaults 1 2

    Whatever you put as what i put newpartition will appear mounted in / which is what you see when you double click filesystem. VFAT is linux for FAT32. The digits "1 2" refer to whether the mount point should be backed up when the dump command is used and disk integrity checks using fsck. The "1" states that it should be backed up when the dump command is issued (0=no). The "2" refers to the order in which "fsck" should check the mount points. The digit "1" identifies the root ("/") of the filesystem. All others should be "2". (0=no check)

    After that, one more command.

    mount /dev/hda1

    Reboot and your partition is mounted.
    I had to look up a few things that i couldn't remember haha. Been awhile since i've been on Linux.
  3. TKJay15

    TKJay15 TS Rookie Topic Starter Posts: 29

    When i installed the updated to the system i was able to see the partition SHARED, the one i wanted to use to share files, but it was under the Computer folder not in filesystem. So now under i have my dvd drive, File system, 128.0 GB volume (which i assume this is windows since that the size of my windows partition), SHARED (the shared partition), and Network. Im not sure why these appeared after the update but they are there, the only problem is i cannot access either the 128.0 GB volume or Shared it gives me the error:

    Cannot mount volume you are not priviledged to mount the volume "SHARED".

    Also, i tired the method you said and followed it but when i tried to create the directory under /dev it said this already existed so i couldnt make it. So i went into the /dev folder and found the /dev/sda2 and tried to access it but i also cannot access it because it gives me the error:

    Cannot Display /dev/sda2

    Another thing i noticed is when i ran the df -h command as root it didnt have the partition sda2 in the list it only had this:

    [root@localhost Jay]# df -h
    Filesystem Size Used Avail Use% Mounted on
    20G 3.5G 15G 20% /
    /dev/sda3 99M 16M 79M 17% /boot
    tmpfs 500M 0 500M 0% /dev/shm
    /dev/sdb1 252M 52M 201M 21% /media/disk

    now im not really sure why it isnt showing the partition. Thanks alot for all the help so far hope i can make heads and tails from this eventually haha.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...