Getting Red Alert to work on XP Home

By leem ยท 19 replies
Oct 22, 2004
  1. I just foundmyold copies of Red Alert and Red ALert 2. I want to put them on my now XP-Home computer. The problem is Red ALert only owrks on 95 (according to the pop-up box during installation). When I try to install Red ALert 2, it says I have the wrong ..crap brain fart. Well, it won't let me install that either.

    Any suggestions?
  2. jstillion

    jstillion TS Rookie Posts: 91

    Right Click on the setup.exe (or the install program) on the cd.
    Choose [Compatibility] Tab
    Put a check mark in [ ] Run this progarm in compatibility mode for:
    Select Windows 95 in the drop down box, hit [Apply], then [OK].

    Then try to install it again.

    You may want to try this downloading and installing this:
    Windows Application Compatibility Toolkit 3.0

    It will not allow you to install the game (do fix above) but it may fix issues with playing the game, or other older software.
  3. Justin

    Justin TS Rookie Posts: 942

    If you browse the CD contents using Explorer (Winkey + E) you can set the compatiblity mode using the same method above for the setup program (Will be called SETUP.EXE or SETUP). I have Red Alert / CS / AM on an XP Pro machine, and that's all I needed to do. This should work for you.
  4. leem

    leem TS Rookie Topic Starter Posts: 73

    It works! It works!

    Thank you do much! :hotbounce
  5. greenmuney

    greenmuney TS Rookie

    it still doesnt work for me!

    :( I tried doing all that and when i try to install ra it still says: C:WINDOWS\SYSTEM32\AUTOEXEC.NT. The system file is not suitable for running MS-DOS and Windows Microsoft applications. Choose 'Close' to terminate the application.
  6. Angelus

    Angelus TS Rookie

    On the internet (other forum) I found the following message to work nicely:

    Autoexec.nt is a text file, probably some virus or spyware has deleted, hidden it or corrupted it. Either create a new one in notepad and enter following text :

    @echo off

    REM AUTOEXEC.BAT is not used to initialize the MS-DOS environment.
    REM AUTOEXEC.NT is used to initialize the MS-DOS environment unless a
    REM different startup file is specified in an application's PIF.

    REM Install CD ROM extensions
    lh %SystemRoot%\system32\mscdexnt.exe

    REM Install network redirector (load before dosx.exe)
    lh %SystemRoot%\system32\redir

    REM Install DPMI support
    lh %SystemRoot%\system32\dosx

    REM The following line enables Sound Blaster 2.0 support on NTVDM.
    REM The command for setting the BLASTER environment is as follows:
    REM SET BLASTER=A220 I5 D1 P330
    REM where:
    REM A specifies the sound blaster's base I/O port
    REM I specifies the interrupt request line
    REM D specifies the 8-bit DMA channel
    REM P specifies the MPU-401 base I/O port
    REM T specifies the type of sound blaster card
    REM 1 - Sound Blaster 1.5
    REM 2 - Sound Blaster Pro I
    REM 3 - Sound Blaster 2.0
    REM 4 - Sound Blaster Pro II
    REM 6 - SOund Blaster 16/AWE 32/32/64
    REM The default value is A220 I5 D1 T3 and P330. If any of the switches is
    REM left unspecified, the default value will be used. (NOTE, since all the
    REM ports are virtualized, the information provided here does not have to
    REM match the real hardware setting.) NTVDM supports Sound Blaster 2.0 only.
    REM The T switch must be set to 3, if specified.
    SET BLASTER=A220 I5 D1 P330 T3

    REM To disable the sound blaster 2.0 support on NTVDM, specify an invalid
    REM SB base I/O port address. For example:

    My Red Alert wouldn't install on my Windows XP. After I did this, I actually COULD install it. Thanks you, mister Peter Hutchison ! : )

    Good luck with installing RA1,

    Angelus - NL
  7. Silentnite

    Silentnite TS Rookie

    Red Alert on XP

    I managed to install the program fine with no problems at all however when I have tried to run the RA95.exe within the red alert directory and get an error message saying...

    The procedure entry point SMapLS_IP_EBP_12 could not be located in the dynamic link library KERNEL32.dll.

    Can ANYONE help me ??? I hope so , i was really looking forward to playing C&C:RA again!

    Oh and by the way i have WinXP:HE and ive tried the compatability thing too.

    PHILXBOX TS Rookie

    red alert 2 help

    ive bought a copy of red alert 2 and having problems installing it. It has worked before with EA games but i lost it,uninstalled it and bought a sold-out version. anyway just after i click agree to lincence terms a message appears saying :

    Setup.exe has encountered a problem and needs to close. We are sorry for the inconvenience. Like when a program crashes. In then error report it says that there is somthing wrong with setup.exe i have tried for months to try and fix it email loads of forums and even sold out itself.:confused: :confused:

    PHILXBOX TS Rookie

    help me please
  10. dreambox

    dreambox TS Rookie

    have problems with installing this game. when i hiy install button in meny i only get the message that says it hase to close. have tried all the stuff over, but it doesnt help.

    when i use the exp pack it works fine, hit the install button and it goes to another page and asks for red alert 2, and both these disks is the same system, so why wont the ra cd work? tired for using so many hours to get the game working. it is stupid. some found a solusion?
  11. mariuslegrand

    mariuslegrand TS Rookie

    same here, when i hit the install button it just freaks out and says: setup.exe has got an error or something like that, and then it's gone :(
  12. Surr3al

    Surr3al TS Rookie

    My friend and I had the same problems, and compatibility settings in properties wouldn't fix the prob.

    We found in another thread that downloading an updated safedisc driver fixes it, and it indeed did, for both of us.

    Here is the link:
  13. Spaq

    Spaq TS Rookie

    Wow...thats' all I have to say..

    I spent so much time on this and I finally got it. Moto of the day don't give up! Anyways...Just go to this link ( and if this doesn't work then go to Start/All Programs/Accessories/Program Compatibility Wizard. I guarantee one of those two things will get it working.

    Thanks Everyone!!
  14. AC_Tex

    AC_Tex TS Rookie

    yea, ditto

    done eveything on here.. none of it works, and i get eh same message as this guy

    "The procedure entry point SMapLS_IP_EBP_12 could not be located in the dynamic link library KERNEL32.dll."

    pretty pretty please somebody help...i got DOS version to work but without sound or proper resolution... none of my other games will install on this piece of crap...reformatted 3 times.. new disk drive, i'm bored out of my mind without games to play, lol
  15. ruscou

    ruscou TS Rookie

    I also tried everything i read on here, to no avail...however i knew it could work on xp pro because i had it working when i first installed xp pro. so what happened? I installed sp1 !!!! After that I could not make it work. So on my other computer I reformatted and didn't install any service pack and Red Alert 2 works fine. I just rarely go on the www with that computer now.
  16. iLag!!!!!

    iLag!!!!! TS Rookie Posts: 18

    If you're trying to use the DOS version, try using DOSBox. It's a DOS emulator which works great. I played Star Wars: Dark Forces using it not to long ago, and it played just like it would on a real DOS OS.
  17. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Good idea without having Service Pack 3 installed !
  18. NodGod

    NodGod TS Rookie

    Red Alert 2 Working with XP SP3

    I somehow managed to install from the CD without using compatibility mode and when I set compat mode on the shortcut all I got was a Red Alert splash screen and nothing else.
    Here is what fixed it for me.
    Open My Computer
    Click Tools
    Click Folder Options
    Click the View Tab
    Scroll all the way to the bottom and unclick Use Simple File Sharing
    Now Right-Click the Desktop Short-Cut and go to Properties and you will now see a security tab
    Click the Security Tab
    Now select Everyone from the list and give them full control.
    Now click OK.

    That's all it took to work for me.
  19. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Note the Security tab is not normally accessible by Xp Home in Normal mode
    Users will need to go to Safe mode to access this
    Xp Pro users do not have this issue


    How to show the Security tab in XP Home

    Download Show_Security_Tab.reg

    To use this file:
    • It is always recommended to backup the registry first
    • Save the file Show_Security_Tab.reg to your computer
    • Merge (Double click) on the file
    • Click Yes
    • Click OK
    The Security Tab is now visible Xp Home

    It is recommended to return the registry entry back to normal
    This is because some programs (when installing) may fail

    Download Hide_Security_Tab.reg

    To use this file:
    • Save the file Hide_Security_Tab.reg to your computer
    • Merge (Double click) on the file
    • Click Yes
    • Click OK
    The Security Tab is now hidden again in Xp Home
  20. sokkasta

    sokkasta TS Rookie

    Hi there. has anybody had the sam experience as I have?

    I installed Red alert 1 then apply the XP Patch (1.08) then When I wanna play multiplayer against a mate, the Network button is gone.

    How do I fix this?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...