Gigabit Lan on Asus A7n8X-E not registering.

By Ironbasher ยท 45 replies
May 30, 2004
  1. My A7N8X-E Deluxe MOBO has 2 Ethernet ports - a 10-100, which works perfectly, and a GIGABIT port supported by A Marvell NIC chip which has never been recognized during hardware detection and doesn't even register in the Device Manager panel.

    I have tried the enable jumper on the MOBO in both positions, just in case they got it wrong in the book, but to no avail.

    I installed the Yukon miniport driver that came with the MOBO and got an OK that the installation was successful - but that had no effect on anything.

    Any suggestions, or do I just have a faulty NIC chip? All suggestions gratefully received - especially one that works!
  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Any chance there is an option in the BIOS to enable the gigbit ethernet controller?
  3. Ironbasher

    Ironbasher TS Rookie Topic Starter

    Curiously, the BIOS has no mention of the Marvel Gigabit port although the Ethernet LAN and 1394 supported by the onboard nVIDIA chipset (both work perfectly) can be individually enabled/disabled. The Gigabit is the only I/O port to be ignored by the BIOS in this way.
  4. Ironbasher

    Ironbasher TS Rookie Topic Starter

    Further to my original posting, has anybody ever managed to get the Marvel Gigabit LAN to work on an A7N8X-E Deluxe? I refer to the later MOBO version with the Marvel NIC and not an earlier version that used a 3-Com NIC. Any observations or suggestions would be most appreciated.
  5. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Is the jumper on the board properly set ?

  6. Ironbasher

    Ironbasher TS Rookie Topic Starter

    Yes, I have tried the jumper in both positions just to be sure (see my original posting). I am also sure it was the right jumper!!!
  7. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Any unknown devices showing up in the device manager ?
  8. Ironbasher

    Ironbasher TS Rookie Topic Starter

    No, everything else is OK. Also, the Integrated Peripherals BIOS page I see on the monitor agrees exactly with that shown in the MOBO manual - that is, no mention of the Gigabit Lan although every other port, including the onboard nVidia Lan is listed there with the option of enable/disable.
  9. Shiney

    Shiney TS Booster Posts: 160

    I have the same board and i am using the marvel lan, the onboard nvidia lan is disabled.

    I installed from the cd then updated to the new driver ie
    23/04/04 ver

    No problems yet :)

    good luck
  10. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    If nothing works it could indeed be that the NIC is shot. I suppose it's still under warranty.
  11. Ironbasher

    Ironbasher TS Rookie Topic Starter

    I tried disabling the nVidia Lan in the BIOS, although I would have thought both should work together. Anyhow, still no effect.

    I have been assuming that the Gigabit LAN was backward compatible with the 10/100. I know all 8 wires are used for the Gigabit LAN and only 4 for the 10/100, but it was my understanding from various stuff I have read that given a 10/100 at the other end, the Gigabit terminal could work this out for itself. I don't have another Gigabit device here so I was just trying to get the Gigabit port on the MOBO to work with either another computer with a 10/100 port or my ADSL modem - which has a single 10/100 port. The intention was to use the dual LAN capability of the ASUS MOBO to share the Internet connection between my 2 PCs.

    But even if my assumption concerning backward compatibility is wrong, why doesn't the presence of the Marvell Gigabit controller show up somewhere? It is not to be found in the Windows XP Hardware Device Manager nor is it reported by the Sandra monitoring software - and, as I previously mentioned, is conspicuously absent from the main BIOS. Perhaps Shiney could tell me if his Gigabit controller advertises its presence anywhere - even if the LAN is disconnected.

    In any event, thanks for the suggestions.
  12. pericon

    pericon TS Rookie

    I too am having the same problem with getting winXP to reconize the marvel driver for this board. My symptoms are exactly as stated by Ironbasher. I have noticed that windows does display a "1394 NET ADAPTER " under net adapters in system properties. This adapter uses a microsoft "miniport" type driver which is similar too the miniport driver supplied un the marvel/yukon driver set. I tried to update the 1394 net adapter using the marvel driver but windows refuses to load them reporting that cuerrent driver is is the closest match.
    The gigabyte lan cannot be turned on or off in the bios it is activated by the jumpeer onboard ,but the Ieee 1394 device is switched in the bios. I tried uninstalling this net adapter and turning off the IEEE 1394 device in the bios and also disconnected the cables from their sockets but the gigabyte lan adapter is still not being reconized by windows.
    I think windows is confusing the IEEE device for the gigabyte lan adapter.
    How can I force windows to accept the marvel drivers in place of the microsoft drivers for this device?
  13. osucowboy

    osucowboy TS Rookie

    I also have the A7N8X-E Deluxe board, and have both network ports installed and working. HOWEVER, every once in a while when I reboot, my Marvell adapter is not working and is "re-found" by WinXP (Pro). XP will not find the driver, but if I reinstall it from the disc it works fine (I just have to reboot again after reinstalling). Side note: after reinstalling the driver, the version of the driver is the same as Shiney's (, so I'm pretty sure I've got the most recent driver.

    My opinion on Ironbasher's problem, it's a bad NIC, RMA the board. I'm wondering if it's the same with mine, but mine is just periodic, not constant.

    As far as backward compatibility, the Marvell adapter should work fine without any tweaking on any network, it just adds the ability for the faster transfer.

    The thought by pericon that the computer might be seeing the NIC incorrectly as a IEEE1394 device is probably not valid. That's simply your "firewire" adapter, and it is a network device, which is why it shows up in that area. I have two of those in my device manager, one from my motherboard, and one from my sound card (Audigy2).

    I hope this helps at least a little with those that have posted here, and if anyone has experienced the same problem I have, please let me know if you have found a solution.
  14. Orogeny

    Orogeny TS Rookie

    Just bought the A7N8X-E board and had a similar problem.

    After installing Win XP neither the SATA Raid nor the Marvell LAN adapter were found - couldn't see either in the BIOS or in windows.

    I finally gave up on things and stuck a spare Netgear 310 card in slot 3 as I needed 2 NICs - and - when I booted up the PCI

    (a) got the SATA controller bios message appearing after the initial bios and

    (b) the Marvell Gigabit LAN appeared in the "Others" device category as an Ethernet Controller.

    I thought now the machine knew it had SATA and Gigabit NIC it'd be OK so I removed the Netgear but on rebooting they had both vanished again :(

    So I've now got a system with a 3rd PCI NIC disabled in devices and everything works fine.

    If anyone has any idea *why* this helps please let me know. It doesn't harm anything but I don't feel too confident with the solution.

  15. cerwinvega

    cerwinvega TS Rookie

    Hey all.

    Just registered to say I have the exact same problem as Ironbasher.

    I've been trying to figure it out for about a month now, I dunno.

    I do know that the LAN did work initially, then quit, and I still haven't figured out why.

    Curious, what BIOS rev are you guys running ? I'm running the 1011 final.
  16. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Found this on the web:
    My $0.02: use Add/Remove Hardware, tick showing hidden devices, and remove/uninstall all instances of the Gigabit lan that you can find first.
  17. Ironbasher

    Ironbasher TS Rookie Topic Starter

    Hi Cerwinvega and others,

    My Gigabit LAN never worked from the beginning and, apart from the physical presence Marvell chip on the MOBO, has never shown the slightest sign of its existence anywhere! The fact that yours gave a few initial twitches, together with the phenomena reported by others makes me suspect that the chip in question has some marginal characteristics. I have seen this type of thing before in prototype VLSI ASICs in data networks I was involved with. Typically, some timing parameter is on the the limit making the whole thing ultra sensitive to the slightest variations in software, timing of associated circuitry or physical conditions. Initially specified production test routines don't necessarily disclose all critical parametes for specific application scenarios. On top of all that the way in which the Gigabit LAN is described and that in contrast to the other LAN NICs that it does not appear on the main BIOS setup makes me think that it has been "stuck on" afterwards instead of being integrated into the system at an early stage in the MOBO design.

    My guess is that somebody in ASUS knows all about this and that probably the problem has been cured (i.e better "fixes" have been found) in more recently produced MOBOs. Mine is about 9 months old and I suppose would be one of the first to use the Marvell NIC that replaced the 3-com NIC used earlier. The fact that it was replaced would suggest that it had its problems too (comments anybody?) although this might be due to strictly commercial reasons.

    Personally, I have given up - unless somebody comes up with some entirely new insight. A functioning Gigabit LAN is not high on my priority list right now and I am very pleased with the A7N8X-E deluxe MOBO in all other respects. By the time I really feel the need for a Gigabit LAN I expect a new MOBO will be on the agenda.
  18. Ironbasher

    Ironbasher TS Rookie Topic Starter

    PS to Realblackstuff

    I think your input appeared while I was composing my reply to Cerwinvega. Anyhow, there is no sign of the Gigabit LAN in the "Add-Remove Software" (I suppose you meant that and not "Add-Remove Hardware" which doesn't exist in the Control Panel) nor in the suggested Reg. locations.

    This tends to further confirm my theory that the Gigabit LAN is a "stuck on" extra feature never foreseen in the original MOBO design. It is clear that even where the NIC shows some signs of life, precise installation procedures involving a long list of caveats are critical. This would be fairly typical of something being shoe-horned into a hardware/software environment never foreseen to accommodate it!
  19. cerwinvega

    cerwinvega TS Rookie


    Yeah, I still love the board too, lol. I run an A7N8X DLX as well as the -E DLX, and they are great boards.

    I'm gonna try a different BIOS revision though, any chance you could check and let me know what rev you are running ?

    This problem DOES NOT seem to be very common at all. In fact, none of the other hardware sites I frequent mention this problem anywhere, even once.

    The LAN is probably toast, no doubt, but for the great majority it appears to be working fine.
  20. Ironbasher

    Ironbasher TS Rookie Topic Starter

    Hi Cerwinvega,

    Bios info - copied directly from "System Information"

    BIOS Version/Date Phoenix Technologies, LTD ASUS A7N8X-E Deluxe ACPI BIOS Rev 1008, 05-Dec-03

    I see from the ASUS download site that there have been 2 updates since that version, but neither of them have anything to do with the problem in hand, so I prefer to leave well alone.

    In any event, thanks for your (and everybody else's) interest and suggestions. Taking into account your observation that problems in this area do not appear to be widely reported, I tend to agree with you that I probably have a dead Gigabyte NIC. However, I still have a suspicion that the addition of the Gigabit Lan was a fix rather than an originally planned design feature. OK, so they got away with it in most cases! However, as I said, the issue is not sufficiently important to me to start a serious campaign to get the otherwise excellent board replaced.
  21. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    I use Windows 2000 Pro, so am not quite familiar with XP. I assume in that case, that you would remove/uninstall in Device Manager (if XP has that).

    I only copied the text from that forum where I found the info. They use XP pro so I assumed tha Add/Remove HW exists.

    Sorry to hear about your ongoing problems.
  22. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  23. Ironbasher

    Ironbasher TS Rookie Topic Starter

    Windows XP/ control panel has an "Add Hardware" item but no "Add/Remove Hardware" item. As you suggested, removal can be done via Device Manager (exept there is no sign of the Gigabit LAN there either).

    Also, I forgot to mention that the Marvell Lan driver I was attempting to install was the still current version, 6.2.8
  24. cerwinvega

    cerwinvega TS Rookie


    Thanks, I'll definitely let you know what I find, if anything.

    The original A7N8X (non -E) Deluxe is dual lan equipped also, albeit 3Com as opposed to Gigabit, along with the nVidia controller. On my non -E this works great. Again, this thread about somes up ALL reports of this issue, lol, we are it.

    In other words, I honestly believe that if this ISN'T a bios issue, (which it probably isn't), then it is more likely a failure of the LAN hardware itself, as opposed to ASUS's implementation.

    Dual LAN, after all, is a pretty common feature for boards of this generation from ASUS, and from all manufacturers in general.

    OK enough rambling. Happy weekend, and I'll let ya know if I find anything worthwhile or otherwise.

    EDIT: Just FYI, my -E board is about a month old, and my non-E is a rev 1.04, about a year and a half old.
  25. ELW

    ELW TS Rookie

    Same problem on new P5AD2

    Same problem on a new Asus P5AD2 Premium mobo that I just purchased. This board has two independant Marvell 88E8053 LAN controllers. Neither one appears in BIOS for me, nor does it appear as a hardware device in the Windows XP device manager.

    My best guess is that it is a resource conflict. It could be...but I don't think it is a bad chip, because I have this same problme on both LAN controller chips, each with its own RJ45 connection.

    My system is: Asus P5AD2, Appian Graphics Phoenix 4 head video (ATI based), 2 x 74 GB Raptors, 2 x 512 MB Corsair XMS2, NEC 3500A DVD Writer, Floppy drive, Logitech bluetooth wireless keyboard and mouse, Dell 2001FP monitors, speakers.

    In trying to fix the problem, I have disabled all unused hardware in the BIOS -- in an attempt to free up resources. To no avail.

    I'm not sure if this is related to the LAN problem, but I have two items in my device manager that still cannot find enough free resources to load:

    Intel 82801FB/FBM PCI Express Root Port - 2662
    Intel 82801FB/FBM PCI Express Root Port - 2660

    I get a green light on the "speed LED" indicating 100 MBit/s. However, the "Act/Link LED" is should be solid green or blinking green.

    I have reloaded XP from absolute scratch (clean drives, etc), but that did not solve the problem.

    At the moment, I am using a 20-pin power connector intead of the preferred 24-pin. Could that be the problem?

    Has anyone figured this one out?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...