hard drive problem / windows xp boot problem

By exodent ยท 11 replies
Jun 27, 2007
  1. hey guys. i have seemed to run into a problem and some help would be appreciated. the story goes like this.

    yesterday i came home with a semi brand new 60gb maxtor hard drive in my hand. i have a 120 gb hard drive already in my dimension 4550, and i thought hey, i got this for free from a friend so why not use it. I take the original drive out so it was less annoying for me to work in that small space, and put both drives back in. i must have gone wrong somewhere because when i booted up, it said that primary drive 0 was not found. after a while, i got the computer to recognize both drives. the 120 gb is a western digital and the 60 gb is a maxtor. even though the computer is recognizing both drives, when i go to boot, after the first part (the DELL sign and the loading bar), it is just a black screen with a blinking _. and after that it will boot to cd because as of now i have the xp professional installation disk in there.

    now, when i run the ide drive diagnostics under the boot screen it recognizes both drives but this one word scares me. it looks something like this

    wdc (the western digital drive) - thenabunchofnumbers - Fail - return code: 7
    then the same thing with the maxtor drive underneath that.

    i wouldnt really have much of a problem just re-installing windows onto the original drive since i didnt have anything that was irreplacable on there, but when i go to system recovery and the chkdsk option, it recognizes that there is an installation of windows on the original drive, and that all the information is still there. im just afraid that if i do go ahead and re-install windows, it still will not boot and i would have just lost my stuff (a lose-lose situation eh?).

    by the way, it is no problem if i would not be able to use the new drive because it will not be an inconvinience.

    so yeah help would be greatly appreciated in this situation. thanks guys :D
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    Hi exodent and welcome to the TS Forum :wave:


    you dont say how you connected the drives, or if they are IDE or SATA, did you

    a) put them both on the same cable and set the jumpers correctly.
    b) put them on seperate cables but have a CD or DVD on the same cable somewhere.

    If its A then its possible that you have set them so that Primary drive 0 is now Primary drive 1 and thats why it wont boot.

    Take out the drives and start again from scratch, find the one with the OS and make sure the jumper is set to Master and if you are using a cable that allows you to have 2 drives on it make sure it goes at the end of the cable and see if it boots.

    If it does you now need to set the other drive as Slave and put it on the same cable and use the other IDE connector .

    If it then misbehaves again and everything is set correctly then its possible that you have a drive that doesnt like having a Slave device attached to it, some IDE devices are like and your only choice is to put the 2nd drive onto the secondary IDE channel, again make sure you check the jumpers of any other devices you have on the channel.

    Lastly some BIOS's allow you to set the boot device by actual connected device, such as primary device 0, primary device 1, for those that have this type of BIOS it means that they can have 1 or more drives with an OS and use the BIOS to decide which boots, other BIOS's just have the choice of HD or CD or Floppy in the boot order.

    Also whilst your here could you please read the folllowing threads It will help to make your Techspot experience a more pleasurable one.

    Techspot FAQ.

    A message for all newcomers.

    SNGX1275`s A guide to making a good post/thread.

  3. exodent

    exodent TS Rookie Topic Starter

    slave drive out, still no proper boot

    yes i am 100% sure that the western digital (primary 0) is IDE and am fairly sure that the maxtor (primary 1) is also.

    i took the maxtor completely on the computer, and the western digital's jumper is set on the cable select setting, and is attached to the right part of the cable. the computer recognizes the drive.

    but, still no proper boot. same problem with the flashing underscore.

    i read on a similar thread to go to the recovery console off of the instillation cd and type 'fixboot'. i did that but i am awaiting conformation that this will work.

    right now it says:

    The target partition is C:.
    Are you sure you want to write a new bootsector to the partition C: ?

    any information on what the outcome on this would be helpful since i have no idea what will happen after i make the confirmation
  4. exodent

    exodent TS Rookie Topic Starter


    i went ahead and tried the fixboot anyway. but, just my luck, no success. same problem. heeeeeeeeeellllllllp please
  5. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    Did you remove the other drive like i said and did it boot ??

    Some drives dont like having another IDE device attached to it, it will still be identified in BIOS as a drive it just wont let the other drive boot

  6. exodent

    exodent TS Rookie Topic Starter

    the new drive was removed and i put primary drive 1 in the off position just to be sure. still no boot after: fixboot, fixmbr, and a chkdsk that took FOREVER. (all in the recovery console on the xp instillation disk). like i said, i wouldnt mind for a re-install of windows (norton 360 has the majority of my stuff backed up in an online safebox anyway), but the way things are looking now, im having my doubts that even that will work.
  7. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    Sounds like the drive has had it after all, well your prepared well enough for a reinstall, but I wouldnt use the old drive.

  8. exodent

    exodent TS Rookie Topic Starter

    yeah that sucks. you think i should give it a shot with the old drive?

    and anyway i have a few more questions on some stuff not related to this topic and you seem like a pretty knowledgable guy. can i pm you or something?
  9. thebaronjocelin

    thebaronjocelin TS Enthusiast Posts: 158

    You say it's booting to CD?
    Try removing the CD.
  10. exodent

    exodent TS Rookie Topic Starter

    it trys to boot from the drive first, then the cd. i have it set like that in the bios
  11. thebaronjocelin

    thebaronjocelin TS Enthusiast Posts: 158

    Oh, okay. Well... new drive.
  12. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    I wouldnt use the old drive it sounds like its going bad.

    Feel free to PM me but your gonna get a wider range of help if you post your probs in the forums...

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...