1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Hard Drive showing up only after i clear CMOS

By pifg99 ยท 14 replies
Apr 2, 2005
  1. Hi all. I have a Maxtor 160GB Serial ATA Hard Drive with Native Command Queuing running off a ABIT AA8XE Motherboard. Here's the problem:

    For the past Week and a half the HD hasn't been detected or has been showing up in the BIOS leaving me locked out of Windows XP. Just this morning though I cleared the CMOS on my motherboard and the everything is fine.The HD shows up as Primary slave and Windows boots right up. But then I shutdown my PC and turn it back on and it back to the same old trouble with the HD not there.

    Anybody know what i'm experiencing here? Thanks in advance.
  2. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    That doesn't sound right. A SATA drive shouldn't be showing as "Primary Slave". Do you have another drive in there? IDE or SATA?

    When you say the HDD isn't "there", you're talking about just not booting off it? Or that the POST shows no HDDs installed? Or the CMOS doesn't show it?
  3. pifg99

    pifg99 TS Rookie Topic Starter

    No other HDDs in there. The post shows no HDDs installed.
  4. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    That's strange indeed, especially if there has been no changes to the system.

    Check the CMOS battery just on the off chance it's not running good voltage.
    Go through the CMOS options and make sure anything with SATA isn't turned of somehow.
  5. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    I am not familiar with that board in particular.. But many add-on and even some integrated SATA / IDE / RAID controllers have their own BIOS. This means the computers basic POST does not detect these drives. Just something to be aware of if you aren't already. Usually you will see the drives listed elsewhere though, perhaps after POST before the Windows logo appears... But this information may not apply.

    Another useful tidbit is that the master / slave assigning convention has been tossed out the window with SATA drives. This means SATA drives do NOT appear to be master or slave. But if you have IDE drives, you will see master / slave.. Perhaps what you are seeing are your CDROM(s) or other non-SATA hard drive(s) listed at POST...?

    If clearing your CMOS temporarily fixes the problem, I might suspect a problem with the BIOS. I think this because when you clear the CMOS, it returns your BIOS settings to the factory defaults and it works, correct? There should be no reason for this setting to change itself after the CMOS has been cleared.

    So, one of the first things I might try while troubleshooting is updating your motherboard's BIOS by visiting Abit's website and downloading the latest available. They will have instructions on how to update (flash) your BIOS if you have any questions. Please be aware that updating your BIOS can permantly damage your motherboard if the power goes out or your PC hangs during the update process, but it may (or may not) be the solution. Certainly worth a shot.

    It's also possible that you have an intermittent problem with the hard drive etc.. Perhaps by coincidence, after you cleared the CMOS whatever the problem was just happened to iron itself out temporarily. Try repeating the CMOS clear to reproduce the "fix" and see if it works each time you clear the CMOS. If it doesn't, then you know it was just coincidence. If it does, then it is safe to assume it is something relating to the CMOS.
  6. pifg99

    pifg99 TS Rookie Topic Starter

    I checked all BIOS options. Everything that has to do with Serial ATA is enabled. How would i go about checking the CMOS battery?
  7. pifg99

    pifg99 TS Rookie Topic Starter

    My CD-ROM shows up in the post. Nothing else. I shut down my PC last night, turned it on this morning and had the same problem so had to clear the CMOS again and it worked like last time. Maybe it's a bad hard drive? I will try updating the bios. If that doesn't work then i'm just going to get an IDE hard drive.
  8. pifg99

    pifg99 TS Rookie Topic Starter

    My Mobo came with an SATA Driver Disk that i haven't used yet. Could that be the problem? I don't know how to install these drivers.
  9. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Does the hard drive show up when you reset the computer?
  10. pifg99

    pifg99 TS Rookie Topic Starter

    Yes but i actually fixed it this morning. I switched to another SATA port, cleared my CMOS again, started up, saw the drive, shut down, waited a little while, started up and my drive was still there.
  11. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Very strange indeed. Bad SATA port?
    Does anyone know if you are required to put a HDD on one or the other of two SATA plugs? Or does it matter?

    If that's the case pifg99, maybe the mobo has problems, might see if you have a warranty on it.

    Hope it keeps working for you.
  12. pifg99

    pifg99 TS Rookie Topic Starter

    It actually stopped working after i left it off for over a minute but i fixed it yet again. I found out that it wasn't the motherboard but the hard drive. I simply took out the hard drive, observed where the connections were and saw there was some jumpers on it, placed a cap on them and the problems are now gone. I heard about how everyone is having compatibility problems with Maxtor DimaondMax 10 series which is the one i have and putting a jumper cap on the drive where the jumpers were solved my issue. The Drive Now shows up all the time. I can leave my PC off for 10 minutes, turn it back on and the drive is still there in the bios.
  13. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Wow. So that begs the question, have you had this "problem" ever since hooking up the drive? If not, why would it work for so long?

    And the second question, what is that "jumper" say it's for?
  14. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    check the battery may be new ,but could be bad connection or just bad
  15. pifg99

    pifg99 TS Rookie Topic Starter

    I did have the problem ever since i had the drive. Don't know why it kept working that way. Wierd. I'm not quite sure what the jumpers are for. I bought the drive OEM from Newegg so it came with no manuals or anything but if i find out from the Maxtor site, i'll let you guys know. As far as it being a bad CMOS battery or something like that, it could be. Well, as long as everything works like i need it to, that's all i care about. I rather use it reconfigured in this new way rather than have to spend money on new parts. That's if anything at all is wrong with the mobo or HD.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...