Hard Drive Unreadable but recognised

By angelos619 ยท 21 replies
Dec 5, 2005
  1. My 160gig hard drive is recognised by windows and i can see it on bios it is detected but when i open my computer its not there i cant assign a drive letter to it or anything i cant access it [​IMG][/URL][/IMG][​IMG]
    i have windows xp sp2 with Western digital HD's and yes i've checked all the connectors and tried new connectors. can any one plz help me
  2. IronDuke

    IronDuke TS Rookie Posts: 856

    Is this new drive SATA or PATA. If the former has it been enabled in the bios?
  3. angelos619

    angelos619 TS Rookie Topic Starter

    they are ide

    they are both IDE
  4. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    try right click on the device in hardware see if you can access and config it there
    I know it's not a seagate ,but download the seagate discwizard tool maybe it will id and format it for you
    I use it for all my hdd startups
  5. patio

    patio TS Guru Posts: 482

    I'm concerned that Disk Management reports a 120G WD as a 40G and a 160 is reported as an 80G...

    patio. :cool:
  6. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    I can only see the first drive, but it is reporting OK at 111GB. You might have the above confused with Window's reporting the partition sizes instead of the total drive capacity.

    You set the jumpers properly? If you know you did, double check anyway. If the drive is alone on a cable, set it to master. If it is connected to another drive was working previously, set it to slave. If that doesn't work, try cable select.

    Another possibility is there's a bug where Windows XP canot support drivers larger than 132GB. Just a total guess (and an unlikely one at that), but I'd recommend upgrading to service pack 2 if you haven't already. If you have, then you can ignore this.

    Provided everything is connected properly, there's not much else that could keep it from showing up. I'd try taking it back and getting another drive... It certainly woudn't be the first bad, brand new drive I've seen. :dead:
  7. valdeviking

    valdeviking TS Rookie

    VIA or memory the culprit?

    I have a similar problem. My BIOS sees the HDD most of the times (?) but win xp fails to.
    I have tried with 3 diff HDD and getting the same result.
    My HDD's are Samsung and Seagate 40, 60 & 80 GB, all different so it can't be HDD problem.
    On cold boot the problem seems worse because on the second boot I normally get them working.
    I can only have my HDD on the same cable, my motherboard won't accept any other config. and I mean any other. I have a read and a read/write cd-rom drive.
    Jumpers and cables have been replaced and changed, no luck.

    My motherboard is a PCCHIPS M925G with VIA controller and according to one (1) message on another board this could be the problem as VIA tends to stress with multiple HDD.
    I later found out that my 512 MB DDR ram isn't 266/200 as the mobo preferres but 333 ! (3200).....

    Recovering data: I have tried (sigh) a lot of progs and the best if you have a working win is Zero assumption which is both fast and sees everything even after formatting from FAT to NTFS brilliant prog.
    In DOS the best is Active uneraser but it's slower and not as userfriendly....

  8. angelos619

    angelos619 TS Rookie Topic Starter

    120gig is split partition i splited into a 40gig and a 80gig
  9. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    so to verify
    the drive images above are the first drive
    your problem is the 2nd drive
    did you try the seagate tool yet ?
    and I can't stress enough do a MB bios upgrade if you can't get this to work
    after the upgrade go into bios set to optimum defaults
  10. angelos619

    angelos619 TS Rookie Topic Starter

    yeap its weird cause i tried creating a new partition and restarted it and still not there and i also tried the Western digital diagnostic tool and it asked me to set it up and i did and nothing.

    I also runned the hard drive test and it passed it all no errors. WTF?
  11. angelos619

    angelos619 TS Rookie Topic Starter

    this thing is weird like if i take off my 160gig my 120gig wont work and wont even show on the bios but when i put it back in it works loads up windows.
  12. swker98

    swker98 TechSpot Paladin Posts: 1,077

    just a thought is the drives hooked up in the right master slave order, are they both set as master or both as slave
  13. angelos619

    angelos619 TS Rookie Topic Starter

    i went in the HD properties and it lied to me about how the status shows "This Device is Working Properly" yea sure

  14. angelos619

    angelos619 TS Rookie Topic Starter

    What the hell Western Digital Diagnostic tool is telling me that my 160gig is also a C:drive when it should be I: drive [​IMG][/URL][/IMG]
  15. angelos619

    angelos619 TS Rookie Topic Starter

    Umm the 120gig is set on master and and the 160gig on slave and now i have the problem of windows telling me that the 160gig is C:drive
  16. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Have you tried booting into Windows yet? Only the drive with an active partition should boot. You may also be able to specify the boot order in the BIOS as to which drive boots first in case there is an issue. Windows should make the active partition C: and then assign (or not assign) a drive letter to your 160GB.

    If there's no data on the 160GB and you cannot boot your computer up, use the partition manager near the beginning of the Windows XP setup to delete all the partitions on the 160GB and recreate them. This will force Windows to assign different letters.
  17. angelos619

    angelos619 TS Rookie Topic Starter

    Yeap tried that and it does show the 160gig but its says drive not accessible i cant even select it, i cant delete the partition because it wont let me select it.

    I think the problem is that the 160gig HD thinks its Master also and it also tries to act as C: drive thats what i think.
  18. angelos619

    angelos619 TS Rookie Topic Starter

    Looks like its unsolvable
  19. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    did you try the seagate wizard
  20. patio

    patio TS Guru Posts: 482

    Leave the 120G as master on IDE1...
    Hook up the 160G by itself as master on IDE2...
    Then run the WD setup utility to prep that drive and format it for use...

    patio. :cool:
  21. angelos619

    angelos619 TS Rookie Topic Starter

    yeap i did i tried everything that wizard has and it was successful but after restarting the problem is still there
  22. angelos619

    angelos619 TS Rookie Topic Starter

    yeap tried it and nothing i tried reinstalling windows and still the same didn't fix anything. I also tried to install windows on the 160gig and it just said Setup cannot access this disc
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...