Hard Drive: Win 2k Pro NTFS to XP NTFS

By mhr2x ยท 17 replies
Dec 18, 2003
  1. I couldn't find this problem being addressed, but I imagine it has somewhere. I recently purchased a new comp. I am trying to copy files from old hard drives onto my new comps hard drive. I thought the easy way would be to slap those drives in the comp. I seem to have the hardware working correctly. However, I get the "D:\ is not accessible. Access is Denied." error when I try to explore the volume. I am logged in as Admin. Is this an OS related issue.

  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Is the new computer running XP or 2000?
  3. mhr2x

    mhr2x TS Rookie Topic Starter

    The new comp has XP Home preinstalled. I have two hard drives which had been in the old computer and are formatted in Win 2k using NTFS. I have tried installing both drives as slaves on the main channel, slaves on the secondary (CD-R on it) channel and sole devices on the secondary channel. Results are the same. BIOS and Windows correctly indentify the hardware. And, Windows maps the drives. But, if I try to access volumes that I am certain are there, I get the error message.

    Thanks a bunch for your response...it is quite frustrating
  4. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    XP can read any partition created with Windows 2000. There appears to be a problem with your file system.

    I have seen instances where a partition is not accessible because it is corrupted, but the OS that is installed on it can read from it fine. This is also a problem that chkdsk will not likely fix.

    Rather than worry about it too much, I suggest trying the opposite. Install your new PC's drive on your old system and read it from Windows 2000. From there, you can copy your data over to the new drive.

    Windows 2000 does not natively support NTFS 5.1, but SP-1 corrects this problem. So make sure you have a recent service pack installed so you'll be able to read your XP drive in your Windows 2000 computer.
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    There may be a case of encryption on the old W2K disks, that you have not (yet) installed on XP-home.
    Also, you will be a different user on XP from W2K, even if you used the same name. You can take ownership of these files as follows:
    Boot XP-home into Safe Mode (Press F8 a few times when starting up) as an administrator. Now use Explorer to go to the folders etc. on your W2K-drives, right-click them, select Properties, click the Security tab and click OK if a security message pops up. Click Advanced, then Owner tab. In the Name list select your (administrator's) name. Mark the Replace Owner on subcontainers and objects check box. Click OK, Yes and OK.

    For taking ownership of files, rightclick them, Security tab, Advanced, Owner tab. In Name list select Administrator or Admin-group and click OK. Click Add and in the "Enter the object...list" type a user or group account or Administrator. Click OK. In the group or user name list, click the account you want (e.g. Administrator), then tick the check boxes for permissions, e.g. Full Control [Allow].

    Hope this gets you on your way
  6. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    you can also run x-copy in a dos window and remove the read only attribute from the files on the old disk .Ntfs does this when there is a O/S change in the hardware.
  7. silkmonger

    silkmonger TS Rookie

    Cheers realblackstuff !

    You're a lifesaver...

    I've had my old Win2K NTFS hard drive unaccessible on my new WinXP system for over a month, loaded with tons of stuff I copied onto it before migrating to WinXP.

    Can't believe Micro$oft don't explain how to do it in the WinXP help system. I followed your instructions step by step, now I have all my stuff again. Thanks!

  8. SonicClub

    SonicClub TS Rookie


    Ok, nevermind everything I said a while ago if you read it..It would save me from the embarassment, I just paniced, that's all. I thought I would never see my important files again, ever. The good news is that I found out how to take back ownership of all the files, and I can rest knowing that all my files are safe again, lol, sorry about the dramatic post if you read it, but I have nothing to say now, no help needed here anymore, sorry.
  9. ratishkurian

    ratishkurian TS Rookie

    Thanks a lot mate..your help is much appreciated (realblackstuff) I have been struggling for the last few days :giddy:
  10. eydryan

    eydryan TS Rookie

    blooming brilliant :lol:

    the same damn thing happened when i went to a friend and used his f-d up windows to copy files from my computer to my computer. however even after taking ownership i cannot delete them... any clues?
  11. quad3d@work

    quad3d@work TS Rookie

    I dropped my computer from 3ft over the weekend and killed my RAID0 drive. Your tip saved my day. Thanks!
  12. Michel Merlin

    Michel Merlin TS Member

    How do I take ownership of the 100,000 files?

    I saw a couple persons very happy with RealBlackStuff's advice above (Sat 20 Dec 2003 11:30 GMT) that did solve their problem, a frequent one that also hurts me; but I failed to understand a part of it, thus failed to fix my problem, hence my report and question.

    I have 3 PCs networked: a 2006 Laptop "U223" (Win XP Pro); a 1999 laptop "SAGER982" (W2KSP4); a 2003 desktop "MerlinDesk" (W2KSP4). They are all in the same "Merlin" networkgroup, and connected with RJ45 cables to a Netgear GS605 hub.

    From one of the W2K, in Windows Explorer, "Network Neighborhood > Entire Network > Microsoft Windows Network > Merlin > ...", I can access each other W2K with no problem. However when trying, from either W2K, to access the XPPro (U223), I can access the PC ("Microsoft Windows Network > Merlin > U223"), then when clicking its root folder "C" I do see its contents, but when clicking any sub folder (like "Documents and Settings" or "Windows" or "Download" or any other one), I get:

       | \\U223\C
       |  X  \\U223\C\Download is not accessible.
       |      Access is denied.
       |               |   OK   |
    From the XPPro I have full access to the 1999 W2K, but I had no access to the 2003 W2K ("MerlinDesk").

    Then I made sure:
    • each drive of each P C is full shared (including adding a New Share with Full control to Everyone, see "Default administrative shares are created..." in The Mole #16, 30 Aug 1999),
    • NetBIOS over TCP/IP is turned on (enabled),
    • and on each PC, the Computer Browser service is started and turned on.
    Then I installed NetBEUI on U223 (KB 301041: How to install NetBEUI on Windows XP) and I rebooted, which gave me full access to the 2 W2K. But from any of these W2K, I still can access nothing on U223 further than the root folder.

    This is where I tried RealBlackStuff's advice. After checking the "Replace Owner on subcontainers and objects" box, clicking "OK" opened a "Security" window with "Taking ownership of: ..." parsing objects for 1 or 2 minutes; then appeared a window with a lengthy advice where I duly clicked "Yes", which opened the same (or similar) "Security" window with "Taking ownership of: ..." again parsing objects (apparently the same ones: the folders in my C: disk), but this time for ~15 minutes.

    Then the next thing to do was:
    Here I don't see what you mean. Sure you don't want me apply "rightclick them" to each of the ~100,000 files one by one, but then, where do I find something representing them all at once? Please be more specific here (as you were above).

    Probably due to this "taking ownership of files" that I failed to understand and apply, the above was not enough to recover access to the XPPro P C from the W2K ones, even after rebooting all of them. Thanks to any help.

    Versailles, Sat 9 Jun 2007 13:32:25 +0200, edited (typos) 13:58:00
  13. Michel Merlin

    Michel Merlin TS Member

    Taking ownership of your own drives = KB810881

    I just found that the advice above is in facts MSKB 810081: "Access is Denied" Error Message When You Try to Open a Folder. That original KB makes clear that you must:
    • Disable "simple file sharing" (despite it is "Recommended").
    • Select the parent item you want (typically, the "C:\" drive)
    • Take ownership of it (and, by checking "Replace owner on subcontainers and objects", of its child items)
    • Then, reapply the permissions on the items you want (Unfortunately it seems that there is no way of setting permissions on all child items at once)
    Unfortunately after re-clearing "simple file sharing" and reapplying permissions to a few sample items ("C:\0read" and "C:\0write") I still get replied "Access Denied" when trying, from a W2K P C, to open those "C:\0read" and "C:\0write" samples on my XPPro P C.

    Versailles, Sun 10 Jun 2007 00:09:20 +0200
  14. veshapi

    veshapi TS Rookie

    Acsses denied XP profetional

    hello every one.

    I have reinstall my XP pro SP2 with format drive and after i recognize that at second disk D: forlder with pictures disapered. i cheked with size and files ware theare. so finali i found them by removin klik on show system hidden files and move them from that folder on same drive 40 GB. after i wanted to sort them and move to anather partion but a soon as i'm moving folder to anather folder becomes unreadable...

    please help me solve problem they are very sensitive femily pics for me
    thanks in advance

  15. StarDust2k5

    StarDust2k5 TS Rookie

    thanks for this topic,

    i installed a new motherboard on my pc today and got the classic win xp thing where it wont let me log on coz of the hardware change. so i installed over my previous copy and got it working however i had lost 90gb of info that i really didnt want to lose, some stuff ireplaceable.

    i couldnt access the folder i wanted and hence thought id lost it for good however after checking the used space on my hard drive i realised it must still be on the disc even though the folder was saying it had 0 bytes in it.

    so ye after a search on the net i found this forum and post. awesome work guys u saved all my important files as i was just about to just do a clean format...

    thanks again
  16. baghdadboy

    baghdadboy TS Rookie

    THANK YOU REALBLACKSTUFF!!! I signed up to TechSpot just to thank you. Means a lot mate thanks :)
  17. Nou1

    Nou1 TS Rookie

    Thank you realblackstuff!

    You saved me and my what I thought forever lost files.

    I appreciate your help!
  18. cak sony

    cak sony TS Rookie

    Access Denied-still not accessible

    i have same case with you, this the sollution
    after i'm replace the permissions in the first time i still cannot access my folder,
    then i replace the permissions again for the second time..
    horee... my folder accessed

    ---replace the permissions twice, and you can access you folders/files again---
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...