1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Harddrive slowing down during copy

By nighteyes ยท 8 replies
Jan 19, 2008
  1. my system (winxp SP2) has 3 harddrives:

    - WD5000aaks-00yga
    - wd2500ks-oomjbo
    - st3250620as
    all are SATA connected
    all are NTFS formatted

    I'm using HD tune to check the transfer rate. On a fresh startup the transfer rate of the 500gig drive is around 78 MB/sec. This stays that way until i start to copy files to anywhere from this drive. I start copying any big file or collection of files and windows starts by saying it needs about 3 minutes to finish. But after 1 minute the time starts going up to 45 minutes. If i then abort the copying and go back to hd tune, i check the transfer rate again and then it's 3.8MB/sec. This stays that way until i reboot.

    I've tried several ways to solve this, all to no avail:

    Off course, spyware and virus sweep: nothing
    checked all cables :OK
    checked defragmentation: OK
    tried different connections on the Motherboard: nothing
    used the devicemanager to remove the harddisks and let windows reinstall: nothing.
    used the devicemanage to remove the sata controllers: nope
    Tried to find another driver for the controllers:nope
    Tried finding the same problem on google and forums: none found.
    Tried finding any weird settings in the BIOS: seems ok

    I also saw the same problem on my 250 gig drive (the WD). That would lead me to think it's not the drive itself that causes the problem. The 500gig drive is 2 months old.

    Also, since the problem occurs some time into the copy operation, it kinda looks like a piece of memory or buffer is filling up and doesn't empty or something. I'm only guessing there since i don't know a lot how this works exactly.

    i'm running out of ideas here, can anyone help me?
  2. Nodsu

    Nodsu TS Rookie Posts: 5,452   +7

    First, the Windows file copy estimate time is bollocks. Don't even look at it, ever.

    The transfer speed dropping like that could be Windows switching the drive from DMA to PIO mode. This happens because of errors during data transfer, which can be caused by bad drivers, bad mobo, bad cable, bad drive..

    I would start by going over all the SATA cables, making sure they are plugged in. Maybe swap the cable with the problematic drive and a good drive. Then run the manufacturer's diagnostics on the troublesome hard drive.
  3. nighteyes

    nighteyes TS Rookie Topic Starter

    yes, i know the windows indication time isn't right(ever :=) ). I only used it as an indication that something went wrong during copying, since it went up so drastically.

    i will try your suggestions first thing in the moring.
  4. nighteyes

    nighteyes TS Rookie Topic Starter

    ok , this thing is slowly getting weirder.

    I double checked all the cables and swapped them. No results. Last night i ran a diagnostics tool wich i downloaded from the Wester digital site on my 500 gig drive. I checked for bad sectors. Since this takes a long time i went to bed. Woke up just now and saw that the result was that 85% was damaged. But as a single whole chain of sectors. To clarify: I saw only green sectors up to a certain point, and from there on i saw only red sectors till the end. So they weren't spread around. At first i thought that maybe i found the problem, but then i noticed that windows was no longer seeing the harddrive that i was testing. So i think it's quite likely that when windows stopped seeing the harddrive, the diagnostics tools started seeing bad sectors. Also the actiivity led for the harddrives on my computer was continually lit.

    After the reboot windows recognized my 500 gig drive, but now my st3250 drive is no longer seen.

    BTW, my system is on the WD2500 drive

    edit: continued searching all morning. i downloaded a intel chipset identification util from their site. it came back with this:

    'Intel(R) 82801GB/GR I/O controller hub (ICH7/ICH7R) SATA Controller found in IDE mode'

    is this correct? shouldn't it be in sata mode or something?
  5. Nodsu

    Nodsu TS Rookie Posts: 5,452   +7

    The last 15% of a drive being bad wouldn't be impossible - it would mean that the last platter surface has been destroyed completely (a head crash?). But this would also make the drive almost unusable in Windows. It sure looks like the drive or the controller simply start transferring bad data.

    Try testing the drive(s) with the DOS-based diagnostic utility. You can download both a floppy or a CD image from WD. This would rule out any issues with Windows drivers.
  6. nighteyes

    nighteyes TS Rookie Topic Starter

    It wasn't the last 15 % reported bad. It was the last 85% reported bad. But this result is negated by the fact that i took your suggestion and did a dos based diagnostic of all harddrives using the western digital software. There wasn't a single error to be found on any of the harddrives. I am strongly beginning to suspect my PSU.

    The problem seems to have shifted now to the 250 gig drive. whenever i put too much pressure on it by accessing or writing a lot of files on it, the computer locks up. The harddrive activity led will stay lit and the mouse stops moving. the only way to get the system back is a reboot.

    tommorrow i'm gonna buy another PSU.

    what else can i try??
  7. Samstoned

    Samstoned TechSpot Paladin Posts: 1,009

    check bios should be in native mode or AHCI mode
    some laptops need to be in pio mode to load xp to the sata drive
    this should not be the case for desktop systems
    damaged drive or lack of power could possibly cause read errors
    re-check bios then re-install the sata controller drivers or update if there is one
  8. Nodsu

    Nodsu TS Rookie Posts: 5,452   +7

    Indeed. If the problem manifests itself only in Windows, then it's most likely a driver issue (for example, the driver not working properly in ATA emulation mode).
  9. nighteyes

    nighteyes TS Rookie Topic Starter

    this morning i installed another PSU. the last one was 400 watts. this one is a corsair 650 watts. Unfortunatly, this did not solve the problem. Oh well, at least i'v got one hell of a PSU now :=)

    Some specific info: the MB is an ASUS p5b-mx/wifi-ap
    the chipset is: Intel(R) 946GZ Express Chipset

    in my devicelist under controllers i see the following:

    Intel(R) 82801G (ICH7 Family) Ultra ATA Storage Controllers - 27DF
    Intel(R) 82801GB/GR/GH (ICH7 Family) Ultra ATA Storage Controllers - 27C0
    Primary IDE-channel
    Primary IDE-channel
    Secondairy IDE-channel
    Secondairy IDE-channel

    The motherboard has a util that installs all drivers. I downloaded the latest version, wich is the same one already on the cd that came with it. The program runs but doesn't appear to install anything, since all the drivers are allready there. When pressing the 'next' button, the programs finishes without doing anything.

    I also checked the intel site to see if i could locate another driver. But i couldn't find anything

    I also checked the bios settings.
    here's the manual with all the settings in it:

    I cant seem to find a setting that says native or ahci mode. There is a setting that sets IDE (page 16)to :enhanced (current), disabled,compatible.
    Is this the setting that controls the controller?


    something has changed. Last time i removed the controllers, both returned again. This time however, i removed them both again but only one returned. Could this be the cause?. I mean, could it be that this was the fault in the first place? Two controllers trying to control the same harrdisks at the same time? Or at least, two drivers trying to do the same thing.
    I seem to notice a better overall performance on my pc. I'm hoping this was the problem.
    edit edit:

    nope. i'm sorry to say that the error remains. Still locking up with the activity led lit. :=(
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...