Have HTTPS connection, but not HTTP

By crrw · 4 replies
Aug 7, 2007
  1. I have tried to regain general internet HTTP browsing. I can get to all my HTTPS sites. I have uninstalled and reinstalled my wireless hardware, twice. I have compared all the connection info with my other computer with wireless connection, and all reads the same. Each time I try to connect to something general, like Google search page, this message shows up: error attempting to validate winsock base providers:2, not all base service provider entries could be found in winsock catalog, reset is needed. Yet, all connections show they are working. Anyone know what to do? using XP Pro, Verizon DSL router
  2. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    Is your router an all-in-one or do you have a WAP connected to your router?
    Sounds like either your router isn't allowing port 80 traffice inbound/outbound or your internet browser is set to Trusted Zone rather than Internet zone.

    I have had the same problem but reversed, in that I could not get to SSL sites (HTTPS - 443) but that was due to a PAT rule between 2 routers not forwarding 443 traffic.
  3. crrw

    crrw TS Rookie Topic Starter

    I have a WAP connection using a D-Link brand adapter. All was working well until I deleted a secured VPN connection (I work for a hospital; bought a new computer for that purpose) - that is when I lost HTTP access. I have no clue as to how to check port traffic....

    “There are basically two types of people. People who accomplish things, and people who claim to have accomplished things. The first group is less crowded.” Mark Twain
  4. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    Have you tried by-passing your WAP completely, and cabling yourself up to your router? Test your internet connection this way.

    If that works, it's your WAP. If that doesn't work, it's your DSL router. We can troubleshoot it further after you try this.
  5. crrw

    crrw TS Rookie Topic Starter

    I did try the cabling test, twice, and had no connection whatsoever, FTP nor HTTPS nor HTTP. Then, as I sat staring in utter dismay at my computer in the dark, it dawned on me to reinstall the VPN connection, and viola! - I have full internet connection again. I noticed the words 'installing' and 'adapter' flash before my eyes; therefore, I suspect something did not switch after deleting the VPN. Weird is that all winsocks were still in place and working, I could ping my computer, etc, etc, etc. Benefit of all this frustration is now my internet connection is working faster - cleared some bogs out of the thing! Thank you for your generous help! Cathy
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...