Have I damaged the MBR on my new HD?

By In Real Time
Jul 24, 2007
  1. After several attempts to install Generic OEM XP Pro on a new Maxtor 100 GB PATA HD (NTSF) and several (Webroot) disk "wipes" in-between, I think I may have damaged the HD MBR. The OS still installs but I get two or three error warnings during installation and the OS doesn't function properly.

    I orginally tried a repair install as suggested here in the forum, but was unable to find the point in the install process where I would press "R" for repair. While installing XP Pro, the first error message says something like, the OS needed to "change the MBR" with the choice to allow or abort the change. The other message says, "an unexpected error (769) occurred at line 5218 in d:\xpsprtn\base\boot\setup\setup.c." and the final error message is the same as the first if abort was selected initially.

    I've tried first aborting the MBR change and on another attempt, allowing the change, either way the OS says, "processing auto configuration" when loading and eventually shows the desktop without any icons, buttons, or functions. I've had the HD up-and-running with the new OS but the aforementioned issue became too problematic.

    Have I blown-up the HD MBR or MFT and if so, can I fix it cheaply? I would have thought that zeroing-out the disk and reformatting would have taken care of the issue.

    Thanks for any help.
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    I would suggest downloading the test tools for the HD from the makers website and checking the disk through.

    The error you get may point to a faulty install disk,

    You cant actually damage the MBR or the MFT as such, the MBR resides in the first 512K of the HD and can only fail if that part of the drive is faulty.

    If you download a Windows 98 boot disk and boot from that and then at the prompt issue the command

    Fdisk /mbr

    this will create a new MBR on the drive, then try installing the OS again.

  3. In Real Time

    In Real Time TS Member Topic Starter

    Thanks for the good info, Ididmyc600. I went to the Maxtor (Seagate) site and downloaded PowerMax and ran the utilities which appear to have fixed the problem - was able to reinstall XP successfully. I'm taking my time loading programs to see which ones cause issues, part of my earlier problem, I think.

    Thanks again for the help.
  4. RedVision_350

    RedVision_350 TS Rookie

    Definately try the fdisk /mbr or fixmbr command. I just recently had a BSoD in which I fixed using that. Like Ididmyc600 said, use a Win98 boot disk or you can use the WinXP setup disk, go to the recovery console and type in the command. Keep us posted.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...