HDD problem or virus?

By -JD-
Mar 12, 2007
  1. Hey guys, this is my first post here at Techspot, hope i can find some help here, i've heard good things....

    So bout two weeks ago while slightly inebriated I knocked my rye and coke all over the keyboard of my laptop

    tried to dry it out real good, but sure enough it was glitching out within about an hour, pretty much acting like there was a stuck key or something....

    So I took it in to staples (probably my first mistake) and they called a couple days later and said it looks fine, just needs to have the keyboard replaced, which was pretty much what i figured.... So after not hearing from them for about two weeks I go back in there and this overweight fellow that looked like he had a touch of downs syndrome tells me they haven't even placed the order for the keyboard yet, all the while wearing this awkward yet smug grin..

    so i tell them I just want it back, pick up a USB keyboard and go home and order the laptop keyboard off ebay.......

    bout two days later i start getting this hardware I/O error whenever i open the laptop...and thats all it says then there is an Ok button... still works fine for another day or so....then i get an unable to locate C:\windows\system32\config\system error.

    read the microsoft article about repairing this problem and thought I had everything working right, go to start it up, see the windows XP laoding screen then pops up this lsass.exe error 'When trying to update a password this return status indicated that the value provided as the current password is not correct.' Now i can't get windows to start, even in safe mode. When i try to load from the windows disk and repair it asks for a password. I KNOW that i haven't set this password and tried my usual set of passwords that i use for everything with no luck. Its like the computer made its own password since i loaded it 20 minutes earlier.

    ANYWAY...... I decided I've spent more time on this than it would have taken to redownload everything had i just started from scratch.

    Run the toshiba recovery disk and now am unable to restore AND unable to completely wipe the HDD!? I stops at about 85% and says error followed by some ten digit number/letter error code.

    Is it most likely the HDD thats screwed?? Just seems odd as i took it out and it seems to be sealed inside of a water tight area, and there where no traces of sticky coke residue on it.....

  2. Stacey

    Stacey TS Rookie Posts: 146

    Hi and welcome to techspot.
    You should post this question in "Security and the Web"
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    It doesn't need to go to Security yet. And we definately don't need it double posted, someone will move it if necessary later.

    Onto the problem. I doubt it is a virus because booting off the recovery disks loads an environment seperate from the OS on your hard drive. Unlikely a virus is going to have any effect there. What you should do is run a drive diagnostic tool on your hard drive to make sure it is fine. You may also want to take a look at your RAM to make sure no liquids got around it.

    Here is a link for drive diagnostics: https://www.techspot.com/vb/topic7602.html
  4. -JD-

    -JD- TS Rookie Topic Starter

    ^Unfortunately my HDD is toshiba, seems to be the only one thats not supported, and like I said I tried the toshiba utilities that came with the laptop...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...