Help! Cannot Format Slave Drive with XP Service Pack 2

By Beaverkeggs ยท 6 replies
Dec 14, 2004
  1. Bought an Hitach Deskstar Drive (Model:HDS728080PLAT20) about 2 months ago and have been using it as a master slave on Windows XP. Then decided to re-install XP as well as put Service Pack 2 on it. Also got the latest BIOS update for my computer. Now that XP SP2 has been put on my machine I am unable to explore the drive as the following error is displayed "Unaccessible. File or directory corrupt". I then deleted the partition and tried to format the drive as NTFS but got to 99% completion then failed implying data was RAW and was unformatable. Have tried formatting in DOS as well as Computer Management but have been unsuccessful. However once the drive is connected to Windows 2000, or XP without SP2, I am able to format and use the drive. Also ran an advanced 'Drive Fitness Test' that found no errors.

    Therefore was wondering if this was a common problem and whether anyone :hotbounce could offer me any advice of how to get the drive working with SP2? I would greatly appreciate your help.
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Welcome to tachSpot

    Master or Slave?

    After deleting a partition, you have to make a NEW partition before you can format it.
  3. Beaverkeggs

    Beaverkeggs TS Rookie Topic Starter

    I have tried using it as a master as well as a slave. Even used 'Killdisk' software to completely wipe the hard drive but will not format as a slave with Service Pack 2 on the master. Then resulted to installing xp on the Hitachi Hard Drive which was fun running Windows XP but as soon as Service Pack 2 was put on, the computer didn't even boot up. Have looked on the Hitachi web site for driver downloads but there are none. It is very odd. Any ideas?
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    You know that Hitachi is really IBM and that it is not Deskstar but Deathstar?
    Hunt around for a low-level format program. Perhaps the HD can be saved.
    If under warranty, apply for an RMA from the supplier or Hitachi.
  5. darkbreeze

    darkbreeze TS Rookie

    You know......

    That was a crappy reply to the question. I'll tell you why. You shouldn't assume that the problem is due to a particular manufacturers common problems. Because, I would probably rape you when it comes to technical knowledge, but I'm having the same problem as they are after installing SP2. My problem is actually posted at extremetech, but it comes down to this. I have a WD 60GB drive that was working fine and recognized consistently for quite some time. I have an 80GB Samsung installed alone on the primary as master. I have a DVD burner installed as master on the secondary. And I have a 60 GB WD drive installed as master on the add in RAID card (No RAID array configured, and not needed to be. In this configuration it is just an extra IDE port.) and everything worked just fine until I installed SP2. The problem is that the BIOS recognizes the drive and windows Device Manager sees it too. The shell doesn't see it though. So, it won't show up in windows explorer or any other program or any other part of the windows os. I've pulled the drive and it comes up just fine in another system that doesn't have windows xp sp2 installed. So, perhaps, just maybe, if your aim is to be helpfull, you should think about a solution instead of blaming on the hardware manufacturer. In all reality, it would appear to be another case of Mr. Bill's guys putting their cart in front of the horse. Or maybe even, shoving the carrot up the horses ***. Either way, there is a problem that perhaps you haven't encountered yet, but it needs to be addressed because I'm sure that we aren't the only two people who are getting jacked because of this software issue. Just my opinion and if you know something I don't, I'm more than willing to listen. My two cents.
  6. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Any other program means you've tried diskpart and Disk Management in Administrative Tools?

    If you haven't tried diskpart (it's a command line app), type list disk in diskpart to see the drives it sees.

    Drives can also be hidden with TweakUI (or similar tweaking app), maybe you could check if they have become hidden for some reason?
  7. Beaverkeggs

    Beaverkeggs TS Rookie Topic Starter

    Sorted the problem. Took 5 mins. SP2's driver set the Hard Drive into UDMA mode 6 which is not supported by my system's chipset. Used the Hitachi Feature Tool to set the Deskstar UDMA mode maximum transfer rate to Mode 5 (100MB/s). Easy as that! Thanks for the help
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...