1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Help: error for Generic Host Process for WIN32

By wasteofpassion · 17 replies
Feb 26, 2005
  1. I've read through a couple post about errors for Generic Host Process for WIN32, but none of them seem to add up to the problem I'm having.

    I'll be online, for any amont of time (from 2 minutes, to 5 hours, whatever) and suddenly, out of no where- a message will pop up and say, "error for Generic Host Process for WIN32 and must close, blahblah," but it ONLY happens while I'm online, and after I click close, MSN (my ISP) says I've been disconnected from the internet and asks if I'd like to reconnect. The little icon in the corner, with the two computers showing you're connected, disapprears. Then, if I click on the message that asked me if I'd like to reconnect, and I click yes, it tells me that my modem is already in use or isn't working, and then I have to restart. This is EXTREMELY annoying, considering it just happens randomly, and only when I'm online. I have anti-spywere, addware, but I can't find any anti-virus programs that don't cost money. I'm slightly on the broke side.. Could somebody PLEASE help me get rid of this problem.
  2. HughJass

    HughJass TS Rookie Posts: 108

    Reply #1, win32 internet problem

    hi there, i to have this problem but it is a bit more severe, i started off gettting those popups then it started to get worst ever since, firstly i couldnt share my c: ova the network i have, then the sound, and windows xp theme started going windows 98! and its REALLY ANNOYING, so if any one knows how to fix this damed virus or what ever it is pls help!!

    p.s i have attached a hijack this txt file, i hope that helps, i have also done a sfc /scannow scan (it came back with nothing), i did a few virus scans and i keep getting this, i beleive there is a program that is letting them past my ZA firewall somehow, and yes it is up to date, i have done some tests with spy bot and it came back with no thing, and i have tried all of these things in safe mode and i still have the problem afterwards

    Attached Files:

  3. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,452


    Boot in Safe Mode
    Switch System restore OFF

    You have a bit of a mess with your Messenger programs.

    The official MS one: C:\Program Files\Messenger\msmsgs.exe (file missing)
    This free from MSN : C:\Program Files\MSN Messenger\msnmsgr.exe
    C2Media LOP adware : C:\Program Files\Messenger Plus! 3\MsgPlus.exe

    I don't use any messenger programs, so can't really advise, other than:
    UNinstall anything to do with:
    C:\Program Files\Messenger Plus! 3\MsgPlus.exe (there is a version that can install WITHOUT adware)
    Let HJT 'fix' the leftovers of: \Messenger\msmsgs.exe (file missing)

    Next, UNinstall anything to do with:
    C:\Program Files\Telstra\Toolbar\bpumTray.exe

    Next, run HJT on its own and let it 'fix' if still there:
    C:\Program Files\Messenger Plus! 3\MsgPlus.exe

    R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://www.computeralliance.com.au
    R1 - HKCU\Software\Microsoft\Internet Connection Wizard,ShellNext = http://windowsupdate.microsoft.com/
    O2 - BHO: (no name) - {3BE5027A-C4E8-A2BB-3598-47228C531FC8} - (no file)
    O2 - BHO: (no name) - {FC2933DE-A9B5-9E4D-3DD9-75C966D60F02} - (no file)
    O3 - Toolbar: (no name) - {12080B53-C4A5-AF0D-034C-D387466427FB} - (no file)
    O4 - HKLM\..\Run: [BigPond Toolbar] "C:\Program Files\Telstra\Toolbar\bpumTray.exe"
    O4 - HKLM\..\Run: [MessengerPlus3] "C:\Program Files\Messenger Plus! 3\MsgPlus.exe"
    O4 - HKCU\..\Run: [MessengerPlus3] "C:\Program Files\Messenger Plus! 3\MsgPlus.exe" /WinStart
    O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe (file missing)
    O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe (file missing)
    O14 - IERESET.INF: START_PAGE_URL=http://www.computeralliance.com.au

    ALL lines with O16 - DPF:

    Unless these IP-addresses are from your ISP, also 'fix':
    O17 - HKLM\System\CCS\Services\Tcpip\..\{916C8A4F-8B7E-49E4-9D19-C14DFFDF7C22}: NameServer =,
    O17 - HKLM\System\CS1\Services\Tcpip\..\{916C8A4F-8B7E-49E4-9D19-C14DFFDF7C22}: NameServer =,
    O17 - HKLM\System\CS2\Services\Tcpip\..\{916C8A4F-8B7E-49E4-9D19-C14DFFDF7C22}: NameServer =,

    When done, delete the bold files. When a directory-name is bold, delete everything in it, including that directory itself.
    Boot normal. If OK, turn System restore back on.
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,452


    there are several free antivirus-programs out:
    AVG from www.grisoft.com
    Avast! from http://www.avast.com/eng/free_software.html

    Not sure how reliable a provider like MSN (Microsoft?) is. If it is a free one, you probably get 'bumped' off at their will/discretion. One of the things you will have to live with if you want 'free' internet.

    Where are you located? There will be other ISPs in your area, no doubt.
  5. wasteofpassion

    wasteofpassion TS Rookie Topic Starter

    Well, my ISP isn't free- we pay monthly for it. I live in Michigan, and all I can get in my area of Michigan, is dialup.

    and I'm downloading those anti-virus programs right now.

    I don't know what else to do, I've looked into everything, and it seems that nothing works- I want to try at all cost to avoid reformatting my whole computer, so if anything else will work, please do help. :/
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,452

    There are a bunch of free ISPs in your area, as well as broadband!
    see http://www.freedomlist.com/find.php3?state=23

    Try one of those free ones and see if you get disconnected there as well.

    What OS are you running, and are you up-to-date with updates?
    How do you connect, internal/external/USB modem?
  7. wasteofpassion

    wasteofpassion TS Rookie Topic Starter

    I'm using WindowsXP professional, and I'm probably not that up-to-date because it takes hours upon hours to download ONE update, and I usually get kicked offline, and then I have to start all over- it's frustrating, so I just don't do it.

    And I believe it's an internal modem.. I just know we use the one that's built into the computer.
  8. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,452

    You need a downloader that can pick up where a broken connection interrupted.
    Go to www.stardownloader.com and install their Stardownloader. One of the best there is, and adfree!

    Try one of the free ISPs.
  9. wasteofpassion

    wasteofpassion TS Rookie Topic Starter

    Well, you see- I don't think my ISP has much to do with the problem I'm having. I ONLY get kicked offline when this program has an error, the Generic Host Process for WIN32, it has something to do with that schost.exe (or scvhost.exe, not sure) and when it dies, so does the rest of my computer. And I want to know how to fix that, because frankly, I'm quiet happy with MSN as an ISP, and because DSL, and cable arn't accessible where I live (for a couple reasons, one because I live in a trailer park, two just because they don't have it) I don't plan on changing anytime soon. I pay like, 20bucks a month for MSN and it's just too much of a hasle to cancel, and blahblah.
    So the real quesiton here is, how do I get rid of the problem with Generic Host Process for WIN32?
  10. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,452

    With not doing any updates, it is rather difficult to fix any problem.
    Click Start/Run and type in: sfc /scannow and press OK.
    Keep your XP-CD handy, it might ask for it. This will replace any missing or corrupt files.
    You can try to re-install your internet-connection, or just make a second one with another name, and see if that improves.
    Other than that there is not much else.
    See how you get on after a thorough virus-scan.
  11. HughJass

    HughJass TS Rookie Posts: 108

    sry to say realblack stuff, but i have tried these methods for trying to fix this problem, and it still dont work, Ahhh this is really annoying, is it possible for someone without the problem to jsut send me the svhost.exe??
  12. wasteofpassion

    wasteofpassion TS Rookie Topic Starter

    Okay, can I still do this without an XP CD because my XP isn't exactly.. a legal copy, shall we say. A friend gave me a burnt copy and I don't have the code for it anymore..
  13. HughJass

    HughJass TS Rookie Posts: 108

    no xp cd

    it dont matter any way wasteofpassion, the sfc thing wont fix this problem, i have the same problem and the sfc thing doesnt pick up anything wrong
  14. glaaki

    glaaki TS Rookie

    I had same problem

    I had exactly this same problem on my refurb gateway 910fmx and I fixed it! And it was easy!
    Here is what I did.
    I put in the gateway disc and noted that it had not loaded the software for the modem, it said "not installed" eventhough the modem was installed and working. I then installed the application for the modem, and ta da, no more problem! It was the app not the driver that fixed it.
    So I suggest finding the application for your modem and installing it.
    My guess is that Windows was assigning the modem to the default COM port, which was already in use by something else. I never figured out what program was using that port.

    Hope that helped.
    Good luck.
  15. HughJass

    HughJass TS Rookie Posts: 108

    ok cool i will have to give it a try,
    now where is that darn CD!
  16. HughJass

    HughJass TS Rookie Posts: 108

    ok well heres an update of how i fixed my system, format c:
    i spent shloads of time trying to fix it without formating it, but in the end (after about 2months ) i just started from new, i recomend anyone else having this problem to do the same and save ur self alot of trouble
  17. the__godfather

    the__godfather TS Rookie

    Answers answers


    The error you are getting is actually a part of a virus, some sort of worm, cant think of the name at the moment. But all that aside the solution to fix your problem is a hyperlink away. The security bulliten MS06-040 will resolve this issue. There is a patch you must download. Apply It and all should be good.


    Any further queries please let me know

  18. uganr

    uganr TS Rookie

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...