Help I can't get my sound to work.

By Altoids ยท 18 replies
May 13, 2006
  1. I have a Gateway mx7120. I wiped the hard drive and loaded up windows xp sp2 home ed. and there was no sound i have audio codecs legacy audio drivers media control devices legacy video capture devices video codecs and i downloaded realtek AC'97 audio but i get an error " this device can not start. (code10)" Does anyone think they can help me. Ive spent 2 days trying to figure this out and i haven't gotten anywhere. thanks
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Are you sure you downloaded the correct sound drivers?

    Go to your computer manufacturers website, you should be able to get all the correct drivers you need for your system.

    Regards Howard :wave: :wave:
  3. Altoids

    Altoids TS Rookie Topic Starter

    thanks for replying

    im going to give it a try i'll tell you how it turns out thanks
  4. Altoids

    Altoids TS Rookie Topic Starter

    didnt work

    i did what it told me to and downloaded the sigmatel driver but when i installed it , it said that the system does not support the driver is there any other advice you could give me?
  5. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Did you download and install al the drivers for your system, including the chipset drivers?

    Regards Howard :)
  6. Altoids

    Altoids TS Rookie Topic Starter

    i dont think i did the chip set ...

    i dont think i did the chip set im going to right now i downloaded the rest though
  7. Altoids

    Altoids TS Rookie Topic Starter

    i did do the chip set

    i was wrong i also did the chip set
  8. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    In that case I have to admit I`m not sure what your problem is caused by.

    Maybe some of our other members will have better ideas than me.

    Sorry I couldn`t help.

    Regards Howard :)
  9. Altoids

    Altoids TS Rookie Topic Starter


    i was downloading Gateway/Broadcom Wireless LAN Driver Version: and during the install process windows trys to load ac 97 audio and a media controller maybe if i could get those to stop loading it would install correctly do u have any idea?
  10. Spike

    Spike TS Evangelist Posts: 2,168

    I've had a similar problem before when I've accidentally used realtek audio drivers instead of via drivers.

    It may simply now be that your computer is rejecting the correct drivers in favour of the ones you first installed. When this happens, it's a proverbial "pain in the backside".

    I can't remember exactly how I resolved it now, but what needs to be done if your issue is similar, is to uninstall the realtek drivers, and completely eradicate them from your system. The easiest way to to this is to uninstall them, delete the driver files, and use system restore if you have a restore point before the time you installed the realtek drivers.
  11. benken2202001

    benken2202001 TS Booster Posts: 115   +17

    Right Click My Computer > Properties > Hardware Tab > Device Manager

    Expand your "sound, video and game controlers"

    Do all codecs and drivers have the same icon next to them? If so, they should all be working fine and the lack of sound is not a driver/codec problem.

    If any has a "!" then you'll need to uninstall that item, reboot, and allow windows to detect the item, then reinstal with your downloaded drivers.

    Did u reformat your drives? Or just reinstall winXP?
  12. Altoids

    Altoids TS Rookie Topic Starter

    thank but no good

    i just tryed deleteing the realtek and rebooting ..sigh didnt work... theres an ! point next to multimedia controller but it still wont accept the ac 97 one that gateway website has provoided me with... this will make 36 hours and counting im going to trying to find a restore point before realtek
  13. Altoids

    Altoids TS Rookie Topic Starter

    i just rewiped

    So i just rewiped my computer and im going to update windows again then update everything some the gateway website hopefully that get it done.
  14. Altoids

    Altoids TS Rookie Topic Starter


    I have finally got around to reinstalling every thing the only problem is this damned multimedia controller even the one that gateway gives me still says its not for my system when it is... i dont know what to do im going to pull my hair out
  15. Altoids

    Altoids TS Rookie Topic Starter

    I Did It!!

    I did it!! i fixed it yesterday! gateway support had the wrong audio driver for my mx7120 i ended up downloading the audio driver for the mx7118 thanks for the help
  16. Oddfall

    Oddfall TS Rookie

    Same problem

    hey, I had the same thing and after about 6 trips to gateway's site and chatting with "technicians" they told me I had to BUY the cd with all the correct drivers on it. They dont even list the realtek as the driver on the support site! Lame huh? I eventually got the guy to give in and mail me the driver cd for free, but I will try the mx7118 driver first.

    thanks for posting your solution, ive been soundless for about a week.

  17. Jaytkoso

    Jaytkoso TS Rookie

    You saved the day, actually year! I think there are alot more people out there who need to know that little factoid about the mx7118. I too went through five technician's (all who tried their best to be helpfull) none of whom discovered the solution that you luckily came accross. I reformatted the notebook to give to my girlfriend who's being sent to Iraq, and was so nervous I wouldn't have it ready in time. Thank You sooo much!
  18. Ressurrector

    Ressurrector TS Rookie Posts: 35

    I'm betting the drivers......... Whatever find out EXACTLY what sound card you have then go search for the drivers....... I bet that will fix you up
  19. driw

    driw TS Rookie

    i was having the same problem with my laptop... i was going to install the crap windows vista again just to fix the problem because i couldnt find the solution.... THANK U very much for post the solution.... u saved my life hehe :hotbounce
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...