Help I've lost my video drive (please)

By rossi46 ยท 4 replies
Sep 13, 2005
  1. Hello all

    I have a Maxtor 40gig HD that is slaved to my main drive specifically for capturing video footage from my camcorder. There was a shortcut on my desktop to it, but now the shortcut is useless.

    The drive seems to have disappeared!

    In device manager, the drive is listed as present and working correctly, but in My Computer and even Disk management, the drive is no longer there. I checked my bios page and it is listed ok in there also.

    I've tried uninstalling the drive then reinstalling it but the end result is the same :(

    I realise that somehow the drive has lost its identity, but I just can't seem to access it to give it an id back.

    My machine is a P4 3.4 running windows XP Home

    One other thing that might be relevant is that I use Daemon Tools a lot. Could that software be causing my prob?

    Any help would be greatly received as I need to finish a family dvd.


  2. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Welcome to Techspot!
    When you installed the drive did you use CS(cable select) or set actual Slave/Master designations?
    If CS Change it !!!!!!
    Also if the drive letters of you removable storage items and Rom drives are low in the Alphabet eg d-f Change them to letters past halfway eg >" L "
  3. rossi46

    rossi46 TS Rookie Topic Starter

    Hi there - thanks for the reply.

    I recently bought this new pc and took the slave drive out of my old one and slotted it in. I've used it for capturing video a few times over the last few weeks, but not for about 3 weeks. The last time I used it, it was working just great. It was installed with the jumpers set to slave (as per the last machine) and was ok. Now I go to put the last of my footage on it and my capture program (Premiere Pro) says it cannot find the capture location. Which leads us back to what I said above. Sisoft Sandra says it's there but cant read it for info or partition sizes and stuff.

  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Please would you take a few moments to read this post. A message for all newcomers. Thanks.

    You mentioned in your first post, that you were using Daemon tools.

    Has Daemon tools created any virtual drives? If so what drive letter/s have been assigned to the virtual drives?

    Also have you tried changing the ide cable?

    Regards Howard :wave: :wave:
  5. rossi46

    rossi46 TS Rookie Topic Starter

    I just added an old Seagate 30gig drive in place of the Maxtor and Bingo! everything's just fine.

    I guess there must be a problem with the actual Maxtor drive (which is a bummer, because it's relatively new :blackeye: ).

    Thanks to everybody who helped me with my problem.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...