Help needed with Bios on Dell 505

By chris172
Oct 24, 2005
  1. Can anyone help me please....?

    I guess this is almost a Password Reset query but not quite which is why I am posting as a new thread. I have read most of whats been written in that thread but got bogged down.

    Hope you all don't mind helping a newbie to this forum so here goes.....

    I have a Dell D505 laptop. It's my old one from work as i've now been given a new one because the OS went screwy, and as it was due for replacing anyway, they gave me a new one and said if i could fix it then i could keep it as they have no time to rebuild, and it was out of warranty anyway.

    What i need....I think.... is the Bios resetting back to factory.

    Story goes like this..... It had password authentication protection...I know the password as it is the same as on my new one.... but the OS went really strange and wouldn't boot which is why my IT replaced it.

    So.... I thought it was Xp that had crashed and as I have an XP install disc I reloaded it. I did a complete reformat and only now have 1 partion which is where I installed Xp....I can hear you all saying... No!!! LOL!!! Now when I boot it I have no authentication password screen and it tells me I have "no bootable drive". This appears at the same time the authentication password screen should pop up. The strange thing is that when it first starts up in the top right hand of the screen it tells me i can enter F12 to enter the boot sequence or F2 to enter bios settings. When I press F2 and enter the bios there is NO password set..... it says disabled in all cases , for primary, admin and HDD.
    When I press F12 and from the list select to boot from Internal HDD it boots fine! However.... after booting this way for about 5 times it now says a "pcisys.dll" or something is missing, so now the laptop is completely disabled.

    I can't repair Xp from the install disc as it is asking me for the admin password and i don't know it and my IT won't give it to me as it's the same one thats on my new one.

    I have tried the Hdd from my new Dell and it works fine , again by manually selecting to boot from internal drive though, So.... I guess this means the lappy has gone into some sort of defence mode. Which is why I think I need the Bios factory resetting.

    Would the Eeprom shorting trick or the password reset App sort my problem. Has anyone got any ideas ? it's a shame to throw it in the bin as I was going to give it to my son.

    Any Apps can be mailed to

    Thanks in advance and sorry if it's so long and if I should have posted this elsewhere.

  2. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 966

    Hello! Welcome to TechSpot!

    This worked for me once quite awhile ago.

    as stated: use @ your own risk.....tho better than the trash bin?!

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...