Help Please!! Motherboard DOA?

By rattle2k ยท 4 replies
Apr 15, 2006
  1. Here's the info:

    I rma'd my motherboard to asus, I just got it back, here's what I have now:

    New power Supply - 550 watts
    New Video Card
    New Motherboard
    New Processor


    The green light on the mobo comes on, but that's it. No fans, no beeps, nothing!

    I have tested the power supply, it's good, all voltages are where they should be.

    All the power connections (24 pin, and 4 pin) are all connected correctly.

    The board is not in the case anymore. I wanted to make sure it wasn't shorting out on the case somewhere, so now it's on the anti-static packaging that it came in.

    I also removed every uneeded piece of hardware. The only things connected now are the power supply, cpu, heatsink, and fan.

    I get nothing. I have tried jumping the power switch pins on the motherboard, (to make sure it's not a faulty switch on the case), I get nothing. Checked all jumpers made sure they are in the right position, nothing. The strange thing is, when I remove the power supply and jump the 14 and 15 pins, the power supply fan comes on and works normally. But as soon as the power supply is plugged into the motherboard, the fan doesn't work anymore and I get nothing!!

    My guess is, I rma'd a bad board, and they sent me a bad board right back!!

    Any help would be GREATLY appreciated!!
  2. kirock

    kirock TS Rookie Posts: 1,221

    May I give you a compliment and say you've done what you should do and I'm impressed. Most ppl don't know all the tricks like pin 14 and 15 on the 20pin connector or jumping the mobo power switch to eliminate the switch factor.

    All I can think is that the *****s shipped you back your original board somehow.
    Was the original mobo/problem the same issue?

    I really don't know what else to suggest, like I said you've covered all the bases that I know of. Maybe some others here got something we can't think.

  3. rattle2k

    rattle2k TS Rookie Topic Starter

    Yep, the other motherboard had the exact same problem. I thought the same thing, *****s sent me back my original board with a different sticker on it.
  4. kirock

    kirock TS Rookie Posts: 1,221

    I suppose it could be a dead CPU and if this is the same one you used with the first mobo then the prob just follows it. I don't suppose, if it is a dead CPU this is exactly what you'd see. Maybe you didn't get a dead brand new mobo, maybe you got a dead brand new CPU. :(
  5. rattle2k

    rattle2k TS Rookie Topic Starter

    Well, there is one problem with the dead CPU theory. I can take the cpu out and I should still get either a beep or an audile error thru headphones. I had to do it that way the 1st time to determine what it was. If no cpu is installed, then the board will say "Warning! No CPU installed".

    The problem is now, I don't even get that, it's like it's completely dead, I can't even get the board to give me the error. Like the board is not telling the psu to come on.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...