Help with ADSL modem with built in 802.11g wireless router

By maclarke ยท 6 replies
Jun 21, 2004
  1. okay....
    I have 2 computers. My main computer is connected to a belkin ADSL modem with built in 802.11g wireless router via ethernet (which i communicate and change settings via my web browser).

    The other computer (no.2) has a wireless network card installed and working fine.

    I had it all connected to a point where i could access the internet on both comuters but not share files, and i could communicate with the router.

    So i tried some trickery to get this file share to work. this involved messing about with the "file and print sharing for microsoft networks" and "clients for microsoft networks", installing clients and service, in the local area connection

    When i did this, i found that i could no longer communicate with the router via my web browser and not access the internet.

    I also noticed that under my TCP/IP settings in address type, my connection was an "automatic private address" instead of "assigned DHCP".

    I thought this would be the problem. so i scouted around the web to find answers and found things like using ipconfig (via cmd in the run command). but no luck. got message like "cannot contact DHCP".

    I tried reinstalling but no luck........WHAT CAN I DO???????/
    PLEASE HELP!!!!!!!!
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Post the ipconfig output of both computers. And what exactly did you do in network settings?

    "Automatic private address" means that Windows was unable to connect the DHCP server (the router) to obtain an IP address. You should always turn on the router before turning on the PCs. Or assign static IP addresses to your machines.
  3. maclarke

    maclarke TS Rookie Topic Starter

    what i did was right click on my local area connection and pressed properties. then highlighted internet protocal and pressed install. then installed client, service and protocal......

    my ipconfig of my computers are...............

    Main Computer
    ethernet adaptor local area connection 6:

    connection-specific DNS suffix:
    autoconfiguration IP Address:
    subnet mask mask:
    default gateway:

    PPP adpater alcatel speedtouch connection:

    connection-specific DNS suffix:
    autoconfiguration IP Address:
    subnet mask mask:
    default gateway:

    Computer 2

    Ethernet wireless network connection

    connection-specific DNS suffix: Belkin
    autoconfiguration IP Address:
    subnet mask mask:
    default gateway:
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    The TCP IP settings for the LAN connection on computer 1 are all wrong. It probably can't communicate with the router. Are you sure the cable is OK? What if you set the TCP/IP configuration manually? IP address should be, all the rest as you can see in comp 2 configuration.
  5. maclarke

    maclarke TS Rookie Topic Starter

    ok...just tried it and there is no change... No, i cant communicate with the router
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    A few basic setups when networking:

    Router-setup WAN:
    Protocol: Fixed IP
    IP-address, Subnetmask and default Gateway: as per ISP-information
    DNS-servers: as per ISP-information
    Enable NAT

    Router-setup LAN:
    IP-address: set to e.g. (or use default)
    DHCP-server: disable

    Router: Some System-settings (depending on your router)
    Optional SNTP (time): e.g. for UK/Ireland (GMT)
    uPnP: disable
    Dynamic routing: disable
    Remote config: disable
    Dynamic DNS: disable
    Firewall: Block hacker attack: enable
    Firewall: Block WAN request: enable
    VPN: disable all settings unless you need it

    Internet Protocol (TCP/IP)
    Use the following IP address: (102, 103 etc.)
    Default Gateway: (IP-address from your Router)
    Use DNS Server address: (IP-address from your Router)
    Second DNS: leave blank or put in first DNS-server from WAN-part in Router

    Enable File/Printer sharing if you wish (works only within local network)
    Check individual printer(s) that they are shared as well (in printer-settings)

    And make sure all your PCs are in the same WORKGROUP.

    If software firewall installed, enable the other PCs IP-address(es)
  7. maclarke

    maclarke TS Rookie Topic Starter's the latest...Its all working now. It wasnt all that complicated as my friend showed me. What i did was reset the router. It didnt work before because you need to hold the damn reset butoon for 7+ seconds. Also i tweaked a few settings in internet explorer and the router. Thank you for your great advice anyway
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...