Help with mmc.exe error..some administrative tools in win2k missing

By rslevine ยท 4 replies
Feb 15, 2005
  1. In win2k pro, when I go to defrag, I get an error, mmc.exe.... Looking at the computer management console, under storage, disk defrag, logical drives and the section Removable storage are missing. Further the help fucntion on the console crashes. But other functions work fine.

    I did a chdsk (complete)- no problem. I did sfc /scannow - no fix. Checking the registry compared to another win2k registry finds missing snapit entries in my registry. When I tried adding snapinin entries to mmc, it failed again. Norton antivirus finds no problems, there is no spyware and my hijack file is religiously clean.

    I need to repair or reinstall the administrative tools, but can't locate a copy of the msi needed for win2k. The file I looked for is adminpak.msi, but I only find for winXP and the server edition of win2k. It won't work.

    Any thoughts, help would be greatly appreciated. Thanks.
  2. lyam77

    lyam77 TS Rookie Posts: 27

    I had a similar problem after a brandnew installation of Windows 2000.I was able to fix the problem by creating a folder.
    go in my computer
    and their create a new folder and name it temp
    Hope this help
  3. rslevine

    rslevine TS Rookie Topic Starter


    Thanks but didn't work.
  4. rslevine

    rslevine TS Rookie Topic Starter

    Problem solved. Found the file I needed. Thanks for looking.
  5. br4sil4life

    br4sil4life TS Rookie


    I am having the same problem! could you please share your solution? thanks
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...