1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

help with MSI k8n neo4 motherboard!

By andyTHPS ยท 8 replies
Jan 6, 2007
  1. I bought all my hardware last year from newegg and successfully put together a functional PC.

    A year later (yesterday) I bought a case and tried to swap everything from the old case into the new one.

    However, the PC turns on, all fans are powered on, but it doesn't get past the "Platinum" screen (the screen before going into Windows). I can't access BIOS or go into POST mode either.

    I've tried putting in my Windows XP disc, but without going into BIOS, I can't choose to boot from the CD ROM drive.

    If i take out the Hard drive cable, it gets passed the screen, but then it says something like "failed to load system disk" or something.

    I've gotten into CMOS now (by removing the CD-ROM and HD cables from the mobo), and was able to set the boot priority to CD-ROM 1st. I saved & exited, then powered off the machine, and rehooked a brand new HD (jumpers set correctly to single/master), and rehooked the CD-ROM drive with my Windows XP disc. I've run into the same problem of it just sitting on the "Platinum" splash screen again.

    I've also tried:
    - Using a new cable for the HD to go into the mobo
    - Using a new cable for the CD-ROM to go into the mobo
    - Unhooking all my PCI cards from the slots
    - Removing all RAM sticks but one (they were 4/4 before, and i never even touched them while i was switching cases, I just left them in the mobo).
    - Unhooking the Floppy drive
    - Hitting the Clear CMOS button on the mobo.

    It seems that no matter what I do, if the CD-ROM drive is connected to the motherboard, it doesn't get passed the first screen. If i disconnect the CD-ROM drive, take it out of the boot sequence in CMOS, reset it the machine, it'll progress past the screen i normally get stuck on. It will then continue into Post, and it'll get all the way to ACPI controller and stop, and say "Verifying VMI Pool data." Then it will be shortly followed by "DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER."

    Is the IDE controller for my CD ROM on my motherboard busted?

  2. riekmaharg2

    riekmaharg2 TS Rookie Posts: 137

    Welcome to Techspot

    Is the CD drive set to slave on the jumpers, if it is on slave then try a different CD drive.
  3. mailpup

    mailpup TS Special Forces Posts: 7,103   +422

    Are you using the power supply that came with the new case? Power supplies that come with cases tend to have high failure rates. Try switching to the old power supply that worked before.
  4. andyTHPS

    andyTHPS TS Rookie Topic Starter

    I have 2 CD-ROM drives, and i've tried both (after changing the jumpers correctly).

    any other ideas?.

    EDIT: yeah, i'm using the same power supply from the old case.
  5. riekmaharg2

    riekmaharg2 TS Rookie Posts: 137

    Have you got a harddrive with windows installed on it. If you have unplug the CD drive and plug in the windows drive and see if it get into windows.
  6. andyTHPS

    andyTHPS TS Rookie Topic Starter

    Yeah, that's what i originally tried to do until I found that it wasn't working.
  7. riekmaharg2

    riekmaharg2 TS Rookie Posts: 137

    Are you using a different PSU, if you are try using the old one from your orginal case.
  8. andyTHPS

    andyTHPS TS Rookie Topic Starter

    No, it's the same PSU from the old case.
  9. raybay

    raybay TS Evangelist Posts: 7,241   +10

    I would go back to basics... Look to see if you have a ground somewhere it shouldn't be... Pulled cable, bent EIDE cable, bad cable socket, bad switch, bad switch wire, bad switch cable connector, grounded post at switch cable connection on motherboard.

    You know that you caused this, most likely. So when you are calm and rested, re do everything, rethinking each step of the way... You are missing something obvious, and those are always more difficult to find.
    The key: Do it when you are relaxed and rested, and do not feel stress.

    Minor damage from taking something apart can be so easily missed. Parts become brittle and crack. Cables that were once flexible snap or pull.

    You will find it. It will be something that will make you kick yourself.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...