Help with Ultra100 Bios

By ihatehardware ยท 7 replies
Oct 19, 2003
  1. Hi all,
    First time poster and hardware challenged! I have a Dell Poweredge 1400sc with mirrored drives (raid 1?). One of my partners messed around inside of it and also added an Yamaha CD Rom drive in addition to the factory installed one.

    Whenever we reboot the machine now, I get a message which reads "Ultra100 Bios is not installed because there are no drives attached. Strike F1 to continue or F2 to run the setup utility"

    If I do hit F1, the system proceeds and boots normally into Windows 2000 Server. I had a quick check in the BIOS and most everything appears to be set to "auto" for detection. I have not yet tried removing the second CD Rom to see if that makes a difference.

    I am not sure what to do, and would like this resolved.

    Any help appreciated.

  2. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Help: ultra100 bios not installed because no drives attached.

    What has happened to the Data on the mirrored drives ? Can you still access them ?

    The message that you get means that there aren't any drives installed on the Promise controller. If it so then your mirrored drives are either non-functional or no longer connected to the Promise controller.

    The Dell page for your PowerEdge 1400sc mentions a RAID controller but does not specify whether it's a Promise or not.

    can you look into the Device manager under "SCSI & RAID controllers" & post what you see ?

    PS. Welcome to the Forums. Hope you enjoy your stay. :wave:
  3. ihatehardware

    ihatehardware TS Rookie Topic Starter

    Hi Didou,
    Yes, I can see/use the data on the drive. However, in the device manager, there is no "SCSI & RAID Controller" entry.

  4. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    If the data is accessible but you still get that error message, it might be that your friend had unplugged your drives from the RAID controller & switched them over to the normal IDE controller.

    It means that your data is no longer mirrored because you would only get such a message if there aren't any drive on the RAID controller at all.

    Maybe your friend decided to take out one of the drives in the mirror array to use it himself on another machine.

    If you're storing important data, I urge you to ask your friend to restore your previous configuration.

    PS. If the RAID controller doesn't show up under "SCSI RAID controllers", it could be that the proper drivers for it haven't been installed. In which case it should appear under "Unknown Devices" as "Mass Storage Device" or something of the sort.
  5. ihatehardware

    ihatehardware TS Rookie Topic Starter

    I think you are on to something, as there is indeed an "Unknown Devices" as "Mass Storage Device" listed in the device manager.

    So I assume I need to find / acquire the the RAID drivers from the Dell discs or website?

  6. Crazy

    Crazy TS Rookie Posts: 139

    Yep download the latest drivers, but you'll still have to fix the boot issue. That has nothing to do with windows.
    I think your partner moved the second HD to another IDE channel or something. Might be worth a look

    Greets Crazy
  7. ihatehardware

    ihatehardware TS Rookie Topic Starter

    Ahh, the things you see when you open the box....

    There is only one harddrive in it !!! Looks like it's time for a chat at the office tomorrow morning.

    So, if I can ask you to confirm my assumptions (As mentioned, I am a hardware failure, so please be patient):

    - The BIOS is expecting there to be more than one drive attached to the mainboard, correct?

    - Can you only have a RAID setup with SCSI?

    - Currently, there is nothing plugged into either SCSI port.
    - IDE1 appears (hard to see it) to only have one cable from it which goes to the floppy, the factory installed CDRom and then the only harddrive. So, it would appear that my coleague disconnected the SCSI cables, removed one drive, and then plugged the existing IDE cable into the remaining harddrive.
    - He then plugged the CDRW he added into IDE2. Is this likely what is appearing as the "Unkown mass storage device"

    Thanks for the help guys. Once I retrieve the pirated parts and tear him a new one, I will likely have more questions for you.

  8. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Let me explain the whole thing.

    You have the motherboard BIOS which can detect the HDDs installed on the Motherboard IDE controller.

    Then you have the RAID card ( which can be integrated onto the motherboard or as a seperate card ). This card has a seperate BIOS which loads after the machines does the POST ( Power On Self test ) & it's that BIOS loading which gives the error message "Ultra100 Bios is not installed because there are no drives attached, etc".

    You can download the RAID drivers for your card but it won't change the fact that your HDDs aren't installed on the RAID card anymore & thus aren't mirrored.

    In order to have a mirrored HDD array, you need to have 2 different HDDs preferably the same size, specification, etc. If you only have one, no mirror array is possible.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...