help with updating bios. cannot find bios upgrade - 6A69RPRDC-00

Not open for further replies.


TS Rookie
hi there, i am fixing a friends old computer and the hdd was stuffed so i got a new maxtor diamondmax 9 for it. although once installing it i found out that it would only run in udma2 mode (checked it in another computer and it ran at full udma6)
so i suspect that the current bios cannot support udma5 or 6, so i am looking for a bios upgrade for it.
the bios string is 6A69RPRDC-00, the number on the actual motherboard is 35-C960-00-05
thanks for any help, i am really hoping i can make this board work at udma5 at least and not have to settle for udma2.
thanks again

ps. i just found this
04/19/2001-i815-ITE87X2-6A69RPRDC-00 ITE87X2 + Winbond-W39A
if that is any help.


TS Rookie

Old Machines.....(just like me... but can still perform to the max lol)

I your Bios has the option of udma up to 6 then generally the bios supports the Mode! and your problem is that the HDD does not support the mode (cant remember if you said it does).

You are probably using wrong criteria for bios upgrade search.
Try WWW.driverguide,com

You Need the MB's Manufacturers Name or at least the MB Chipset and bios Manufacturers Name as well. go to the Computers muanufacturers website (you probably done that already) and search model.

otherwise Download a System info utility from Tech Spot, I use SiSoft Sandra or AIDA32.. (sandra might cause bluescreen on older machines).. Aida problably will have link direct to bios update site. hope this was of some help


TS Rookie
Just read your post again.

sorry seems your hdd does suport udma 6

Some older PC Chipsets dont have support for higher UDMA even with Bios Update and would require BIOS UPGRADE which is much too costly..

good luck with your search


TS Rookie
the code i gave above, when you decipher it, gives the chipset and manufacturer
6A69R Intel 'Solano' i815(E) chipset with Award BIOS v6.00, just cant find the manufacturer or bios update anywhere , i will try aida tomorrow.


TechSpot Chancellor
Intel 815 chipset supports ATA100 and should not need a bios upgrade to run at that speed. if you are only getting UDMA2 from the hard drive then you either have the hard drive plugged intot he wrong IDE channel (the ATA33 instead of the ATA100) or you have it attached using a 40 wire cable instead of a 80 wire cable.


TS Rookie
hi, i have now tried a few things to get it to run in udma5. i have tried
1. the maxtor drive on master on another 80 conductor cable (tried on both connectors)
2. the maxtor drive on slave on another 80 conductor cable (tried on both connectors again)
3. the maxtor drive on cable select on another cable (both connectors)
tried all of the above again on the secondary channel.
tried all of the above with my seagate drive out of this computer still no luck
the original cable that i bought the other day for the machine does run udma5 and udma6 i put it in my machine and tested it.
i am out of ideas :(
does anyone know if there is any options in award bios version 6 for this problem?
thanks again.


TS Rookie
Just a thought!!!!!!!

Not got a machine with award BIOS at the mo, but is there an option in Bios setup to Allow 32 or 48 bit Direct Memory Access/Transfer?? or Use Block Mode?? and is there any listing of the HDD in section listing DMA channel??

I think Floppy uses DMA 0 and Have seen HDD on Channel 3 or 5

Cant remember exactly but think you could try to enable block transfer mode in sub section where you set HDD detection to Auto or Manual.

If options are there then enable Block Mode / Transfer and also 32 or 48 bit Access / Transfer and Enable DMA

Sorry cant be more specific but think that might be where the problem is.


TS Rookie
im not at home at the moment, but when i get home later, i'll have a look and let you know how it goes,
thanks for your help.


TS Rookie
There is a block mode it was set to enabled and still is.
there is no where in the bios to set 32 or 48 bit access/transfer.

in advanced options there is this.
primary master ide pio
primary slave ide pio
secondary master ide pio
secondary slave ide pio
all of the above can be set to mode 0,1,2,3,4 or auto, they are currently set to auto.
then below this is

primary master ide udma
primary slave ide udma
secondary master ide udma
secondary slave ide udma

all of the above can be set to enabled or disabled, they are currently set to enabled.

im sorry if this doesn't make sense, i am just listing what the bios has as options.


TS Rookie
problem fixed!!! :D

asked a friend in canada about it and he was able to help me out.
what was happening is because maxtors are udma6 the bios and onboard ide controller could not handle this so it was defaulting to the lowest udma value which was 2 hence why it was using udma2 all the time.
so with further research i found this..
once this was installed and the computer restarted it took over the job of the default ide controller which could not handle above udma2. and with this program i was able to make the hdd run at the controllers maxiumum udma setting of udma4, not maxiumum i know but you can't expect that much of an old board. :)
thanks heaps for your help guys, much appreciated.
Not open for further replies.