helpctr.exe and msconfig.exe not running (XP)

By Lathca ยท 4 replies
Dec 14, 2005
  1. I have tried to figure this out on my own, but.... :confused: I have lost my use of Help and Support. I restored my system as far as I could go (Nov 2) and discovered that Help and Support didn't even work then, so I don't know when I lost this service, or what I did to lose it.

    I have since added two new keys to my registry that points to where helpctr.exe and msconfig.exe are located: C:\windows\PCHealth\HelpCtr\Binaries. When I click on Help and Support, the error message says the system service is not running.

    When I try to start the system service, I get an error 1083: the executable program that this service is configured to run in does not implement the service. The path to the executable (Help and Support properties) is C:\WINDOWS\System32\svchost.exe -k netsvcs. I don't know if that has anything to do with it. I am grasping here...

    I ran Panda Titanium 2006 for any viruses: nothing. I have also tried to rebuild Help and Support according to suggestions from this link (, but nothing changed.

    Msconfig works if I click on it from within its location in Binaries, but does not work when I use Run - msconfig. It says it can't find it...?

    Any suggestions? Thanks.
  2. Eric Legge

    Eric Legge TS Rookie Posts: 132

  3. Lathca

    Lathca TS Rookie Topic Starter


    Thanks Eric. I checked out the thread and it looks like they went through some of the same gymnastics that I went through. I have tried all of the suggested attempts to fix, except I haven't considered reformatting my drive....yikes! I hope it doesn't come down to that.

    I just fixed one of the problems concerning msconfig. Where it points to msconfig from the registry (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\msconfig) the value for that key to the executable file (C:\WINDOWS\PCHealth\HelpCtr\Binaries\msconfig) is case sensitive...I had ....\Msconfig. Oops. :eek:
  4. Lathca

    Lathca TS Rookie Topic Starter

    Almost fixed

    I am replying to myself here..but I almost fixed the Help and Support question.

    There is a fix at I ran this program (helpsvcfix) and Help and Support now indicates that it is running (no errors); however, when I click on the Help and Support icon (or the helpctr.exe file), nothing happens. * close.
  5. Lathca

    Lathca TS Rookie Topic Starter

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...