Hi Ppl, I Need Ur Help!!!!

By Nagoya ยท 4 replies
Jun 1, 2007
  1. Windows Media Center Edition 2005 having problem with ICS

    I recently installed a Windows Media Center Edition 2005 software on my PC, and i could not start the windows firewall/internet connection service even though i have tried starting it through control panel/administrative tools/services. it keeps popping up with "Error 1075: The dependecy service does not exist or has been marked for deletion" . i have two operating systems on one pc (windows Xp and Windows Media Center 2005). i dont know if there could be a conflict.

    PLS HELP ME!!!

    Oh!! i have not yet installed any anti-virus or firewall, just a spyware and Windows Defender!!
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    Hi Nagoya and welcome to the TS Forum :wave:

    First go into 'services.msc'. Check to make sure that the services "Network Connections", "Windows Management Instrumentation" and "Remote Procedure Call (RPC)" have started (right-click each of these services > Properties. Check where it says 'Service status'). If it is not, click on the 'Start' button on that screen.

    Additionally, check where it says 'Startup type' to ensure that each of these are set to "Automatic".

    Now try starting the Firewall.

  3. Nagoya

    Nagoya TS Rookie Topic Starter

    still not working!!

    Thanks for ur solution, Ididmyc600. but it still did not work, i got fed up and started starting all the services in 'services.msc'. can u suggest anything else.
  4. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    You need to find out what dependancies are failing to start, it sounds like some kind of corruption in the OS.

    Under Services.MSC look at the part labelled windows firewall ( i think its ICS) and see what dependancies it has, see also what these are dependant on, it might be easier to write them down, then take a look at the working OS and see what the difference is.

  5. Nagoya

    Nagoya TS Rookie Topic Starter

    i've checked!!!

    i think its the corruption on the os cos when i look at it (dependencies screen), it says "dependencies: class not registered".
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...