1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Hmm.... no power.

By dzneill ยท 10 replies
Nov 12, 2007
  1. OK... here is my situation.

    I recently returned from a 15 month tour in Baghdad. As a reward I decided to buy myself an extreme gaming rig. I had previously put together a lower end rig with help from a knowledgeable friend so I figured I knew what I was doing and I could build it myself. Obviously I was incorrect.

    I unpacked all the components for the tower and went to work following, as best I could, along with the provided literature. I installed the motherboard, PSU, optical drive, HDDs, video cards and RAM. I connected all the power cables. This is where I felt I was screwing up. Everything looked ok so I decided to try and fire it up so I could check the BIOS and all that jazz.

    When I flip the switch on the PSU I get a blue indicator light on the motherboard. When I press the power button on the case fans spin and LEDs turn on.... but only for about half a second before turning off again. I've gone as far as disconnecting all the drives and check my power headers. I tried removing the USB headers with no change. I'm at a loss.

    Here is a list of the components I'm using:

    Motherboard: nForce 680i SLI
    CPU: Intel Quad Core Duo Extreme
    PSU: OCZ 700w GameXStream
    RAM: 2gb Corsair DHX XMS2 Dominator
    Video Cards: PNY GeForce XLR8 8800 GTS 640mb (I have 2)
    HDDs: 150gb WD 10,000rpm & 500gb Seagate

    Any insight anyone has will be greatly appreciated. I have a feeling it is something relatively stupid and obvious.

  2. Ph30nIX

    Ph30nIX TS Rookie Posts: 243

    First of all try booting with bare minimum. This means just CPU,RAM (one stick, if you have two) and a single video card. This narrows it down to the 3 main components that could be faulty. If you are able to boot successfully and POST, then you should be confronted with a message stating "No Operating System Found" or something similar. From there add your hard drive and install an OS. Please ensure everything is operating correctly. Make sure you only add a single hard drive at this point. Ensure that all correct drivers and installed and that you can actually power down and then load the OS again.

    From there keep adding components until something doesnt work. Remove the last component installed and then boot again. If successful, then this is a broken part. Now try adding any remaining components, and you should be fine.

    If you find any faulty parts you may need to replace them. PLEASE ENSURE YOU ARE GROUNDED WITH AN ANTISTATIC WRISTBAND WHEN WORKING ON A PC.

    Please post new results back here once you have tried the suggestions.

  3. rahkstah

    rahkstah TS Rookie

    I had this problem last week when I reassembled my pc. Ultimately, I think I knicked a solder joint on the copper coils and broke a connection. Only my fans were running up.

    Check your power connections to the chipset. Mine wouldn't start with 12vATX connected, bc it's an older motherboard I suppose. Try it with and without it connected. My OS was also corrupted, and I think this was part of the problem. Make sure you've got a good HDD in your tower.

    I agree, try to isolate the fault using as little components as you can, and make sure everything is grounded to the chassis correctly.

    Trial & error. You'll figure it out eventually.
  4. kirock

    kirock TS Rookie Posts: 1,221

    Be careful not to blow your new PSU. It sounds like a mobo short to the case and the PSU is shuting down with overlaod peotection. Remove your mobo from case and place it on the anti-static bag it came in. Now reconnect PSU cable and CPU power connections, video card, leave off the HDD. Connect monitor and start it by shorting the case switch pins on the mobo.
  5. dzneill

    dzneill TS Rookie Topic Starter


    I took the mobo out of the case and connected power, it booted right up.

    Now all I have to do is find away to get the mobo in the case without causing a short.
  6. technicalfury42

    technicalfury42 Banned Posts: 62

    Did you use the brass standoffs between the motherboard and case chassis?
  7. dzneill

    dzneill TS Rookie Topic Starter

    Yeah I used the brass standoffs. I couldn't physically see anything touching before I removed the mobo either.
  8. kirock

    kirock TS Rookie Posts: 1,221

    Sometimes the stand-offs have an insulating washer to prevent the mobo trace for being grounded. It depends on the mobo and where they drilled the mounting holes (i.e. does the hole run through an active circuit trace).
  9. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    trooper- this sounds like a power issue. Either your PSU is bad, or you are underpowered, or you are grounding out. Use a PSU tester along with a multimeter.

    -Sarge (Officer candidate) Tedster
  10. Slappydotcom

    Slappydotcom TS Rookie Posts: 28

    maybe a new powersupply with more juice could cut it, sounds like you have a whole heap of hardware and not enough watts to power it all.
  11. dzneill

    dzneill TS Rookie Topic Starter

    Thanks for everyone who is offering suggestions, I'm going to attempt them all but I'm really busy and it's hard for me to find time to sit down and troubleshoot.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...