How Do I enable AGP on my new system?

By Dyl Rob ยท 6 replies
Jul 6, 2005
  1. Hi,

    I've recently had my PC upgraded, the only thing I had left from the old system was my Graphics card which is an 256MB SAPPHIRE RADEON 9600 ATLANTIS. My problem at the moment with it is that I cant enable my card to run at AGP 4X or 8X. I've got all the neccesary software installed (.net framework for the catalyst control center) and running the latest drivers. I've had a look in the bios to see what the new system's running at & noticed that the primary display was set to PCI, so I changed it to AGP to sse if I would be able to set up the card to run at AGP 4 or 8X, but nothing seems to work. Is there anything I have missed or am I looking at haveing to buy a new Graphics card or Motherboard :( the mother board I have is an ASUS K8N socket 754 DDr400.

    Thanks in advance for any suggestions.
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Your AGP card is working already, otherwise you would not see anything on your screen.
    Tha AGP/PCI switch is used if you would have 2 graphics cards in your PC, and you would want to tell the PC which one is your primary card. With only 1 card, this switch has no function, but should be set to AGP to speed up booting (a tiny bit).
    AGP speed (4x/8x) may be set somewhere in your BIOS, check the motherboard manual.
    It will most likely default to the fastest possible speed anyway (x8 for that card).
    So forget about it, I would say.
  3. Dyl Rob

    Dyl Rob TS Rookie Topic Starter

    Thanks for that piece of advice mate.

    I didnt explain fully what I was trying to achieve. The problem is that when I go into my graphics Card display properties and look at the AGP & Fast write properties they're both selected off. I have tried selecting them on but when I reeboot they still apperar to be off. I've been doing a bit of detective work of my own since the original post & found the following problems in device manager;

    I've been onto the ASUS website & D\L the latest drivers pack for my mother board to try & rectify the missing drivers problem. I tried installing the drivers a few times, but for some reason they just wont install, again, I've run out of ideas :(

    Thanks in advance for any help :)
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    The SMBus controller is the 'System Management Bus controller', it's part of the Intel chipset on your motherboard.

    Problems with the SMBus controller typically indicate that you didn't install the Intel INF update utility, also known as the Chipset Software Installation utility.
    This is easily fixed by installing the latest one from here:*+XP+Professional&submit=Go!

    The other yellow ? is probably related and should disappear after the fix.
  5. Dyl Rob

    Dyl Rob TS Rookie Topic Starter


    just tried your suggestion, nothing changed when I installed it unfortunatley :(
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Find C:\Windows\Inf\NVSMBUS.INF
    Rightclick it, and select Install.

    Or maybe still on the mobo-cd in X:\Drivers\Chipset\K8N\WINXP_2K\SMBus
    where X: is your CD-rom.
  7. Dyl Rob

    Dyl Rob TS Rookie Topic Starter

    I've just got it sorted :bounce: All I did was re d\l the driver zip from ASUS & the drivers went straight in with absolutley no problems !!! Turns out it was a corrupt zip file :cool:

    Thank you for your help matey, much appreciated !!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...