How to re-erase cdfs filing format ??

By jay2jay ยท 16 replies
Mar 21, 2007
  1. Hi there. Is there any one out there that may be able to help me out with this???. I recently managed to obtain a company personalized flash drive. Practically the problem is that part of the storage space which loads instantly showing the company's logo and information is in the what so called cdfs format. I wonder is their some sort of application that would actually rearaze the cdfs format and compels it into fat32, or ntfs.

    Would appreciate the help for both the knowledge and fixing this cdfs once in for all lool :)))
  2. jobeard

    jobeard TS Ambassador Posts: 11,166   +986

    ASSUMING you are authorized to modify this media;
    go to your cp->admin tools->storage->Disk Mgr
    select the Flash drive
    delete the partition
    create a new partition (NTFS; and yes this does work)
    let it format
    and assign it a drive letter​
    This device will now ONLY mount on Win/NT and above

    If you need Lunix, Win/98, or Mac access, format the partition
    as FAT32.
  3. jay2jay

    jay2jay TS Rookie Topic Starter

    i have predone the same procedure you have told me, and still unable to erase the cdfd format. It seems that it is kind of read only and encrypted.
    I also tried to erase the thing by an application called file extinguisher, but still uneraseable haven't yet found a solution.

    Any suggestions of how to overcome this problem ???
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Is it a U3 flash drive? You have to use the special U3 uninstaller program to get rid of that.
  5. jay2jay

    jay2jay TS Rookie Topic Starter

    I wasn't aware of the U3 technology till now. But i guess it it is as instead of having a launch pad with applications, it has got a partition of 18.9mb which is autorun automatically having a cdfs formatkind of read only.
    Than i did some sort of research of how to erase this u3 technology, and found a u3 eraser [COLOR="RoyalBlue"[/COLOR]
    but unfortanately it didn't regonize the flash drive.
    By any chance nodsu do you know any solution, or an application that would help me out.
  6. bmil

    bmil TS Rookie

    You bet! Google "U3 Launchpad" and you will find the "U3 Launchpad uninstaller". Used it myself and made the flash drive into a simple file bucket. It will now even work on 'public' machines that may block executables.
  7. brannigan

    brannigan TS Rookie

    bmil, I have the same issue with a hand me down drive. No protect switch or brand name on the drive. Your suggestion of it being a u3 device seems to be right on. The information describing the second drive letter, drive type and format matches. I tried the u3 uninstall and a program to reformat but neither will recognize drive. Any other programs you might suggest? The u3 drive has some read only files that I can't delete. Could this prevent the u3 uninstall?
  8. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    There are some competitors to U3.. Look at the apps and files on the drive and try to determine the exact kind of technology used.
  9. brannigan

    brannigan TS Rookie

    U3 file type?

    Nodsu, Are you saying that one of the files on the partition drive letter will have a U3 name or mention U3? A powerpoint presentation was placed on mine and all the files are read only, so I can't delete them or uninstall the U3 drive letter. I have tried several programs the claim to be able to access read only files but none have.
  10. brannigan

    brannigan TS Rookie

    did you find a fix

    Did you find a fix to your problem, I have a flash drive with the same thing and no luck?
  11. zuma

    zuma TS Rookie

    CDFS errase

    Hello Brannigan,

    Have you found a solution already for this. I search and search but can't find annything that works.

    Hope you can help me,
    Henri Brans
  12. brannigan

    brannigan TS Rookie

    no fix found

    I have tried many programs that claim they can erase the cdfs file on my flash drive. I even spoke to a developer of one of the products and he was stumped that his program wouldn't touch it. It doesn't take that much space but it's very frustrating. If I ever find a fix I'll post it.
  13. zuma

    zuma TS Rookie

    Which programs have you tried ?? or which program was suggested by a developer,??
  14. brannigan

    brannigan TS Rookie

    I had given up, so I don't have my notes. Just if you are considering buying a program that claims to be able to perform this function, get it in writing and I was not shy about talking to someone in person and using there name when I wanted a refund. The first reaction with refunds is hesitation. My situation was probably different than most. I received a drive as a promotion for a particular software. When you plugged it in a program demo would run automatically. It was unique and fun to use because it looked different than a regular drive but holding down the shift key so the program wouldn't run became just to much. I bought a regular drive with more memory and went on.
  15. clydieq

    clydieq TS Rookie

    I used a command promt and typed >format drive letter /fsfilesystem my line looked like this

    >format g:/fsfat32

    I now have a usable flash drive.
  16. david2008

    david2008 TS Rookie

    what is cdfs, can you tell me
  17. clydieq

    clydieq TS Rookie

    The CDFS format, or compact disk file system, emulates a CD-ROM drive--files are auto-played and organized, just like a CD.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...