hung at mup.sys and trouble booting up from cd-rom with shuttle XPC

By kchang001
Nov 8, 2004
  1. A friend of mine is having some system problem. Not sure if it is hardware or software related. He has

    Shuttle XPC G4300
    AMD Athlon XP 2400+ 266 MHz FSB
    S3 Unichrome
    256MB PC 3200
    Drive bay 1: 80 GB SATA 7200 RPM
    Drive bay 2: no drive
    52x CD-RW / 16X DVD
    On board 5.1 Sound w/SPDIF In/Out
    56K PCI modem
    Logitech Ultra KB8 Mouse combo
    Parallel Printer port
    No wireless
    No floppy
    XP home
    Works suite
    Open office

    He bought his system directly from Shuttle about 10 days ago. It ran well for the first few days. Then he put Open office and added a scanner. Couple days later his computer started rebooting automatically. Won’t go past the Microsoft bootup screen. When tried to go to safemode, the system hung on MPU.sys.
    I played around with his bios and nothing worked. Tried to boot up from his Shuttle XP recovery disk and it can’t find the hard drive. Shuttle website says to download the RAID driver and put it on a floppy disk and install during XP recovery. But the problem is my friend does not have a floppy disk drive.
    I integrated his recovery disk with the RAID drivers (viasraid.sys etc) and made a new boot CD. It went through hardware inspection, loading files etc and reached “examining 76534 MB drive on id0 on viasraid...”. about an hour later it said to push any key to restart windows and then the reboot cycle started all over again. I tried it one more time and it crashed after examining HD.

    Anybody has any idea how to fix this? I found that having to load the raid drivers before booting up from a CD really complicates the issue (at least for me).

  2. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    I would try repairing XP. I had this problem actually when my motherboard blew a few capacitors. But after getting a new mobo I had to repair XP anyway, so I'm not sure if it was hardware or XP related, but that is how I fixed mine. There is a thread located at the top of the Windows OS Forum that should have everything you need for repairing XP/2000

    :wave:Welcome to TechSpot:wave:
  3. Burned

    Burned TS Rookie


    There is nothing wrong with mup.sys if you see it on the screen. That means it has loaded succesfully. The problem is with your BIOS, the ESCD is corrupt. Re flash your BIOS and all should be good. :grinthumb
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...