Spread the love! TechSpot Tech Gift Shortlist 2017

I can only upload FTP files that are 1KB or less

By Rick ยท 20 replies
Jul 30, 2006
  1. This problem cracks me up. :haha:

    The issue...
    I can only upload FTP files that are 1KB or less.

    The cause... I think...
    I'm pretty sure this is because of a worm I removed from my computer (sqldbmanager.exe, worm.sdbot.sv), because I didn't notice this symptom until after I treated this. I 'repaired' all the damage done by this worm according to the virus encyclopedias I've found by reverting registry/system settings and deleting/fixing appropriate files. I noticed that this worm utilizes FTP to compromise and distribute information on host and client computers. So maybe this is tied together somehow.

    The details...
    This happens with multiple FTP servers and only on this computer. I can connect, change permissions via FTP, create folders and upload files smaller than 1KB. I can download the largest of files with no issues... BIN and ASCII modes work properly and while I usually use Passive mode, I've tried Port mode with no success. I tried directly through the modem as well as through the router without any luck. However, it works perfectly on my laptop using the same software and similar Windows setup.

    Here's a snippet from my SmartFTP log.
    Windows XP SP2 + latest updates
    FTP clients: SmartFTP, LeechFTP, FTP.exe (XP cmd client), IE integrated FTP function
    Firewalls and other network-altering utilities uninstalled.

    Additional stuff... (Updating this as the thread progresses)
    • Repaired my Winsock via the netsh winsock reset command.
    • Repaired my Winsock via LSP & Winsock Repair programs
    • sfc /scannow performed and passed
    • PASSIVE and Direct PORT modes - no difference
    • BIN & ASCII files using BIN & ASCII modes with different files - no difference
    • No log entries in eventvwr.msc
    • Reinstalled XP Networking Components (Add/Remove Components)
    • Replaced C:\Windows\System32\wininet.dll with an older copy from SP2.

    It's a weird problem and I'm stumped... I'll format if there's no answers - no big deal - but I like to find solutions. I'm hoping someone here understands more about Windows and FTPing than I do and might be able to come up with some possible reasons for this. :)
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hi Rick.

    I don`t know if it`ll help any, but if you want to post a HJT log, I`ll gladly take a look and see if there`s anything that shouldn`t be there.

    Regards Howard :)
  3. Rick

    Rick TechSpot Staff Topic Starter Posts: 4,572   +65

    Here's my HJT log, so you can see what's going on.
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Your HJT log is as clean as a whistle.

    It seems you`re not running any antivirus or firewall software, but I guess you already know that lol.

    Whatever you problem is caused by, it appears it`s not a current malware problem, or at least none that show up in your HJT log.

    All I can think, is it`s probably due to some damaged files caused by the worm you removed. Other than that, I have no ideas mate.

    Regards Howard :)
  5. Rick

    Rick TechSpot Staff Topic Starter Posts: 4,572   +65

    I actually uninstalled my virus scanner, network analyzer(s) etc.. while troubleshooting this issue. I don't run a software firewall on this 'workstation', but I did have one installed that I wasn't using. I uninstalled that one too. I haven't bothered to put any of it back on yet though. :)

    That's my idea too. I just wish I knew where to look. I tried uninstalling and reinstalling SP2. I haven't tried to repair Windows, but I might give that a shot just to see if it works or not.
  6. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Seeing as you wrote the instructions for how to repair Windows, that might not be a bad idea :p

    I suppose you could try running the sfc /scannow command.

    Regards Howard :)
  7. Rick

    Rick TechSpot Staff Topic Starter Posts: 4,572   +65

    I used SFC also while troubleshooting, no dice. :(
  8. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Maybe the worm did more registry changes than Trendmicro says. I didn't find any particular FTP settings from the registry though.

    msieftp.dll , from there with Dependency Walker. But I don't know if that helps as you've already scanned things with SFC.

    Does this happen with HTML form submits too (or with PHP) ?
  9. jobeard

    jobeard TS Ambassador Posts: 10,848   +897

    connect to the destination site and then issue

    it will cause the data transmission to occur from a private port rather
    than the default port 20.

    the other thing to try is to issue
    before the put, just to make sure that the file does NOT contain
    an embedded EOF (^Z)
  10. Rick

    Rick TechSpot Staff Topic Starter Posts: 4,572   +65

    I agree. The changes listed were correct, and I did 'reverse' them... But there may be others. :giddy:

    I'm able to upload to this board (for example) and I can use email attachment upload forms etc... I can also upload any file that's less than 1kb in size on any FTP server I have access to, which is interesting. :) Direct FTP access via IE appears to have the same issue with uploads.

    That's a very cool program. I checked out msieftp.dll with it and it gives me the following message:
    MSJAVA.DLL is missing and MPR.DLL appears to have a problem. I will investigate this.

    Unforutnately, it still happens despite using passive of port 20. A random port such as 36934 still has the same issue.
    This doesn't appear to make a difference either, interestingly enough. :)
  11. tweaks_sav

    tweaks_sav TS Rookie Posts: 186

  12. Rick

    Rick TechSpot Staff Topic Starter Posts: 4,572   +65

  13. Spike

    Spike TS Evangelist Posts: 2,168

    Have you only tried using your current program (smartftp) or have you tried XP's native FTP support also?

    Does another well known program (such as cuteftp) work ok? Obviously, I'm just thinking about narrowing it down to either a windows fault or an application fault. My apologies if I'm teaching you to suck eggs here, but you neverr know what's been tried. The other thing of course, is the question of whether there are any related entries in the application log of event viewer?
  14. Rick

    Rick TechSpot Staff Topic Starter Posts: 4,572   +65

    No eventvwr log entries. :(

    SmartFTP (2 versions), FTP.exe, LeechFTP and Internet Explorer's integrated FTP all exhibit the same issue - no files larger than 1kb can be uploaded. This includes BIN and ASCII modes for BIN and ASCII files, multiple files and multiple file types. Weird!
    :giddy: Don't worry about it. :giddy:
  15. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +419

    Don't do anything rash yet. For some reason I think I remember a problem like this before, but not how to fix it :(. Google searching shows others have had this problem too, but so far I haven't found a solution.

    Ok, thought of this.. Perhaps its essentially already been done during the above steps in some form. But go to Add/Remove Windows Components and then uncheck network services. Probably rebooting after doing that is a good idea, and then go back and check it, so it reinstalls that - obviously going to need the XP cd to do this.
  16. Rick

    Rick TechSpot Staff Topic Starter Posts: 4,572   +65

    Thanks for the idea. I gave it a shot and no positive results. Good suggestion though, as I hadn't done this yet.

    It got me thinking about some things so I started following some leads on the net, I replaced my slightly newer copy of C:\Windows\System32\wininet.dll with a fresh, older one from SP2. This did not work.

    My copy of Vista Beta looks awfully tempting! ;)
  17. Spike

    Spike TS Evangelist Posts: 2,168

  18. Rick

    Rick TechSpot Staff Topic Starter Posts: 4,572   +65

    LoL. That was a pretty good find.

    However... My laptop (which is connected to the router & Internet service) uploads large files perfectly, using the same programs. :knock:
  19. tweaks_sav

    tweaks_sav TS Rookie Posts: 186

    I know this is an old thread. Just curious if you ever figured out the issue. :)
  20. Rick

    Rick TechSpot Staff Topic Starter Posts: 4,572   +65

    I'm afraid not. :(

    I don't like to give up when it comes to computer problems, but I did give up on this one. I tried a direct connection to the Internet and two different wireless connections. Replacing various files and even a system repair. I uninstalled any and all network utilities and searched tirelessly online... nada.

    A fresh install sure fixed it though. ;)
  21. jobeard

    jobeard TS Ambassador Posts: 10,848   +897

    fyi followup on MSJAVA.DLL

    Back on 8-21-2006 you mentioned MSJAVA.DLL

    This is the MS JVM which had litigation results and was withdrawn as MS
    modified the Sunmicro version and violated the terms of the license.
    It is way, way down level and should not exist on XP/*.

    There are two missing DLLs that frequently show-up
    EFSADU.DLL file system encryption
    and that is how it should be.

    EFSADU.DLL is XP/Pro only and the XP/Home should not have one

    A missing DLL is not always fatal -- the fact that a specific DLL is present or
    has meaning to the software, eg: feature xyz is or isnot installed.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...