i cant burn cd or dvd????? only read!!

By rockwild3r ยท 7 replies
Dec 2, 2005
  1. i have a TSSTcorp CD/DVDW TS-H552B this driver will not burn any cd or dvd..only read :knock:
    i have tried to update the firmware..DID NOT HELP
    i tried a different burning prog..currently using nero 7 premium..DID NOT HELP

    when i go to MY COMPUTER..the dvd-rw drive is called a cd-drive type instead of a dvd-rw drive or something like that..

    Could anyone help me..it drives me crazy *** hell :hotbounce ..

    i have stuff to burn..my harddisk is getting pretty full..
  2. topsites

    topsites TS Rookie

    No but I have the same problem...
    Removed a 7-year single-speed burner (even thou I am sure it was still good) and put in a newer 52x32x52 burner (which IS a bit more pnp compatible) and same thing:
    The BIOS recognizes it as a CD-RW
    The Device Manager displays it as a CD-RW
    But, under Properties it just shows Standard CD-Rom...
    And of course, when attempting to copy files to it, nothing...

    I suspect it's something to do with XP myself...
  3. iss

    iss TechSpot Chancellor Posts: 1,994

    try uninstalling the IDE channel the drive is on and reboot. when windows restarts it will reinstall the ide channel and the drive.
  4. topsites

    topsites TS Rookie

    That was a good idea! Did that, but no...

    Here is what it says when attempting to copy, it gives me a simple:
    F:\ is not accessible.
    Incorrect Function.
    (and a button, of course).

    Here there is some bs:

    But I'm not using Roxio...
    Nero is a POS, v.6 came with it but it has probs...
    I thought with Winxp, there is no need for progs...
    There is one other thing,
    Under Properties there exists no Recording Tab.

  5. doomsweek

    doomsweek TS Rookie Posts: 39

    How about updating the driver? Does that burner support Windows XP?
  6. topsites

    topsites TS Rookie

    oh man I'm not going there, LOL! Fact is my old drive worked before but I suspected since it was a 7-year old single-speed writer that maybe XP and it were no longer compatible, as happens sometime when new meets old.

    Then, I found more bs:
    CD-R drive or CD-RW drive is not recognized as a recordable device
    This is good, has to do with when there is No Recording Tab !!!

    Ok, so then follow the steps, do a regedit and go to hkeyusers/software/etc
    and do as microsoft says and export something as backup...
    And so then under:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CD Burning\Drives
    There are tabs listing VolumeSSS (I have 2 cd's, thus I should have two volumes) but, I see only ONE Volume!!!
    ahhhhh, ohhhhh....
    Next step says check the value, should be 1 or 2 (1 = cd-rom, 2=cd-rw), now mine says 3....
    And, I have only ONE volume tab thou I have 2 cd-roms (one cd-rw)....
    Well, what the heck, change the 3 to a 2.
    Open My Computer, and the CD-Rom is gone but the cd-rw is there and lo and behold, under Properties now exists a Recording Tab !!!

    hmmmm, still, no E: drive (e and f my cd's)...

    lalala, let it finish booting and do another regedit, back to:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CD Burning\Drives
    And, now there exist TWO volumes :) :) :)

    Checking the values, first volume is now a 3, second volume is 1...
    Microsoft notes that If you have more than one CD-ROM drive, DVD-ROM drive, or CD-RW drive in the computer and the Recording tab is not displayed, an incorrect drive may have been configured as "recordable" in the Windows registry. To troubleshoot this issue, follow these steps:a. Follow steps 1 through 9 to edit the Drive Type value of the Volume{GUID} folder whose value you previously changed.
    b. In the Value data box, type 3, and then click OK.

    The drive type value of 3 indicates that the drive is a standard CD-ROM and is not writable.
    c. In the left pane of the Registry Editor window, click the next Volume{GUID} folder.
    d. Follow steps 7 and 8 to change the Value data entry to 1 or 2, depending on the drive type.

    So now it is a matter of remembering which volume is which, lol.
    But, progress... be right back :)
  7. Spike

    Spike TS Evangelist Posts: 2,168

    the burner doesn't need to support xp - it's ATAPI and shouldn't matter - at least not for CD's. It's winXP that needs to support it if anything. It's very rare for a modern ATAPI drive to be incompatible with XP - I've see it once though, but that thing was really out of the arc, and in any case, It was possible to get it working with many hours and much frustration.

    In any case, I've had that exact smae drive model, and continue to use it now. How long have you had the drive for? Did it used to work?
  8. topsites

    topsites TS Rookie

    The original is a Sony CRX100E, actually it is a 4x writer but I always used it at 1x to ensure coaster-free environment. Yeah it worked great until I switched from WinME to XP, then it worked a few times, more often than not it did not but I still think the drive itself is fine.

    The new drive is a LiteOn product... Just newer, is all...

    After I did the registry tweak, my only problem now is it says to insert a CD into the drive, I even went out and bought some Maxell GoldPro CD-R's and to make sure the quality was good, insert brand-new CD and still the same thing...
    But, I'm closer than the 'not recognized as cd-r' error...

    So a few tweaks later, it says:
    Cannot complete Cd Writing Wizard...

    ahhh, start the imapi thing from within services.msc

    And, it works !!!!
    It is burrrrrnning as I sign off :slurp:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...