I have a problem in setting up my LinkSys Router...help??

By torrenter ยท 10 replies
Jul 4, 2007
  1. I am using the LinkSys Router WRT54G and am trying to forward a port so that I can use utorrent effectively. I had everything working fine before I restored my PC to factory-shipped condition but now am stuck.

    I have followed the instructions in full at:


    This is a link that utorrent forwarded me to after saying that my chosen porrt was still not open.

    What I've done:

    I've set up a static ip address.

    I've even disabled all options on the security subpage of the LinkSys site/program/router. An example being unchecking the option, "Block Anonymous Internet Requests".

    The instructions also said I should uncheck the option "Enable uPnP Port Mapping" in utorrent which I've done.

    I've placed the certain port in the "Start" and "End" boxes under "Applications and Gaming/Port Range Forward" page, and placed my internal IP Address under it's heading, and ticked enable!

    Have I missed anything here? Help would be much appreciated
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Reboot the router. Make sure that the firewall on your PC is not blocking the said port. Make sure that your ISP is not blocking P2P traffic. Make sure that your ISP is not blocking incoming connections overall.
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +418

    You will also want to make sure you have the current firmware for that router. I had one for a couple years and had a problem very similar to yours, firmware update fixed it.

    If it still doesn't work after a firmware update post back, there is another firmware you can use that isn't official.
  4. torrenter

    torrenter TS Rookie Topic Starter Posts: 166

    Ok SNGX1275, after going to my router page (, in Address Bar), it notified me that my firmware version is "v3.03.6 - HyperWRT 2.1b1". Basically, I'm taking that as version v3.03.6.

    So what I've done is I've gone to the relevant LinkSys Downloads page, and I can see that there are 7 downloads for my router, or rather, there are 7 "Firmware Release Versions". Version 7 being the latest, released 17th Jan 2007.

    Is it correct that I should download that and install it? I don't suppose it's likely I'd have any major problems doing that, will it?
  5. jobeard

    jobeard TS Ambassador Posts: 10,840   +896

    Don't forget to ALLOW that/those ports inbound access in your firewall!
  6. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +418

    Actually I wouldn't do that until you read about it a little bit. HyperWRT and DDWRT are not the official firmware versions, and I'm not 100% sure you can go back to the officials after using othem... Maybe check if there is a newer HyperWRT release for your router.
  7. torrenter

    torrenter TS Rookie Topic Starter Posts: 166

    Jobeard, thanks for your help. I've started to use Trend Micro PC-Cillin and in the Firewall Exception list it says I've allowed Connections Out, on UDP and TCP on any ports, for utorrent. I would do this naturally anyway.

    The thing is, I think the .torrent files I've been using, usually use HTTP to connect. When I go to download the .torrent files it usually gives me the option between HTTP or UDP I think. I normally chose HTTP. However, on this latest file with which I have problems, I'm not so sure. It doesn't give me any options, no mention of HTTP,UDP or TCP. So I'm taking it that he program or .torrent file is specifically using UDP and TCP as I clicked it as OK when PC-Cillin asked permission for it.

    Oh, and SNGX1275, I really haven't got a clue, but what do HyperWRT and DDWRT stand for/do? What's the difference between them?

    Thanks again for any help guys.
  8. jobeard

    jobeard TS Ambassador Posts: 10,840   +896

    that's well and good, but the hispeed utorrent needs inbound and most likely UDP on specific ports for the utorrent client software.
    http uses tcp (ie: one and the same) but likely to be different ports as http is port 80 by default.
  9. torrenter

    torrenter TS Rookie Topic Starter Posts: 166

    Thanks again jobeard. There was absolutely no problem at all with my router. I should of investigated my firewall settings a bit more at the beginning. PC-Cillin's Firewall Security level is set to high by default. It does not allow incoming connections unless strictly entered as an exception. I've just set it up to accept everything utorrent. And following the instructions in forwarding a port at http://www.portforward.com/english/r...G/Utorrent.htm everything is now fine. Thanks jobeard and SNGX1275 again for all your help.
  10. jobeard

    jobeard TS Ambassador Posts: 10,840   +896

    feedback; fixed

    Actually, this is not only common, but the only rational default for any firewall.

    Glad you got it done and thanks for the feedback which helps other site vistors :)
  11. torrenter

    torrenter TS Rookie Topic Starter Posts: 166

    Sorry guys, to go over this again but I have more problems here. What I've noticed is that although I added the utorrent to PC-Cillins Firewall Exception List in every way, reset the router and all the rest of it, utorrents Port Checker now says that the port is closed.

    What I then did was see if there was something inherently incompatible with PC-Cillin and utorrent. I disabled/shutdown all of PC-Cillin and ran Windows Firewall, with utorrent on it's exception list aswell.
    And what happens, surprise!! The green tick comes back again, Portchecker says that it's my chosen port is open and nodes go flying up in number. Also the download speeds go up.
    BUT, this happens only for a while. The speeds then go systematically down but the nodes still stay high!! I'm then really left in limbo.

    What do you think I should do guys? I've only had this problem when I've started to use PC-Cillin after restoring my PC to factory-shipped condition. Before I did that I was running ZoneAlarm with no problems. I've also read on utorrent's website that there are supposed to be problems with my specific router and utorrent!! However, again I did not have this problem when using ZoneAlarm. I can only think PC-Cillin is the problem.

    Again, do you think I could be right here?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...