I have to assign a drive each time I use portable device

By Fitzerino ยท 9 replies
Aug 14, 2006
  1. I recently had a new Asus K8V-MX Motherboard fitted to my three year-old Mesh Matrix computer, since which time, no portable devices are seen in My Computer. They are picked up and correctly identified on the systray, but each time I want to use any flash drive or portable device I have to assign it a drive letter through Windows XP (Home Edition) Disk Management.

    Even then it is only visible in Windows Explorer where I can actually see and access my files. No portable device ever shows up in My Computer.

    If I unplug the device and plug it in again, without having rebooted, although the letter still appears in the list of drives, I have to add a new letter to the same device in order to be able to see the files on it once more. If I reboot, the drive vanishes, and I have to start over again.

    Is it perhaps something strange in the Registry that may be causing this?
    All devices work, the USB port settings are fine, but it cannot automatically be seen.
    I have tried reloading the chipset from the motherboard CD and have also added the Registry tweak so that all unused USB devices can be seen, have then uninstalled then allowed them to reinstall themselves.
  2. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    load the correct drivers for device
    check in the hardware environment look for yellow ? on a device
  3. Fitzerino

    Fitzerino TS Rookie Topic Starter

  4. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    how many drive letters are already existing before the removable media is attached and are the consecutive?
  5. Fitzerino

    Fitzerino TS Rookie Topic Starter

    There are three drives C, D, and E, the last two are CD/DVD drives. No more are taken up, and any drive I assign to a portable device never stays after a reboot.
    If I unplug the device without rebooting, then the drive appears in the list but if I replug in the device, it displays the sign:
    "K:\ [or whatever drive] refers to an invalid path, which is not available at the moment.
    It may be a harddrive or network drive. Please assure that the media
    is inserted correctly, or that the internet connection is up and
    running and repeat the process. It may be that the information was
    moved into another place, if the path stays invalid."
  6. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    move D,E to G,H

    removable STORAGE tries to be assigned as LOW as possible and BEFORE
    slower devices :)

    I have C(hd) D(thumbdrv) E(usbHD) F(cd/dvd) and the assignments hold across reboots.
  7. Fitzerino

    Fitzerino TS Rookie Topic Starter

    I'm reluctant to tamper with the CD and DVD drives which have always been where they are. I don't understand why the automatic letter assignment has been lost, and it's that inability to assign and keep a letter which is the main problem. It worked perfectly before.

    Why did you change the assigned drives for your CD/DVD drive? Were your portable devices having problems?
  8. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    yea, MS drives me nuts too. one would think there would be simple solutions
    but realize that MS has more lines of program code than even IBM so it's bound to be complicated.
    to make it work :)
  9. Fitzerino

    Fitzerino TS Rookie Topic Starter

    So you were having problems with your portable drive too? Was it a problem with assigning the drive like mine?
  10. Fitzerino

    Fitzerino TS Rookie Topic Starter

    I've had this problem for about a month now, and have trawled many computer-related forums. The closest I've come to anyone having the same problem, let alone a solution, has been in this thread:-

    However, it seems that the guy went out and bought new USB ports(?) which I'm pretty sure is not the answer, as I'm fairly certain that all the hardware works fine. Devices are always recognised and correctly identified, and all portable devices do what they are supposed to do on other PCs.
    The ONLY problem is assigning and keeping a drive for the device.

    I can't believe I'm the only person ever to have had exactly this problem.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...