I Need Game Cube Help

By yodafly3000
May 25, 2007
  1. My game cube works fine with all of my games but gives the 'cannot read disk' error message every time I put in my action replay. The action replay is brand new so I know it's not that, and my game cube hasn't been dropped and doesn't have any cracks. Please help!!!
  2. chamillitarysk8

    chamillitarysk8 TS Booster Posts: 128

    try returning the action replay the one you got may be defective
  3. yodafly3000

    yodafly3000 TS Rookie Topic Starter

    I have already done that three times =( None of them worked... But thanks for the reply.
  4. MetalX

    MetalX TechSpot Chancellor Posts: 1,388

    That happened to me too. I think some gamecubes are unable to read action replay discs. Because it worked in my friend's gamecube but not mine. Do you have a silver gamecube? Because that's the kind I had and it didn't work. I know the silvers are a little different because they don't have a component video out on the back...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...