IDE Driver Problem

By 40 oz. ยท 6 replies
May 20, 2002
  1. Driver Problem

    I'm having a problem with and IDE driver I installed for my Hard drive. The IDE controller was previously installed incorrectly and i had the wrong drivers for the device, so I downloaded the right set of drivers and installed again. What turned out was the old Ultra IDE channels stayed with the new primary and secondary IDE channels and the updated controller. I removed one of the old IDE channels and that was the two cd rom drives so the conflict was resolved for the secondary IDE channel. But there is no remove option for the IDE channel for the hard drive. Now the Primary IDE channel and the old ultra IDE channel are having a conflict on the same interrupt. The computer operates fine but i can't remove the old ultra IDE so the updated primary IDE channel would work. I tried safe mode and also tried installing another driver for the old IDE driver but nothing would remove it. The driver message for the old IDE channel is that the driver is not loaded or not needed so I do not have an uninstall driver option in the driver details page. The pic of what the problem looks like is included. The motherboard is a Iwill KA266 with an ALi Magik 1 chipset. Any suggestions is appreciated.

    Attached Files:

  2. Classified

    Classified TS Rookie

  3. 40 oz.

    40 oz. TS Rookie Topic Starter Posts: 17

    The drivers on Iwill's website are the same ones i downloaded. Its not a deal with installing them its just with getting rid of the old ultra IDE channel with my hard drive on it so the new one can work properly
  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Are you seeing these duplicates in

    HKEY_LOCAL_MACHINE \ SYSTEM \ ControlSet001 \ Control \ Class \ {4D36E96A-E325-11CE-BFC1-08002BE10318} \

    HKEY_LOCAL_MACHINE \ SYSTEM \ ControSet001 \ Enum \ PCIIDE \ IDEChannel \

    HKEY_LOCAL_MACHINE \ SYSTEM \ ControlSet002 \ Control \ Class \ {4D36E96A-E325-11CE-BFC1-08002BE10318} \

    HKEY_LOCAL_MACHINE \ SYSTEM \ ControSet002 \ Enum \ PCIIDE \ IDEChannel \

    as well?
    You could try removing (or renaming, a bit safer) the duplicates if they're present.

    Also, if you're running XP, you could try System Restore or its driver rollback feature.
  5. Classified

    Classified TS Rookie

    try removing the ALI bus master IDE controller and rebooting.
    The bus master controlls all of the other IDE devices listed.
  6. 40 oz.

    40 oz. TS Rookie Topic Starter Posts: 17

    Mictlantecuhtli the keys you listed are the only ones present in my registry, do you mean the same keys under controlset001 and controlset002 or two of the same keys under one controlset... i'm getting confused, well if you do get to read this post again please reply thanks. And i already tried to remove the host controller but windows just reinstalls it at boot up and then the same problem occurs.
  7. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    I meant two of the same (similar) keys under each controlset. I think the other (002) is just a backup. This is beginning to feel like the best option is reinstalling..
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...