1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

IE Fails to keep Cookies

By PHATMAN5050 ยท 18 replies
Jan 1, 2003
  1. This problem started yesterday out of the middle of nowhere. None of my sites are keeping the cookies, everytime I want to post here I have to login again, and everytime I close the browser and come back it says 'Click here to register' as if I'm a new member again. This is the same on the other forums I am a member of. I still have over 4 gigs on my primary hd so it is not lack of space. Any ideas?
  2. StormBringer

    StormBringer TS Rookie Posts: 2,244

    I'm sure you have already checked, but if not, check to make sure IE is still set to accept cookies. Something may have caused these settings to change. Also check your security settings in Internet Options.
  3. PHATMAN5050

    PHATMAN5050 TS Rookie Topic Starter Posts: 593

    Still no luck...Rather aggrivating though :rolleyes:
  4. StormBringer

    StormBringer TS Rookie Posts: 2,244

    forgot to mention it before, but what about the Privacy tab. I recently discovered that the reason why some of the ads here don't show up is because they use cookies which don't have a privacy policy or something like that. Anyway, the privacy settings also have cookie controls and could have been changed. If you use a firewall, you may also want to look at its settings to see if anything relating to cookies has been changed.
  5. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    One other thing to check is if you have installed a firewall recently. This could be setup to not allow any cookies to get in. So check that.

    But if it just happened out of the blue, that is kinda weird. I am sure you are using anti-virus, and being smart online, etc., but you might have gotten some funky program.....
  6. PHATMAN5050

    PHATMAN5050 TS Rookie Topic Starter Posts: 593

    I put the bar on LOW and added this site to the ALWAYS ALLOW and still no go... :evil:
  7. PHATMAN5050

    PHATMAN5050 TS Rookie Topic Starter Posts: 593

    This seems to only be happening with forums and logging into them, so any ideas?
  8. conradguerrero

    conradguerrero TS Rookie Posts: 310

    what other sites are doing this not logged in stuff?

    If you are linking to these forums through an old link (pre-server move) then you will have to log in every time.

    If this is the problem then just log in through the new url.
  9. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +7

    try some of the following:

    I would try setting the internet zone to default settings.

    if any web sites are mentioned in trusted or restricted sites, remove those.

    a custom level of "medium" is also good for internet zone.

    also, go to "privacy" tab. hit advanced. tick "overide automatic cookie handling" make sure first party and third party are ticked to accept. ensure that "allow session cookies" is ticked.

    as a last resort, try backing up your profile (if you are using windows 2000 , XP, etc) to another folder, and then logging on as another user in the administrators group. delete your profile, log back on as the username you usually use, and the profile will be regenerated. all profile settings will return to their defaults. see if the problem resists then.
  10. Greeno

    Greeno TS Rookie Posts: 281

    You're not using 2k, or XP and are now logged on as someone else ? - this would affect it right ?

    and/or you're not using any sort of firewall that maybe preventing cookies, i know you say IE's set how you'd like, but there maybe something else overriding it.

    -or- lastly, you've not got a virus have you ?
  11. PHATMAN5050

    PHATMAN5050 TS Rookie Topic Starter Posts: 593

    Nope, still didn't work phantasm. :(

    I guess my profile is damaged but how could this happen out of the blue? And yes, I'm using winxp pro.
  12. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +7

    first log in as another user with admin rights and check if the problem persists. if not, then its your profile that's to blame. in which case, do the following:

    try a fresh profile.

    first, create a folder to keep a backup of your old profile in.

    right click my computer, select user profiles, highlight your profile and click copy to.

    browse to the local of your folder you created. under "permitted to use" select everyone.

    once the profile is copied, log off and log on as another user with admin rights. go back into user profiles, select the username you usually use (i.e. the one you think has the profile problem) and then select delete.

    once deleted, log back off and log back on as your usual account. the profile will be regenerated, including a new ntuser.dat file which is imported into the hkey_user part of the registry when you log on. this fresh profile will resemble the default windows settings that you got when you first installed windows.

    go into the folder containg your older and restore desktop items, favourates, etc.

    the suggestions that i made were based on looking through knowledge base on microsoft's web site. there wasn't a lot of information, which is surprising since my search parameters were fairly wide. i could not find any more information than i posted but i may have overlooked something.
  13. PHATMAN5050

    PHATMAN5050 TS Rookie Topic Starter Posts: 593

    I signed on as 'administrator' and the problem still persisted. :evil: So aggrevating. Now what should i try?
  14. palmboy5

    palmboy5 TS Rookie Posts: 71

    switch to some other browser;)
  15. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +7

    general information about cookie management in IE is here : http://support.microsoft.com/default.aspx?scid=kb;en-us;283185

    i am sure that you must have a "block all cookies" setting somewhere....

    the changing user thing may not work perhaps because settings there refer to the computer as a whole and are not per-user.
  16. PHATMAN5050

    PHATMAN5050 TS Rookie Topic Starter Posts: 593

    As quickly as this has come, it has left. For some reason, I just attempted to sign into the forum, but did not need to. The cookie has been saved.
  17. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +7

    That must have been one of the things that you tried....
  18. iss

    iss TechSpot Chancellor Posts: 1,994

    Maybe IE just had the Flu and thats why it was tossing it's cookies.puke:
  19. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Have you checked your partition for errors? Maybe the cookie file is damaged. Maybe something/someone has set it to read-only or changed its security settings (if using NTFS). Apart from changing browser, that's about all I can suggest.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...