IE Networking problem

By gazzaoz ยท 7 replies
Nov 17, 2007
  1. I have a Toshiba Satellite 2400 with a D-Link DWL-G630 Notebook Adapter in it. The card has set up and I have established a wireless connection to my D-LInk DI-524 wireless router. This show excellent signal strength. I am using WPA-PSK security with TKIP encryption. Icon on bottom right of taskbar say connection is OK but I can not get Internet Explorer to connect to home page or any web page on Internet. Also Outlook Express can't find email pop server - I have tried different email accounts with known working Pop Servers. Does anyone know why I can't get Internet connection.

    My D-Link DI-524 via it WAN connection point is connected to Motorola SB4200 which is connect to Bigpond Cable. I also have a PC connect via 100BaseT to DI-524 and wireless bridge to my workshop where I have four PCs connected via a switch to other end of wireless bridge. All of these PCs can see each other and Internet with no problems.

    Any ideas anyone???
  2. davids

    davids TS Rookie Posts: 96

    To start with the best thing to do is to goto start menu > run > and type in cmd then hit enter (this should bring up the command prompt).

    Now type in ipconfig /all

    hit enter and it will give you your network configuration, here you can check that your network card has picked up an ip address from your router, it should be something like 192.168.x.x subnet mask will be 255.255.x.x and you should have similar address in gateway and dns.

    If this is so, then it confirms that you have entered the right encription key and your laptop has successfully communicated with your router. If this is not the case, you may have a problem with the wireless on your laptop or you may have entered the wrong encryption.

    If this is the case, try:

    if there is no reply, then the problem lies with your router/wireless card/firewall

    if you do get a reply, then the problem lies with internet explorer, so you need to check all the settings and make sure your computer is free of viruses.
  3. N3051M

    N3051M TS Evangelist Posts: 2,115

    gosh its been a while since i've touched my dlink...

    as the above advice, do the network test first, since it only takes a second. Then start troubleshooting, starting from the source.

    can you get internet access wired directly to modem?
    If yes, then connect the router and run its setup wizard, then try it again wired to one of its network ports. You should have got an extra network cable with your router. (any will do, i think that auto-detects what type and changes accordingly).

    If you get a connection, then try wireless without the security (for troubleshooting) then when thats successfull use the passwords and other filtering methods where needed.

    if you don't get a connection, then its probably a setting in your router or modem that needs to be fiddled with. I think i saw an option for bigpond users specificaly in the WAN setup or something. Can't be sure.

    FYI: you should be trying to ping your ISP first and formost ie: ping
    that will tell you if you have a connection to your ISP, since sometimes (for example you put in your password wrong) they'll block access to external sites untill you rectify any logon issues. Or the connection to google is down/bad (however unlikely)
  4. jobeard

    jobeard TS Ambassador Posts: 11,165   +986

    if your other systems are working nicely and ONLY one system is failing,
    then obviously the modem and router are ok and the configuration of the
    failing system is the issue.

    see this post for basic network debugging

    inspect the NIC adaptor settings and remove ALL static entries; you what
    DHCP for your IP address and DNS.
  5. gazzaoz

    gazzaoz TS Member Topic Starter

    Thanks all for your replies - the problem turns out to be an issue with WPA-PSK security/encryption. I used to be network design architect (CCNE) but never had anything to do with WPA-PSK. Even though both ends of link are D-Link products, WPA-PSK is still not 100% compatible at both ends. I tried no encryption and 128 bit WEP and all works perfectly. Thanks for your help and suggestions.
  6. jobeard

    jobeard TS Ambassador Posts: 11,165   +986

    Yes, compatability can be an issue for WPA when there's different brand names on each end of the connection -- should not be, but it is not the less.

    try updating the firmware and the drivers; it sometimes helps.
  7. gazzaoz

    gazzaoz TS Member Topic Starter

    I did update drivers and firmware. I thought with same brand for Laptop Card and Wireless Router, everything would have been OK but appears not.

    Has worked perfectly with WEP. I prefer to use WPA as it is more secure encryption/protocol.
  8. jobeard

    jobeard TS Ambassador Posts: 11,165   +986

    we all agree on this
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...