1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

IE6 /Windows XP

By anabol20 ยท 6 replies
Apr 8, 2003
  1. I have just upgraded from W98 to XP Pro (w SP1) and while my BT broadband connection is operating OK, I have a problem with additional web page links.

    I can access the first page of a web site no problem. If I then click on a link within that page, a new window opens but that is it! It goes no further even with a refresh etc. I get the same if I try to open uup a graphics file (jpg) on a web site. I have tried tinkering with Internet Options but with no success to date. Anyone have any ideas?

    Many thanks for any help.
  2. Nic

    Nic TechSpot Paladin Posts: 1,549

    Maybe you need to install a Java Virtual Machine (JVM). You'll find this at ...

    Sun JVM - Recommended

    Microsoft VM for Java - Old

    You might also want to try Windows Update.

    If none of these work then maybe someone else can help as I am all out of ideas.
  3. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    I had the same problem here

    The only thing I could think of that caused the problem is ad aware removed an important file that it shouldn't have. Unfortunately I deleted my quarinteened files and can't restore them. If you use aaw6 this might be why. I have yet to figure out a solution to it, so I use Opera which works for some reason.

    Sorry we haven't figured this problem out as it is VERY annoying.

    BTW, :wave: :wave: Welcome to TechSpot :wave: :wave:
  4. LaYkE

    LaYkE TS Rookie Posts: 16

    Everyone I know (including me) who has upgraded to XP pro has had some sort of problem. TBH, I would backup my info and do a clean sweep install.

    I did it and it's never given me problems since.
  5. Nic

    Nic TechSpot Paladin Posts: 1,549

    Upgrading from win9x to winxp is generally not a good idea, as you run the risk of having incompatable software on your system. Its always better to do a clean install. The same goes for any major hardware changes (e.g. mainboard) - do a clean install of your OS).
  6. TS | Thomas

    TS | Thomas TS Rookie Posts: 1,319

    Click on Start, Run and type in "regsvr32 urlmon.dll" (without the quotes).
  7. boseith

    boseith TS Rookie

    I had the same problem, I found these and they helped. I was untable to get it to work with just registering urlmon.dll, I had to go all the way to actxproxy.dll before mine started working again.

    Here is what I found that helped me, I will also attach the txt file.

    This behavior may occur for any of the following reasons:
    The (Default) value setting in one or more of the following registry keys points to an incorrect location for the Urlmon.dll file:



    This may occur if you install a customized version of Internet Explorer that was created with the Internet Explorer Administration Kit (IEAK) version 5.01 Service Pack 1 (SP1), 5.5 SP1, or 6.0.
    The following registry key is missing or damaged:

    One or more of the following files is missing, damaged, or improperly registered:
    To resolve this problem in Internet Explorer, follow these steps:
    Quit all programs that are running.
    Click Start, and then click Run.
    Type regsvr32 urlmon.dll, and then click OK.
    When you receive the "DllRegisterServer in urlmon.dll succeeded" message, click OK.
    If this does not resolve the problem, repeat steps 2 through 4 for each of the following files (in step 3, replace Urlmon.dll with each of the file names below):
    Shell32.dll (Windows XP and Windows 2000 only)
    If the problem is still not resolved, verify that the following registry values are present and correct:
    Name: (Default)
    Value: IDispatch
    Name: (Default)
    Value: {00020420-0000-0000-C000-000000000046}
    Name: (Default)
    Value: {00020420-0000-0000-C000-000000000046}

    Attached Files:

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...