1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

In game Graphics driver issue

By Miss Behavin ยท 7 replies
Aug 20, 2005
  1. Hey guys! I was wondering if you could help me!

    I have, a few days ago formatted my pc. Now it's come to installing my stuff (stuff being a very techincal term :( ) Anyway I have installed one of my games that is prob the one I need most. MOHAA. But this is what it looks like in game


    Not very useful to me... I don't actualy get to play the game much to be honest but I do admin a couple of leagues and need to go in and be able to spectate games regular.

    I have had this problem before after formatting it is not a dodgy format or anything along those lines. How I sorted it before I really don't know I was messing about with it for about 3 weeks and sorted it by accident :blush:

    I have installed all drivers from the my cards CD and it still looks like that above.

    I have also used the ati cat uninstaller and then gone to the site and downloaded lastest cat.

    I am just about pulling my hair out now. I really don't have a clue.

    I am using a ATI 9600
    Windows XP
    Service pack 2
    AMD Athlon XP 2200+ 0.79GHz
    768 MB RAM

    Could anyone help me? Please??
  2. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,372

    Do a full format, then install Windows, Service Packs, motherboard drivers and then the latest Catalyst drivers from ATI's site. The drivers that come with video cards are always out of date.
  3. Miss Behavin

    Miss Behavin TS Rookie Topic Starter

    I have formated 4 times and done all that you said hun. still no joy.
  4. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,372

    Do you by chance have an nForce chipset motherboard? They seem to have compatability issues with Radeon 9600 series cards.
  5. Miss Behavin

    Miss Behavin TS Rookie Topic Starter

    Erm....I don't think so.

    My motherboard failed not so long ago and I went to the local shop and brought a jetway motherboard. Not a highly thought of one I know. But money was tight.

    The Graphics card has worked with this motherboard tho and ran the game.

    I have not changed anything in my computer for over 6 months. This problem only occurs after a format.

    I think it's drivers. But I am installing everything from the disk and updating them with latest catalyst from ati site. There are no problems with anything when I look in device manager.

    I do not understand what I am doin wrong. It must be something really simple tho LOL
  6. mailpup

    mailpup TS Special Forces Posts: 7,323   +591

    Maybe it's just the way you worded your post but did you uninstall your old cat driver and install the XP generic driver before going to ATI to download the latest Catalyst driver? If so, did you uninstall the generic driver before installing the new driver.?

    I always have the new Catalyst driver ready before I uninstall the old one. When XP asks if I want to install a driver, I cancel and instead go to install my new Catalyst driver from "Run."
  7. Miss Behavin

    Miss Behavin TS Rookie Topic Starter

    Well I finally gave up and took it to the shop today guys...I am ashamed to say but it was driving me mad.

    Basicaly I needed to unistall my ATI utility from add remove progs (not the disk or divice manager!) I then needed to update my VIA drivers then install my new cat.

    I was installing new cat before but, well even tho I thought all the drivers for ATI had gone and I could find none there were still some there installed by windows.

    ATI cards are fussy is all the guy in the shop said to me LOL My reply was ATI made me cry!

    He also told me not to install the drivers of anything for my card off the disk....if you ain't supposed to install anything off it...why do they give you one for your card!

    But anyway I am sorted and my rant is over! Many thanks for the replies for trying to help.
  8. Method

    Method TS Rookie Posts: 20

    u tried reinstallin AA?

    just looks like corrupt pk3 files
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...