Incompatible hard disks?

By Rick
Jul 14, 2002
  1. First, some relavant system specs:

    Windows XP Professional
    MSI K7T266 Pro2 - Latest BIOS
    VIA 4-in-1 v4.36a (*Tried each version through to the newest ones)
    Western Digital SE/JB 80Gb 7200RPM
    Maxtor 540DX 40gb 7200RPM

    I just recently got an 80Gb Western Digital Special Edition and plugged it into my motherboard, along with my Maxtor 40Gb on the same ATA-133 channel.

    Here's what's going on:

    WD => Master
    Maxtor => Slave

    When copying files, it gives me a bad cylinder error, saying it cannot find the file. This only happens to the Maxtor (Doesn't affect the WD) and seems to be most frequent with files located deep within the directory structure.

    I replaced the IDE cable, tried the other IDE channel.. Still the same problems unforutnately. Reversing the Maxtor's position to be Master instead of slave does not seem to help. As long as it is hooked up to the WD, it gives me cylinder errors. I also tried manually inputting the heads/cylinders, but it has the same problem.

    The second part of this problem is booting up with the WD causes the initial post/boot screen to hang for a minute. Whether I have the BIOS setup on auto-detect or manually input the values, this hang occurs regardless.

    When the drives are setup in such a way that they do NOT hang at post, the Maxtor gets cylinder errors when I copy files.

    When the drives are setup in a position that they DO hang, it works fine again.

    I'm confused?

    I just want to be able to get rid of the post hang and still be able to use my Maxtor without cylinder errors simulateously. It seems like I can only do one or the other, but I can't get both problems solved at the same time.

    I'm going to play with it some more and maybe give some pertinent information.
  2. Rick

    Rick TechSpot Staff Topic Starter Posts: 4,572   +65

    Well, I managed to find a combination that works correctly.

    Primary Channel
    Secondary Channel

    This solves my problem, but I'd still like to know why the cylinder errors happen in other combinations. If anyone has had a simliar problem or has some guesses, freel free to spew out any ideas.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...