install java in fedora.

By focus_water · 4 replies
Mar 29, 2007
  1. ive tried for 2 days now. im trying to install java. i tried following the instructions in the java site but it still didnt work. i ran the install package in the terminal and it created a file in the root folder. i remember i got it working in ubuntu one time but im pretty sure it is diffrent in fedora and i dont even remember how i did it anyway.
  2. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    so; what steps did you complete and what went wrong on the last step?
  3. focus_water

    focus_water TS Rookie Topic Starter Posts: 168

    well i tried again and this is what i did. i put the rpm.bin file in usr/java i changed the permissions so it can be executed and i ran it in the terminal and it came up in with the License Agreement then it made jre-1_5_0_11-linux-i586.rpm and when i opened that it said /usr/java/jre-1_5_0_11-linux-i586.rpm is already installed.

    i dont know if that means java is already installed but when i do the test on the java site it says it isnt installed.
  4. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    rpm.bin is just a downloadable chuck
    /usr/java/jre-1_5_0_11-linux-i586.rpm is the installer package

    ... it said /usr/java/jre-1_5_0_11-linux-i586.rpm is already installed
    this is from the RPM installer point of view. Try to find the documentation,
    as I recall, you need an environment variable to point to the RTE location.
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You are mixing up things.

    On the command line, run the command "java". If it runs, you have Java installed. The Firefox/Opera/Konqueror/whwtever Java plugin that would let you run Java applets on websites is a separate thing to install.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...