Installing Linux display drivers

By Vehementi ยท 8 replies
Dec 15, 2002
  1. Since my copy of Red Hat 7.2 doesn't seem to have built-in support for my Radeon 8500, I kind of need to download display drivers from here. My problem is...

    How in the heck do I do it??

    RH7.2 is all installed & ready to go, it's just that it boots into the command prompt, not the X windows system: KDE or GNOME.

    Should I burn the drivers to a CD-RW? Or should I make a floppy disc? If I make a floppy; will Linux be able to read Windows' file system?

    Thanks in advance.
  2. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    It's an RPM ( RedHat Package Manager ), which is kinda the equivalent to InstalShield for Windows.

    In order to install, you have to position yourself in the directory containing the RPM & type :

    . rpm -ivf fglr200-glc22-4.2.0-1.4.3.i586.rpm where I = install, V = verbose & F = I no longer have the slightest clue.

    ( Linux Gurus, help with the parameters, I'm not sure it's -ivf ).

    You can now configure your VGA/Screen options with an utility such as Xconfig & once you're done StartX should start the default Window Manager.:)
  3. Vehementi

    Vehementi TechSpot Paladin Topic Starter Posts: 2,704

    Well now that I've got the RPM all up and running...

    ...I've got another problem.

    After I run through the whole of fglrxconfig, and make a new XF86Config file, I run "startx."

    This is supposed to start X, is it not? Well, it doesn't, and instead returns me to the CLI with this error message:

    fatal server error:
    no screen found


    X10: fatal IO error 104 (Connection reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining.

    :( Help!
  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Check the lines beginning with "(EE)" in /var/log/XFree86.0.log (or was it .9.log) and post them here. I think your card isn't configured properly in /etc/X11/XF86Config-4.
  5. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    if you have edited /etc/X11/XF86Config-4, try moving the /etc/X11/XF86Config file to another directory (say create a directory called /etc/X11/old and move that file in there, keeping /etc/X11/XF86Config-4 in its original place with the correct changes.)
  6. Vehementi

    Vehementi TechSpot Paladin Topic Starter Posts: 2,704

    I really wanted to fix this just to say I could...but it sounds like a little, stupid problem to me and I'll just wait for RH8 to come...which it will be in a few days.
  7. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    but that way you will never learn.
  8. Vehementi

    Vehementi TechSpot Paladin Topic Starter Posts: 2,704

    True phant, but I think I have bigger fish to fry ;) I'm not going to be using the CLI, because that's just not an operating system to me, and I could never find a use for it. But, then again, I could have a job in the future like yours Phant, where I would have to deal with Unix...

    Leave it up to Phant to make me fix the damn thing.

    K, I'll boot into Linux and do what both of you said...
  9. Vehementi

    Vehementi TechSpot Paladin Topic Starter Posts: 2,704

    OK, it's done...and...

    Moving the original XF86Config file into /etc/X11/old didn't work. It was not XF86Config-4...

    There were 3 errors in /var/log/XFree86.0.log:

    (EE) module ABI minor version (5) is newer than the server's version (4)
    (EE) failed to load module "fglrx" (module requirement mismatch, 0)
    (EE) No drivers available

    The Linux CLI seems so much more familiar now...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...