Interesting POST beeping... what is it?

By MexieuS ยท 8 replies
Sep 8, 2007
  1. EDIT: Updates posted below! New issue detected...

    Hello, I just built my first PC off an MSI K9NBPM2-FID. I'm getting beeps when I turn on my computer and after reading all the AMI beep code explanations I'm conflicted over what they mean. It's two quick beeps (about a half-second apart), but it's sometimes followed by a longer beep (probably signaling the end of the POST test?) I'm reading that the two short beeps might be a memory failure, but the one longer beep means it passed the POST tests...

    Here's the situations. I have the following dual-channel memory, rated @ 2.2v:

    2 x Patriot 1GB - PDC22G6400LLK
    2 x Patriot 512MB - PDC21G6400LLK

    With all 4 DIMMs in, the computer won't even go to the POST screen... just blank. Does it matter that two are 1GB and two are 512MB? I made sure to match them in pairs for the dual channels...

    With the 2 x 1GB DIMMs in, i hear two short beeps (see image below) and then it boots-up fine. However, if I set "Quick Boot" to disabled for those extra diagnostics, I get one more solid beep right when it switches to load the boot disk and boots up fine.

    With the 2 x 512MB DIMMs in, I still hear the two short beeps, but it doesn't matter whether I have "Quick Boot" enabled or disabled, i always get that longer lower-pitched beep just before it loads the boot disk.


    (in the picture, i had 128MB set aside for VGA, so 1920MB sounds right)

    I have tried each DIMM seperately in slot one, then each one in slot 2, and I'm always hearing those two beeps. I ran memtest86 which found no issues.

    I also disconnected all my PCI cards and SATA/IDE drives, but always the same two beeps.

    When I load the performance tab under task manager, it always reads the correct amount of memory (1984mb or 960mb with 64mb set aside for VGA in BIOS).

    The one thing I wasn't sure about in the beginning was what to set the voltage at safely. it's been at 1.9v since I built it (BIOS default), so I thought raising it to 2.15v might fix the problem and even make it to POST with all four DIMMs in (Anything 2.2v and over in the BIOS reads out "not recommended settings, the system may be unstable" but maybe if the RAM is rated at 2.2v it's ok?)

    Thanks for taking the time to read all this, I hope you can help me figure this out!
  2. MexieuS

    MexieuS TS Rookie Topic Starter

    I already tried them paired though... here's something I read in the manual: it says "in dual-channel mode, make sure that you install memory modules of the same type and density in different channel DDR DIMMs."

    does that mean all four slots must have the same 1GB in each? because what I'm trying right now is 1GB in slots one/two and 512MB in slots three/four... I don't understand why that wouldn't work though...

    Thanks for your help
  3. MexieuS

    MexieuS TS Rookie Topic Starter

    Well, i got the board to recognize the memory. I didn't realize the cards had to alternate '1GB, 512MB, 1GB, 512MB'. I still have those two short beeps though, right before it shows "2944MB OK" , followed by the single, longer beep at the end of the POST.

    I noticed this line right before checking NVRAM: "Bank interleave requested, but not enabled"

    Before it was doing the single beep without this line, now it seems to be doing the beep AT this line.
  4. MexieuS

    MexieuS TS Rookie Topic Starter

    Ok, another update! After searching for the Bank Interleave Error, I came up with this:

    "Bank Interleave Requested But Not Enabled:

    This message appears during POST on a system that contains only one pair of single-rank DIMMs on one CPU. This type of configuration does not support bank interleaving."

    What does this mean exactly? If it helps, I'm using a dual-core AMD 64 X2 5600. I tested having just the 1GB DIMMs in the yellow slots, then i swapped them out with the 512MB DIMMs in the yellow slots. Both times, there was no error. So, only with all the slots full do I get this error.
  5. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    please bother to read the bios beeps guide in the guides forum
  6. MexieuS

    MexieuS TS Rookie Topic Starter

    That's the problem, the codes conflict. it shows 2 short beeps being a memory issue, but the one long beep meaning everything is fine...I'll definitely post details one this is all figured out.
  7. MexieuS

    MexieuS TS Rookie Topic Starter

    UPDATE! so I figured out the beeping-- and why it was happening at the USB controller initialization. There is a single beep for each USB device plugged in. Obviously the first time I thought I had unplugged everything, I left the USB mouse and printer plugged in. But, there are still issues. In order to make use of the dual-channel memory, here's what the manual says:


    Now, here's what the board looks like:


    Interestingly enough, with the 1GB sticks in the green and the 512MB sticks in the orange, start-up shows "DRAM Clocking = 800HMz, Single-Channel"

    I decided to try once more with my initial setup of what the manual shows, and this time it booted up!! I'm not sure why it wouldn't boot up with this same configuration before... I tried multiple times. I have the 1GB sticks in banks 1/2 and the 512MB sticks in banks 3/4, and on start-up I see "DRAM Clocking = 800HMz, Dual-Channel".

    But wait, there's more. I am still seeing the "Bank interleave requested, but not enabled" error at start-up. I have narrowed this error down to the 512MB sticks. I never get it when I have just the 1GB sticks in slots 1/2 or 3/4 or 1/3. I also don't get it when I have just the 512MB sticks in slots 1/3. But, with the 512MB sticks in slots 1/2 or 3/4, I see the error.

    I tried reading up on bank interleaving, but I think someone here would be more knowledgeable than a beginner like myself. Is this an issue with my 512MB DIMMs? Is this error to be expected with anything less than a 1GB DIMM?
  8. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    when all else fails RTFM...
  9. MexieuS

    MexieuS TS Rookie Topic Starter

    Again, there is nothing in the manual regarding this bank interleave error...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...