Intermittent "Automatic" Reboot - bugcheck with dump

By jemorse ยท 17 replies
Mar 17, 2005
  1. I have experienced 7 BSOD events since 2/27/2005. System events log shows these are reboots from a bugcheck.

    The computer has rebooted from a bugcheck. The bugcheck was: 0x0000000a (0x00000000, 0x00000002, 0x00000001, 0x8042def4). Microsoft Windows 2000 [v15.2195]. A dump was saved in: C:\WINNT\Minidump\Mini031605-01.dmp.

    I did obtain and run the Microsoft debugger, but, not getting too much information that means anything to me. The debugger does say

    BugCheck D1, {eabe0114, ff, 1, 8204204a}
    Probably caused by : ntoskrnl.exe ( nt!KiTrap0E+27c )

    I have attached the most recent dump (3/16/2005) after changing the dmp extension to txt.

    Any clues as to what may be happening would be appreciated.

    As I haven't added info to my profile yet, the computer is an older IBM Thinkpad A22p running Windows 2000 Pro. I have NOT changed any hardware for a long time. And I have not added any new software recently. However, some of the software does update itself - for example Webroot's SpySweeper, Panda Platinum....


    Attached Files:

  2. dopefisher

    dopefisher TS Rookie Posts: 444

    hmm have you tried reinstalling windows?
  3. jemorse

    jemorse TS Rookie Topic Starter

    Well - not yet... I would like to have some indication that the problem is software related and not hardware related or that the problem is related to a specific software module that could be solved without requiring a Windows re-install.
  4. jungle_p

    jungle_p TS Rookie

    I have had similar problem over past 2 months. I have windows 2000 SP4.

    Event Viewer:
    The computer has rebooted from a bugcheck. The bugcheck was: 0x00000050 (0xfe8ade0c, 0x00000000, 0xbf7ef405, 0x00000000). Microsoft Windows 2000 [v15.2195]. A dump was saved in: C:\WINNT\Minidump\Mini032305-02.dmp.

    Problem started early Feb 2005 after I did a windows update and installed several critical updates. Computer would automatically reboot if I loaded it up heavily, usually while on the internet (several programs open + lots of tabs/windows in browser). I eventually isolated problem to windows 2000 hotfix KB891711. Problem disappeared when I uninstalled this hotfix. I tried reinstalling the hotfix latest version (Mar 8 2005) in case problem had been fixed. But problem reappeared. So I have removed this hotfix and do not intend reinstalling.
    Check to see if you have installed this hotfix (control panel, add/remove programs), and uninstall it if you find it. See if that helps.
  5. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Hi Jemorse,

    The minidump is snapshot when the windows unless the analyse reportof the crash shows that is is hardware error or have the failing device driver name. Usually the failing routine is ntoskrnel and win32k.sys. Unless you have a lot of windows debugging experience otherwise it is very difficult to find out culprit.

    Usually we need 4 to 5 minidumps to whether it is hardware or software. Hardware error usually occurs randomy, hence the failing instruction at each dumps is different. Software error is usually consistent and you will find the failing instruction address and the bugcheck code is the same.

    The failing module of your last minidump nt!KeWaitForSingleObject which is different to another case nt!KeTrap0e. Usually crash at nt!KeTrap0e is caused by hardware error at the motheboard, CPU or RAM.

    If you zip all the dumps and attach zip files, I can confirm whether it is hardware or software error.

    My suggestion
    1) Upgrade ATI display card driver because it is 4 years behind
    2) Download memtest and stress test the ram (
  6. jemorse

    jemorse TS Rookie Topic Starter

    Mini-dmp sip files attached

    Thank you for your information. Per your request I have attached a 5 zip files which contain 2 mini-dumps each - 10 minidmps total with most recent for April 5 and the oldest for March 15.

    I will have to figure out how to get and apply an updated driver for the ATI display - my computer is an IBM A22p Laptop. I will try this suggestion after I have done some research on doing driver updates for it.

    It does seem that the errors only occur when I am on-line for some length of time with several windows open - FireFox, PocoMail, MailWasher, etc. I am also using Panda Platinum for my anti-virus and firewall. This is similar to the experience of jungle_p in the previous post. While I do have SP4 I do not have the hotfix that jungle_p referenced.


    Attached Files:

  7. IronDuke

    IronDuke TS Rookie Posts: 856

    Updates for IBM, at least on an x24 are a doddle.

    Open Access Support should be under programs and the click Get Software Updates. Finally IBM Update connector.

    It is all automated from there on.

  8. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    There have 6 occurences which has the same failing instruction and the failing routine is KeWaitForSingleObject

    If KeWaitForSingleObject crashed it's because
    A) someone pased bogus parameters (not the case ehre since it's call by the Nt API which does full parameter validation
    B) something corrupted memory and clobered a random structure - KeWaitForSingleObject is the victim.

    Since corrupted memory occurs randomly, I think most likely it is software driver issue. From the stack trace and there has no footprint for any device driver. The stack trace have the footprint of IocreateFile and I believe that it is related to firewall Teefer.sys. One crash is also caused by Teefer.sys
    Would you un-install Teefer.sys and install other firewall utility

    Debug report
    Mini031505-02.dmp 1E (c0000005, 804519c7, 00000000, 01bb0eed) nt!ObpLookupObjectName+43e
    Mini031605-01.dmp 0A (00000000, 00000002, 00000001, 8042def4) nt!KeWaitForSingleObject+139
    f2493894 804b8b18 820393cc 00000000 81498d01 nt!KeWaitForSingleObject+0x139
    f24938ec 8042a549 82039330 00000000 00000000 nt!IopMountVolume+0x32
    f2493914 804966e9 f2493c98 82039330 f2493af0 nt!IopCheckVpbMounted+0x4a
    f2493aac 80451a5e 82039330 00000000 f2493b60 nt!IopParseDevice+0x3ee
    f2493b20 80496299 00000000 82095f00 00000040 nt!ObpLookupObjectName+0x4d5
    f2493c30 80497198 00000000 00000000 82092201 nt!ObOpenObjectByName+0xc5
    f2493d04 8049be82 005bf53c 00100001 005bf508 nt!IoCreateFile+0x3ec
    f2493d44 80465b91 005bf53c 00100001 005bf508 nt!NtOpenFile+0x25
    f2493d44 77f85b06 005bf53c 00100001 005bf508 nt!KiSystemService+0xc4
    WARNING: Frame IP not in any known module. Following frames may be wrong.
    005bf4bc 00000000 00000000 00000000 00000000 0x77f85b06
    Mini031705-01.dmp D1 (17459225, 000000ff, 00000000, 8201afdd) nt!KiTrap0E+27c
    Mini031705-02.dmp 1E (c0000005, 804519c7, 00000000, 01bb0966) nt!ObpLookupObjectName+43e
    Mini032105-01.dmp D1 (a273a35c, 00000002, 00000000, bfedd37f) Teefer+337f
    Mini033005-01.dmp 0A (00000000, 00000002, 00000001, 8042def4) nt!KeWaitForSingleObject+139
    Mini033105-01.dmp 0A (00000000, 00000002, 00000001, 8042def4) nt!KeWaitForSingleObject+139
    Mini040105-01.dmp 0A (01bb0b78, 00000002, 00000001, 8042def4) nt!KeWaitForSingleObject+139
    Mini040405-01.dmp 0A (01bb0a7e, 00000002, 00000001, 8042def4) nt!KeWaitForSingleObject+139
    Mini040505-01.dmp 0A (01bb08f9, 00000002, 00000001, 8042def4) nt!KeWaitForSingleObject+139
    Mini040605-01.dmp 0A (42548ad5, 000000ff, 00000000, 8042a4c2) nt!IopCheckDeviceAndDriver+b
  9. jemorse

    jemorse TS Rookie Topic Starter

    Response to IronDuke = I have an older A22p Thinkpad. It does not have the Access Support that I believe you were talking about. However, through this TninkPad's "Access ThinkPad" and the "Service And Support" I did get to IBM's Product Support page and then was directed to their page that provides download support for their "ThinkPad Software Installer" - a new capability first made available on 3/15 this year.

    I downloaded and installed their installer program. Not sure it is working the way they claimed, but, when I allowed it to go to the internet to find and download driver updates, several were downloaded. However, none of them included anything to do with the ATI Display driver mentioned by cpc2004 a couple of posts ago.

    Response to cpc2004's latest post = I checked on the "teefer.sys" you mentioned. It is on my computer because of the Panda Platinum anti-virus/firewall I have installed. Teefer.sys is actually part of SyGate's package which is used by Panda. I should update Panda anyways so hopefully within the next week I will have an opportunity to do the update. I will also be checking with Panda tech support to see what else they can suggest. In reading a PC Magazine review of the Panda 2005 product, a member review had severely downrated the Panda product because of the teefer.sys module causing him problems.

    I have also downloaded the memtest that you recommended and will run this also just as a verification that my RAM is OK (or not).

    I thank everyone that has taken the time to investigate and respond to my problem. I will post again when I have updated/re-installed the Panda product.

  10. IronDuke

    IronDuke TS Rookie Posts: 856

    Interesting John, I just updated my Thinkpad and the only update was for ATI. Everytime I update (every 2 or 3 months) there seems to be something for ATI. It seems with other graphics cards I've had they only get updated for a couple of years.

  11. jemorse

    jemorse TS Rookie Topic Starter


    Could you tell me what website your computer goes to when you check for upgrades???

    Also, what is the vintage of your x24? My A22p is 4+ years old now. Perhaps the updates available for older computers do not include everything....

  12. IronDuke

    IronDuke TS Rookie Posts: 856

    My x24 is just over a year old. Can't say what address is connected to as you just get a progress screen with no other feedback.

    These are versions I have, the A24p is not included on the list of applicable machines for this version. My guess is yours is too old to still be updated.

    ThinkPad Software Installer Version 2.20.0442

    Video Features (Mobility-RADEON) for Windows XP Version

    I assume you went to the link below and entered your model form there:

  13. Daniel

    Daniel TS Rookie

    This is what helped me

    Hi @all,
    Maybe a little late, but the
    STOP 0x0000000A (0x00000000, 0x00000002, 0x00000001, 0x8042DEF4)
    0x8042DEF4 has base at 8040000, DateStamp 4047db83 - ntoskrnl.exe
    error just made me mad some days ago too.
    Happened after installing new Mainboard + Graphic (I took the time completele reeinstalling Windows after that...)
    Drivers all up to date, but also tried older ones - with no effect.
    Checked RAM (Simmcheck and other Hardware)
    But all was fine if I started once in safe mode and rebooted (even if I changed absolutely nothing in Safe mode)

    What finally helped was unchecking the "Load at startup"-Option in my Firewall and putting a link into the Autostart-menu.

    It's always what you least expect, isn't it...

    Maybe this might help for some of you who might experience similar problems.

    Hardware not the best, but enough for me
    ASUS A7......
    AMD 2000+ XP
    512 MB RAM (some OEM)
    GeForce 4 MX 4000 (ok...)
    OS: Win2000 Pro SP4, some Sec.Upds
    O Herr, schmeiss Hirn vom Himmel!
  14. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    When Windows crashes with blue screen, it writes a system event 1001 and a minidump to the folder \windows\minidump. Check system event 1001 and it has the content of the blue screen

    Control Panel -> Adminstrative Tools -> Event Viewer -> System -> Event 1001. Copy the content and paste it back here

    Your symptom is probably related to faulty ram. If you Zip 6 to 7 minidumps and attach the zip files here, I will study the dump and find out the culprit.

    hope it can help you
  15. Daniel

    Daniel TS Rookie

    sorry, no such Event (1001) in minidump don't know why -
    besides it can't be faulty ram, as I said I already replaced the RAM-Plate, but that did'nt solve the Problem

    Thx though
  16. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Bugcheck 0A may be related to software problem such as Zonealarm or it may be caused by faulty ram. Do you find memory.dump at the folder \windows
  17. Daniel

    Daniel TS Rookie

    No dumps, no Memory.dump - just nothing
    You're right though: must have been ZoneAlarm
    Don't bother: seems to work correctly now, since I replaced the startup method in ZoneAlarm

    The cat sat at the mat...
  18. mr_incredible

    mr_incredible TS Rookie

    same problem

    i recently installed windows 2000 with sp2 (upgraded it to sp4 and updated it through microsoft update). specs are as follows:

    amd 1.5
    pc chips mb
    256 ddr 333 ram
    40 gig hdd seagate
    geforce 5200 128 mb

    i've had several bsod's in a short span of time almost all pointing to 0x00000050 error page fault in non paged area ntoskrnl.exe

    i've attached the zipped minidumps for anyone to check.

    now, i've uninstalled ie-spyad, spyware guard and unchecked startup on open office. so far (still to early to tell) no bsod has occured yet though my hopes are not up. still have to stress test my ram but i dont think thats the problem.

    could anyone check out my minidumps and comment?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...