1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Internet problem

By giyad ยท 16 replies
Mar 28, 2007
  1. So I recently built a computer and installed Vista Business Edition as my OS. Everything is working great, and I'm really happy about this PC. For some reason though, a lot of webpages aren't working. I am not sure what the problem is, but I'm having trouble surfing the web. I'm using IE7, but I tried using FireFox as well to make sure it wasn't IE's problem. When I try to visit a lot of websites I get "Internet Explorer cannot display the webpage.

    Most likely causes:
    You are not connected to the Internet.
    The website is encountering problems.
    There might be a typing error in the address. "

    I am not sure what the problem is, and when I try to diagnose this it says that it may be a problem with my ISP, but its definately not because my other computer visits these sites just fine. Does anyone know what this could possibly be?

  2. chamillitarysk8

    chamillitarysk8 TS Booster Posts: 128

    ok hmm it does the same thing in firefox right? also are you using wifi and are you sure your drivers are compatible with vista
  3. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    use run->cmd /k ipconfig /all
    and you will see the gateway and DNS addresses

    the follow this post to prove your TCP settings on VISTA are usable
  4. giyad

    giyad TS Enthusiast Topic Starter Posts: 59

    The drivers are compatible with vista, but its really weird. The thing is that Im on the computer right now, so obviously I am able to connect to the Internet. For some reason though, a bunch of websites don't work. I followed that link and the steps and my TCP settings are fine. I am on a router, but the thing thats even weirder is that when I connect my computer directly to the cable modem, it doesn't work. However, when I connect through the router, it does. Does that make sense to anyone?
  5. McBob

    McBob TS Rookie


    well, you did say ur using a wifi connection,right?
    check to make sure that the server your connecting to doesnt have any sites
    blocked or banned, also just becuase their is no wep security setting on the
    server doesnt allways mean that you can use it anytime,(i found out the hard way)
    and when i say to check to make sure the server your connected to doesnt
    have any blocked sites, check ur own as well,
    if ur connected to a server that u dont have admin rights to, then checking
    the servers blocked sites are out of the question,
    they arnt bad sits, right?
    if so, that could be the problem,
    let me know just how ur wifi config is set to connect, and to whos connection
    and ill see what the possibilities are!!

    Questions and more Email to
  6. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    there are THREE layers here:
    1. the modem connection to the ISP
    2. the router connection to the modem
    3. your browser-email et al programs

    If you look at this post you can test 1-2.
    the ability to translate a URL into the ip-address of the host can be tested
    nslookup token
    where token is some url eg www.google.com OR
    an email domain mail.adelphia.net
    either of these returns a result which is the ip-address
    ping result
    and it should not timeout or produce Host Unreachable

    Your browser or email client perform these actions under the covers and will
    guide you to understanding
    • is my network communicating with my isp?
    • is the browser/email client having problems with a specific site
  7. giyad

    giyad TS Enthusiast Topic Starter Posts: 59

    Actually no, I'm not using a wifi connection. Thats whats weird. I can connect the ethernet cable to the router and then it connects to the Internet, but when I connect directly to the cable modem it doesn't work.
  8. NetCablesPlus

    NetCablesPlus TS Maniac Posts: 228

    Some older modems require an Ethernet Crossover cable instead of the standard straight-through Ethernet Patch cable and that could be why you can connect to the Router and not directly to the modem. On the other hand, you could be using a Crossover cable and the Router may have auto-sensing in which it will make adjustments for using the wrong type of cable while the modem may not be able to do this. However, I do not think that these issues are the likely cause of the overall problems that you are having.
  9. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    likely the modem is config'd as a bridge which requires the router downstream.
    why remove the router -- it provids NAT as a protection feature.
  10. giyad

    giyad TS Enthusiast Topic Starter Posts: 59

    Well... I wasn't removing the router. I just wanted to see whether it was the router causing the problem with those certain sites or if it was something else. Since I couldn't get the Internet to work without the router I couldn't pin-point the problem.
  11. giyad

    giyad TS Enthusiast Topic Starter Posts: 59

    Ok, so I tried pinging www.messengerfx.com and this is what I get "Ping request could not find host www.messengerfx.com. Please check the name and try again." When I perform an nslookup I get But that doesn't work either when I put it in the searchbar. I'm thinking there is a problem with my DNS service... could that be it?
  12. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    for me:
    (1)nslookup for the name returns exactly the same result
    (2)ping by name is ok and
    ping by address is ok too (sure better be if by-name works :) )​

    a web browser doesn't lookup ip address, that's nslookup and DNS's job
    you might use but that sure stinks!
    (btw: this works in FF as does www.messengerfx.com

    and (3), interesting; nslookup uses the same technique to solve
    nslookup www.messengerfx.com as the browser accessing http://www.messengerfx.com/

    My gut reaction would be your browser has been hijacked!

    Follow this topic by Howard
  13. giyad

    giyad TS Enthusiast Topic Starter Posts: 59

    This is really the weirdest thing! I can ping by IP address once I do the lookup, and the IP's usually work when I put them into IE7, but when I try to access by name it doesn't work, I'm sure its a DNS problem. The thing is I tried removing the www. and just trying messengerfx.com it worked! I tried for another website which wasn't working. www.fluffycat.com wouldn't ping, but when I did the nslookup the IP address would ping, so I tried fluffycat.com in the browser and that worked! I'm pretty sure I haven't been hijacked but Im gonna check out that topic... Its got to be a Vista problem.
  14. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    it is related to your browser only, otherwise nslookup would fail too!

    Hijacking the browser is easy, it leaves TCP alone (so nslookup still works)
    and it takes control of your accesses to DNS!

    Get the Hijackthis log and post as an attachment :)
  15. russ

    russ TS Rookie Posts: 39

    You may have your firewall set not to accept these pages or maybe windows vista firewall doesn't allow them to be accessed. Just a thought
  16. giyad

    giyad TS Enthusiast Topic Starter Posts: 59

    I have windows vista firewall off and I have Kaspersky Internet Security installed. To tell you the truth you might be right, because ever since I installed Kaspersky, even with the firewall off I have been having some problems with the program Azureus. It was only ever since I installed Kaspersky. I'm still trying to resolve that, but I think Im just gonna switch to BitDefender.

    Where do I find the Hijackthis log? Also, I'm not sure if its the browser thats the problem because I get the same exact problems with the same pages on FF.
  17. giyad

    giyad TS Enthusiast Topic Starter Posts: 59


    Ok, I guess I created two threads for the same issue without knowing... Anyway, I figured out the problem and it was just that my router didn't fully support Vista... I bought a new router and everything is working fine :)

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...